aboutsummaryrefslogtreecommitdiff
path: root/devel/gettext-lint/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-02-20 16:45:42 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-02-20 16:45:42 +0000
commita80cf883012e7bbc6ac052749de117434d4c3f42 (patch)
tree9bfd00734d135200a8ff2e8fa05f7066e9c76cf8 /devel/gettext-lint/Makefile
parenta1ec5dcc07c512082bbc850be36438a50a9a46c2 (diff)
downloadports-a80cf883012e7bbc6ac052749de117434d4c3f42.tar.gz
ports-a80cf883012e7bbc6ac052749de117434d4c3f42.zip
Notes
Diffstat (limited to 'devel/gettext-lint/Makefile')
-rw-r--r--devel/gettext-lint/Makefile12
1 files changed, 8 insertions, 4 deletions
diff --git a/devel/gettext-lint/Makefile b/devel/gettext-lint/Makefile
index 1f7581730e21..36b1b7590506 100644
--- a/devel/gettext-lint/Makefile
+++ b/devel/gettext-lint/Makefile
@@ -7,9 +7,10 @@
#
PORTNAME= gettext-lint
-PORTVERSION= 0.1.1
+PORTVERSION= 0.3.1
CATEGORIES= devel
-MASTER_SITES= http://mega.ist.utl.pt/~pmmm/gettext-lint/download/
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR=gettext-lint
MAINTAINER= ports@FreeBSD.org
COMMENT= Check the validity and consistency of PO and POT files
@@ -21,8 +22,11 @@ USE_PYTHON= yes
GNU_CONFIGURE= yes
MAKE_ENV= PYTHON_SITELIBDIR=${PYTHON_SITELIBDIR}
+MAN1= POFileConsistency.1 POFileChecker.1 POFileSpell.1 POFileFill.1 \
+ POFileEquiv.1 POFileStatus.1
+
post-patch:
- @${GREP} -lR "/usr/share/gettext-lint" ${WRKSRC} | ${XARGS} \
- ${REINPLACE_CMD} -e "s,/usr/share/gettext-lint,${PYTHON_SITELIBDIR}/gettext-lint,"
+ @${GREP} -lR "@prefix@/share/@PACKAGE@" ${WRKSRC} | ${XARGS} \
+ ${REINPLACE_CMD} -e "s,@prefix@/share/@PACKAGE@,${PYTHON_SITELIBDIR}/@PACKAGE@,"
.include <bsd.port.mk>