aboutsummaryrefslogtreecommitdiff
path: root/devel/gettext/Makefile
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2003-08-25 05:37:53 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2003-08-25 05:37:53 +0000
commita8ed54fcae54603575c22ca70ee23d80c12d819f (patch)
tree06faa3c6cf8b551b726c4f62f3c010ab37c944c2 /devel/gettext/Makefile
parent69b897c40162d747e47b57205cd02919056564e9 (diff)
Update to 0.12.1. This brings a shared lib bump of libintl.so. It is
recommended people use: portupgrade -rf gettext -m BATCH=yes To update this port. Tested by: Thierry Thomas <thierry@pompo.net> myself
Notes
Notes: svn path=/head/; revision=87643
Diffstat (limited to 'devel/gettext/Makefile')
-rw-r--r--devel/gettext/Makefile17
1 files changed, 7 insertions, 10 deletions
diff --git a/devel/gettext/Makefile b/devel/gettext/Makefile
index 66d14229e2cc..20e40d50a8ed 100644
--- a/devel/gettext/Makefile
+++ b/devel/gettext/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= gettext
-PORTVERSION= 0.11.5
-PORTREVISION= 1
+PORTVERSION= 0.12.1
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= gettext
@@ -18,7 +17,7 @@ COMMENT= GNU gettext package
LIB_DEPENDS= iconv.3:${PORTSDIR}/converters/libiconv \
expat.4:${PORTSDIR}/textproc/expat2
-USE_LIBTOOL= yes
+GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= ACLOCAL="${TRUE}" \
AUTOCONF="${TRUE}" \
@@ -27,7 +26,8 @@ CONFIGURE_ENV= ACLOCAL="${TRUE}" \
MAKEINFO="makeinfo --no-split" \
CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
-CONFIGURE_ARGS= --with-libexpat-prefix=${LOCALBASE}/lib
+CONFIGURE_ARGS= --with-libexpat-prefix=${LOCALBASE}/lib \
+ --mandir=${PREFIX}/man
INSTALLS_SHLIB= yes
PLIST_SUB= LOCALBASE=${LOCALBASE} X11BASE=${X11BASE} \
@@ -41,14 +41,11 @@ MAN3= bind_textdomain_codeset.3 bindtextdomain.3 dcgettext.3 \
dcngettext.3 dgettext.3 dngettext.3 gettext.3 ngettext.3 \
textdomain.3
-pre-configure:
- ${RM} ${WRKSRC}/doc/gettext.info*
+INFO= autosprintf gettext
post-install:
- @install-info ${PREFIX}/info/gettext.info ${PREFIX}/info/dir
- ${MKDIR} ${PREFIX}/share/emacs/site-lisp
-.for file in po-compat.el po-mode.el
- ${INSTALL_DATA} ${WRKSRC}/misc/${file} ${PREFIX}/share/emacs/site-lisp
+.for f in po-compat.el po-mode.el
+ ${INSTALL_DATA} ${WRKSRC}/gettext-tools/misc/${f} ${PREFIX}/share/emacs/site-lisp
.endfor
${MKDIR} ${X11BASE}/share/locale