aboutsummaryrefslogtreecommitdiff
path: root/devel/gettext
diff options
context:
space:
mode:
authorTrevor Johnson <trevor@FreeBSD.org>2004-04-03 02:03:27 +0000
committerTrevor Johnson <trevor@FreeBSD.org>2004-04-03 02:03:27 +0000
commitea182a1646b78cdc94559f9f45c36f6745cd2f39 (patch)
tree60c75fb61ed134ff25da350d29c87d452ac4512c /devel/gettext
parent66172f293e8bf648728d1e60e7a4bc3ee6dc3a42 (diff)
downloadports-ea182a1646b78cdc94559f9f45c36f6745cd2f39.tar.gz
ports-ea182a1646b78cdc94559f9f45c36f6745cd2f39.zip
Notes
Diffstat (limited to 'devel/gettext')
-rw-r--r--devel/gettext/Makefile14
1 files changed, 9 insertions, 5 deletions
diff --git a/devel/gettext/Makefile b/devel/gettext/Makefile
index 068612dd8e3c..26d4dba7a7be 100644
--- a/devel/gettext/Makefile
+++ b/devel/gettext/Makefile
@@ -33,6 +33,7 @@ INSTALLS_SHLIB= yes
OPTIONS= EXAMPLES "install example files" off
PLIST= ${WRKDIR}/plist
+PLISTU= ${WRKDIR}/plist-unsorted
PLIST_SUB= LOCALBASE=${LOCALBASE} X11BASE=${X11BASE} \
VERSION=${PORTVERSION}
@@ -71,18 +72,21 @@ post-build:
.endif
pre-install:
- @${RM} -f ${PLIST}
+ @${RM} -f ${PLISTU}
+ @${TOUCH} ${PLISTU}
.if defined (WITH_EXAMPLES)
cd ${WRKSRC}/gettext-tools && \
${FIND} -s examples -type f | ${GREP} -vw examples/po | \
${GREP} -v ChangeLog | ${GREP} -v examples/Makefile | \
${GREP} -v examples/installpaths.in | \
- ${SED} 's:^:share/doc/gettext/:' > ${PLIST} && \
+ ${SED} 's:^:share/doc/gettext/:' > ${PLISTU} && \
${FIND} -d examples -type d | ${GREP} -v examples/po | \
- ${SED} -e 's:^:@dirrm share/doc/gettext/:' \
- >> ${PLIST}
+ ${GREP} / | ${SED} -e 's:^:@dirrm share/doc/gettext/:' \
+ >> ${PLISTU}
.endif
- @${CAT} ${.CURDIR}/pkg-plist >> ${PLIST}
+ @${CAT} ${.CURDIR}/pkg-plist ${PLISTU} | ${GREP} -v ^@ > ${PLIST}
+ @${SORT} -r ${.CURDIR}/pkg-plist ${PLISTU} | ${GREP} ^@dirrm >> ${PLIST}
+ @${GREP} -h ^@ ${.CURDIR}/pkg-plist ${PLISTU} | ${GREP} exec >> ${PLIST}
post-install:
.for f in po-compat.el po-mode.el