aboutsummaryrefslogtreecommitdiff
path: root/devel/gettext
diff options
context:
space:
mode:
authorAde Lovett <ade@FreeBSD.org>2008-06-06 02:36:00 +0000
committerAde Lovett <ade@FreeBSD.org>2008-06-06 02:36:00 +0000
commitee3857ac876456535c09c83cc89dfe0ee26d65d3 (patch)
tree0e3dac7597fb30f7eead17a469abb423969a5545 /devel/gettext
parent8240e363240c33109677d2fdd36d19b65efa766d (diff)
downloadports-ee3857ac876456535c09c83cc89dfe0ee26d65d3.tar.gz
ports-ee3857ac876456535c09c83cc89dfe0ee26d65d3.zip
Notes
Diffstat (limited to 'devel/gettext')
-rw-r--r--devel/gettext/Makefile10
-rw-r--r--devel/gettext/distinfo6
-rw-r--r--devel/gettext/files/patch-gettext-runtime_intl_Makefile.in16
-rw-r--r--devel/gettext/files/patch-gettext-tools_Makefile.in10
-rw-r--r--devel/gettext/pkg-plist49
5 files changed, 36 insertions, 55 deletions
diff --git a/devel/gettext/Makefile b/devel/gettext/Makefile
index 57d1c2c79f1c..699f3bdb243d 100644
--- a/devel/gettext/Makefile
+++ b/devel/gettext/Makefile
@@ -6,8 +6,8 @@
#
PORTNAME= gettext
-PORTVERSION= 0.16.1
-PORTREVISION= 3
+PORTVERSION= 0.17
+PORTREVISION= 0
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= gettext
@@ -33,10 +33,10 @@ USE_LDCONFIG= yes
PLIST_SUB= VERSION=${PORTVERSION}
-MAN1= autopoint.1 gettext.1 gettextize.1 msgattrib.1 msgcat.1 \
- msgcmp.1 msgcomm.1 msgconv.1 msgen.1 msgexec.1 \
+MAN1= autopoint.1 envsubst.1 gettext.1 gettextize.1 msgattrib.1 \
+ msgcat.1 msgcmp.1 msgcomm.1 msgconv.1 msgen.1 msgexec.1 \
msgfilter.1 msgfmt.1 msggrep.1 msginit.1 msgmerge.1 \
- msgunfmt.1 msguniq.1 ngettext.1 xgettext.1 envsubst.1
+ msgunfmt.1 msguniq.1 ngettext.1 recode-sr-latin.1 xgettext.1
MAN3= bind_textdomain_codeset.3 bindtextdomain.3 dcgettext.3 \
dcngettext.3 dgettext.3 dngettext.3 gettext.3 ngettext.3 \
textdomain.3
diff --git a/devel/gettext/distinfo b/devel/gettext/distinfo
index e24a57ca77c1..ebbb9721833a 100644
--- a/devel/gettext/distinfo
+++ b/devel/gettext/distinfo
@@ -1,3 +1,3 @@
-MD5 (gettext-0.16.1.tar.gz) = 3d9ad24301c6d6b17ec30704a13fe127
-SHA256 (gettext-0.16.1.tar.gz) = 0bf850d1a079fb5a61f0a47b1a9efd35eb44032255375e1cedb0253bc27b376d
-SIZE (gettext-0.16.1.tar.gz) = 8539634
+MD5 (gettext-0.17.tar.gz) = 58a2bc6d39c0ba57823034d55d65d606
+SHA256 (gettext-0.17.tar.gz) = 209638bb8e162f22c281145a34e220c66f1f6e9ff5e4c50c6f2ef2ded59537ba
+SIZE (gettext-0.17.tar.gz) = 11640890
diff --git a/devel/gettext/files/patch-gettext-runtime_intl_Makefile.in b/devel/gettext/files/patch-gettext-runtime_intl_Makefile.in
index 48a26872a4ad..823552253a8b 100644
--- a/devel/gettext/files/patch-gettext-runtime_intl_Makefile.in
+++ b/devel/gettext/files/patch-gettext-runtime_intl_Makefile.in
@@ -1,16 +1,16 @@
---- gettext-runtime/intl/Makefile.in.orig Mon Nov 27 09:02:00 2006
-+++ gettext-runtime/intl/Makefile.in Sun Dec 3 17:48:38 2006
-@@ -78,3 +78,3 @@
+--- gettext-runtime/intl/Makefile.in.orig 2007-11-04 21:21:12.000000000 +0000
++++ gettext-runtime/intl/Makefile.in 2007-12-12 03:28:44.000000000 +0000
+@@ -79,3 +79,3 @@
DEFS = -DLOCALEDIR=\"$(localedir)\" -DLOCALE_ALIAS_PATH=\"$(aliaspath)\" \
--DLIBDIR=\"$(libdir)\" -DBUILDING_LIBINTL -DBUILDING_DLL -DIN_LIBINTL \
+-DLIBDIR=\"$(prefix)/libdata\" -DBUILDING_LIBINTL -DBUILDING_DLL -DIN_LIBINTL \
-DENABLE_RELOCATABLE=1 -DIN_LIBRARY -DINSTALLDIR=\"$(libdir)\" -DNO_XMALLOC \
-@@ -191,3 +191,3 @@
+@@ -195,3 +195,3 @@
$(CC) $(CPPFLAGS) $(CFLAGS) $(XCFLAGS) $(LDFLAGS) -o $@ \
-- $(OBJECTS) @LTLIBICONV@ @INTL_MACOSX_LIBS@ $(LIBS) @LTLIBTHREAD@ -lc \
+- $(OBJECTS) @LTLIBICONV@ @INTL_MACOSX_LIBS@ $(LIBS) @LTLIBTHREAD@ @LTLIBC@ \
+ $(OBJECTS) @LTLIBICONV@ @INTL_MACOSX_LIBS@ $(LIBS) @LTLIBTHREAD@ \
- -version-info $(LTV_CURRENT):$(LTV_REVISION):$(LTV_AGE) \
-@@ -346,18 +346,2 @@
+ $(OBJECTS_RES_@WOE32@) \
+@@ -369,18 +369,2 @@
if test '@USE_INCLUDED_LIBINTL@' = yes; then \
- test @GLIBC21@ != no || $(mkdir_p) $(DESTDIR)$(libdir); \
- temp=$(DESTDIR)$(libdir)/t-charset.alias; \
@@ -29,7 +29,7 @@
- fi; \
- fi; \
$(mkdir_p) $(DESTDIR)$(localedir); \
-@@ -447,5 +431,5 @@
+@@ -472,5 +456,5 @@
if test '@USE_INCLUDED_LIBINTL@' = yes; then \
- if test -f $(DESTDIR)$(libdir)/charset.alias; then \
- temp=$(DESTDIR)$(libdir)/t-charset.alias; \
diff --git a/devel/gettext/files/patch-gettext-tools_Makefile.in b/devel/gettext/files/patch-gettext-tools_Makefile.in
index e96c41c38209..73174661ba6f 100644
--- a/devel/gettext/files/patch-gettext-tools_Makefile.in
+++ b/devel/gettext/files/patch-gettext-tools_Makefile.in
@@ -1,7 +1,7 @@
---- gettext-tools/Makefile.in.orig Mon Nov 27 09:34:56 2006
-+++ gettext-tools/Makefile.in Sun Dec 3 17:50:43 2006
-@@ -486,3 +486,3 @@
+--- gettext-tools/Makefile.in.orig 2007-11-06 23:40:19.000000000 +0000
++++ gettext-tools/Makefile.in 2007-12-12 03:30:36.000000000 +0000
+@@ -726,3 +726,3 @@
ACLOCAL_AMFLAGS = -I m4 -I ../gettext-runtime/m4 -I ../autoconf-lib-link/m4 -I ../m4 -I gnulib-m4 -I libgettextpo/gnulib-m4
--SUBDIRS = doc intl gnulib-lib libgrep libuniname src libgettextpo po projects misc man m4 tests examples
-+SUBDIRS = doc intl gnulib-lib libgrep libuniname src libgettextpo po projects misc man m4
+-SUBDIRS = doc intl gnulib-lib libgrep src libgettextpo po projects styles misc man m4 tests gnulib-tests examples
++SUBDIRS = doc intl gnulib-lib libgrep src libgettextpo po projects styles misc man m4
diff --git a/devel/gettext/pkg-plist b/devel/gettext/pkg-plist
index ef9a2969d298..6283b5e11a1b 100644
--- a/devel/gettext/pkg-plist
+++ b/devel/gettext/pkg-plist
@@ -36,7 +36,7 @@ lib/libgettextlib.so
lib/libgettextpo.a
lib/libgettextpo.la
lib/libgettextpo.so
-lib/libgettextpo.so.3
+lib/libgettextpo.so.4
lib/libgettextsrc.la
lib/libgettextsrc-%%VERSION%%.so
lib/libgettextsrc.so
@@ -56,6 +56,7 @@ share/aclocal/iconv.m4
share/aclocal/intdiv0.m4
share/aclocal/intl.m4
share/aclocal/intldir.m4
+share/aclocal/intlmacosx.m4
share/aclocal/intmax.m4
share/aclocal/inttypes-pri.m4
share/aclocal/inttypes_h.m4
@@ -64,7 +65,6 @@ share/aclocal/lib-ld.m4
share/aclocal/lib-link.m4
share/aclocal/lib-prefix.m4
share/aclocal/lock.m4
-share/aclocal/longdouble.m4
share/aclocal/longlong.m4
share/aclocal/nls.m4
share/aclocal/po.m4
@@ -73,7 +73,6 @@ share/aclocal/progtest.m4
share/aclocal/size_max.m4
share/aclocal/stdint_h.m4
share/aclocal/uintmax_t.m4
-share/aclocal/ulonglong.m4
share/aclocal/visibility.m4
share/aclocal/wchar_t.m4
share/aclocal/wint_t.m4
@@ -122,33 +121,6 @@ share/aclocal/xsize.m4
%%PORTDOCS%%%%DOCSDIR%%/gettext_25.html
%%PORTDOCS%%%%DOCSDIR%%/gettext_foot.html
%%PORTDOCS%%%%DOCSDIR%%/gettext_toc.html
-%%PORTDOCS%%%%DOCSDIR%%/javadoc1/AllNames.html
-%%PORTDOCS%%%%DOCSDIR%%/javadoc1/gnu.gettext.GettextResource.html
-%%PORTDOCS%%%%DOCSDIR%%/javadoc1/images/blue-ball-small.gif
-%%PORTDOCS%%%%DOCSDIR%%/javadoc1/images/blue-ball.gif
-%%PORTDOCS%%%%DOCSDIR%%/javadoc1/images/class-index.gif
-%%PORTDOCS%%%%DOCSDIR%%/javadoc1/images/constructor-index.gif
-%%PORTDOCS%%%%DOCSDIR%%/javadoc1/images/constructors.gif
-%%PORTDOCS%%%%DOCSDIR%%/javadoc1/images/cyan-ball-small.gif
-%%PORTDOCS%%%%DOCSDIR%%/javadoc1/images/cyan-ball.gif
-%%PORTDOCS%%%%DOCSDIR%%/javadoc1/images/error-index.gif
-%%PORTDOCS%%%%DOCSDIR%%/javadoc1/images/exception-index.gif
-%%PORTDOCS%%%%DOCSDIR%%/javadoc1/images/green-ball-small.gif
-%%PORTDOCS%%%%DOCSDIR%%/javadoc1/images/green-ball.gif
-%%PORTDOCS%%%%DOCSDIR%%/javadoc1/images/interface-index.gif
-%%PORTDOCS%%%%DOCSDIR%%/javadoc1/images/magenta-ball-small.gif
-%%PORTDOCS%%%%DOCSDIR%%/javadoc1/images/magenta-ball.gif
-%%PORTDOCS%%%%DOCSDIR%%/javadoc1/images/method-index.gif
-%%PORTDOCS%%%%DOCSDIR%%/javadoc1/images/methods.gif
-%%PORTDOCS%%%%DOCSDIR%%/javadoc1/images/package-index.gif
-%%PORTDOCS%%%%DOCSDIR%%/javadoc1/images/red-ball-small.gif
-%%PORTDOCS%%%%DOCSDIR%%/javadoc1/images/red-ball.gif
-%%PORTDOCS%%%%DOCSDIR%%/javadoc1/images/variable-index.gif
-%%PORTDOCS%%%%DOCSDIR%%/javadoc1/images/variables.gif
-%%PORTDOCS%%%%DOCSDIR%%/javadoc1/images/yellow-ball-small.gif
-%%PORTDOCS%%%%DOCSDIR%%/javadoc1/images/yellow-ball.gif
-%%PORTDOCS%%%%DOCSDIR%%/javadoc1/packages.html
-%%PORTDOCS%%%%DOCSDIR%%/javadoc1/tree.html
%%PORTDOCS%%%%DOCSDIR%%/javadoc2/allclasses-frame.html
%%PORTDOCS%%%%DOCSDIR%%/javadoc2/deprecated-list.html
%%PORTDOCS%%%%DOCSDIR%%/javadoc2/gnu/gettext/GettextResource.html
@@ -197,6 +169,7 @@ share/emacs/site-lisp/po-mode.el
%%DATADIR%%/intl/l10nflist.c
%%DATADIR%%/intl/langprefs.c
%%DATADIR%%/intl/libgnuintl.h.in
+%%DATADIR%%/intl/libintl.rc
%%DATADIR%%/intl/loadinfo.h
%%DATADIR%%/intl/loadmsgcat.c
%%DATADIR%%/intl/localcharset.c
@@ -225,6 +198,8 @@ share/emacs/site-lisp/po-mode.el
%%DATADIR%%/intl/relocatable.c
%%DATADIR%%/intl/relocatable.h
%%DATADIR%%/intl/textdomain.c
+%%DATADIR%%/intl/tsearch.c
+%%DATADIR%%/intl/tsearch.h
%%DATADIR%%/intl/vasnprintf.c
%%DATADIR%%/intl/vasnprintf.h
%%DATADIR%%/intl/vasnwprintf.h
@@ -256,6 +231,12 @@ share/emacs/site-lisp/po-mode.el
%%DATADIR%%/projects/TP/trigger
%%DATADIR%%/projects/index
%%DATADIR%%/projects/team-address
+%%DATADIR%%/styles/po-default.css
+%%DATADIR%%/styles/po-emacs-x.css
+%%DATADIR%%/styles/po-emacs-xterm.css
+%%DATADIR%%/styles/po-emacs-xterm16.css
+%%DATADIR%%/styles/po-emacs-xterm256.css
+%%DATADIR%%/styles/po-vim.css
share/locale/be/LC_MESSAGES/gettext-runtime.mo
share/locale/be/LC_MESSAGES/gettext-tools.mo
share/locale/ca/LC_MESSAGES/gettext-runtime.mo
@@ -277,6 +258,7 @@ share/locale/es/LC_MESSAGES/gettext-runtime.mo
share/locale/es/LC_MESSAGES/gettext-tools.mo
share/locale/et/LC_MESSAGES/gettext-runtime.mo
share/locale/et/LC_MESSAGES/gettext-tools.mo
+share/locale/eu/LC_MESSAGES/gettext-tools.mo
share/locale/fi/LC_MESSAGES/gettext-runtime.mo
share/locale/fi/LC_MESSAGES/gettext-tools.mo
share/locale/fr/LC_MESSAGES/gettext-runtime.mo
@@ -293,12 +275,12 @@ share/locale/ja/LC_MESSAGES/gettext-tools.mo
share/locale/ko/LC_MESSAGES/gettext-runtime.mo
share/locale/ko/LC_MESSAGES/gettext-tools.mo
share/locale/locale.alias
+share/locale/nb/LC_MESSAGES/gettext-runtime.mo
+share/locale/nb/LC_MESSAGES/gettext-tools.mo
share/locale/nl/LC_MESSAGES/gettext-runtime.mo
share/locale/nl/LC_MESSAGES/gettext-tools.mo
share/locale/nn/LC_MESSAGES/gettext-runtime.mo
share/locale/nn/LC_MESSAGES/gettext-tools.mo
-share/locale/no/LC_MESSAGES/gettext-runtime.mo
-share/locale/no/LC_MESSAGES/gettext-tools.mo
share/locale/pl/LC_MESSAGES/gettext-runtime.mo
share/locale/pl/LC_MESSAGES/gettext-tools.mo
share/locale/pt/LC_MESSAGES/gettext-runtime.mo
@@ -328,6 +310,7 @@ share/locale/zh_CN/LC_MESSAGES/gettext-tools.mo
share/locale/zh_HK/LC_MESSAGES/gettext-runtime.mo
share/locale/zh_TW/LC_MESSAGES/gettext-runtime.mo
share/locale/zh_TW/LC_MESSAGES/gettext-tools.mo
+@dirrm %%DATADIR%%/styles
@dirrm %%DATADIR%%/projects/TP
@dirrm %%DATADIR%%/projects/KDE
@dirrm %%DATADIR%%/projects/GNOME
@@ -339,8 +322,6 @@ share/locale/zh_TW/LC_MESSAGES/gettext-tools.mo
%%PORTDOCS%%@dirrm %%DOCSDIR%%/javadoc2/gnu/gettext
%%PORTDOCS%%@dirrm %%DOCSDIR%%/javadoc2/gnu
%%PORTDOCS%%@dirrm %%DOCSDIR%%/javadoc2
-%%PORTDOCS%%@dirrm %%DOCSDIR%%/javadoc1/images
-%%PORTDOCS%%@dirrm %%DOCSDIR%%/javadoc1
%%PORTDOCS%%@dirrm %%DOCSDIR%%/examples/build-aux
%%PORTDOCS%%@dirrm %%DOCSDIR%%/examples
%%PORTDOCS%%@dirrm %%DOCSDIR%%/csharpdoc