aboutsummaryrefslogtreecommitdiff
path: root/devel/gflags
diff options
context:
space:
mode:
authorYen-Ming Lee <leeym@FreeBSD.org>2006-12-19 07:28:37 +0000
committerYen-Ming Lee <leeym@FreeBSD.org>2006-12-19 07:28:37 +0000
commit9bf5a669ab6d81426c69fedef04fe02a92a4f106 (patch)
treef140570cb6cd1c696e38fc593970ffa6609e87a0 /devel/gflags
parent0ce5ab7b9a986cba34cea28b82b4a774b9764130 (diff)
downloadports-9bf5a669ab6d81426c69fedef04fe02a92a4f106.tar.gz
ports-9bf5a669ab6d81426c69fedef04fe02a92a4f106.zip
Notes
Diffstat (limited to 'devel/gflags')
-rw-r--r--devel/gflags/Makefile33
-rw-r--r--devel/gflags/distinfo3
-rw-r--r--devel/gflags/pkg-descr9
-rw-r--r--devel/gflags/pkg-plist6
4 files changed, 51 insertions, 0 deletions
diff --git a/devel/gflags/Makefile b/devel/gflags/Makefile
new file mode 100644
index 000000000000..738d5cfba669
--- /dev/null
+++ b/devel/gflags/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: gflags
+# Date created: 19 December 2006
+# Whom: Yen-Ming Lee <leeym@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gflags
+PORTVERSION= 0.1
+CATEGORIES= devel
+MASTER_SITES= http://google-gflags.googlecode.com/files/
+
+MAINTAINER= leeym@FreeBSD.org
+COMMENT= Commandline flags module for C++
+
+USE_LDCONFIG= yes
+GNU_CONFIGURE= yes
+
+PORTDOCS= AUTHORS COPYING ChangeLog INSTALL NEWS README gflags.html
+
+post-patch:
+ ${REINPLACE_CMD} -e 's|^docdir.*|docdir = ${DOCSDIR}|' ${WRKSRC}/Makefile.in
+.if defined(NOPORTDOCS)
+ ${REINPLACE_CMD} -e '/^install/s/ install-dist_docDATA//' ${WRKSRC}/Makefile.in
+.endif
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+BROKEN= Do not compile
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/gflags/distinfo b/devel/gflags/distinfo
new file mode 100644
index 000000000000..fffa2313305e
--- /dev/null
+++ b/devel/gflags/distinfo
@@ -0,0 +1,3 @@
+MD5 (gflags-0.1.tar.gz) = 7c54095fdc8a5a0efad209e619d5aa2c
+SHA256 (gflags-0.1.tar.gz) = a2dd3ca9cdc50e98e3230bd9a0c92c0aae9ecd71513613acfa1104c3790849fd
+SIZE (gflags-0.1.tar.gz) = 387517
diff --git a/devel/gflags/pkg-descr b/devel/gflags/pkg-descr
new file mode 100644
index 000000000000..48779c916f27
--- /dev/null
+++ b/devel/gflags/pkg-descr
@@ -0,0 +1,9 @@
+google-gflags
+Commandline flags module for C++
+
+The gflags package contains a library that implements commandline flags
+processing. As such it's a replacement for getopt(). It has increased
+flexibility, including built-in support for C++ types like string, and the
+ability to define flags in the source file in which they're used.
+
+WWW: http://code.google.com/p/google-gflags/
diff --git a/devel/gflags/pkg-plist b/devel/gflags/pkg-plist
new file mode 100644
index 000000000000..1c77442b1d2b
--- /dev/null
+++ b/devel/gflags/pkg-plist
@@ -0,0 +1,6 @@
+include/google/gflags.h
+lib/libgflags.a
+lib/libgflags.la
+lib/libgflags.so
+lib/libgflags.so.0
+@dirrm include/google