aboutsummaryrefslogtreecommitdiff
path: root/devel/gide/Makefile
diff options
context:
space:
mode:
authorChris D. Faulhaber <jedgar@FreeBSD.org>2000-02-29 03:04:32 +0000
committerChris D. Faulhaber <jedgar@FreeBSD.org>2000-02-29 03:04:32 +0000
commitc7ebf682d0c919c23fc99f62e49f8917a9d85707 (patch)
treeb4d0a407a3b868a38f0b55ef7350680265b274e1 /devel/gide/Makefile
parent804abed2515e5ad4f9bc165b1fdb0ab27baab0cf (diff)
downloadports-c7ebf682d0c919c23fc99f62e49f8917a9d85707.tar.gz
ports-c7ebf682d0c919c23fc99f62e49f8917a9d85707.zip
Notes
Diffstat (limited to 'devel/gide/Makefile')
-rw-r--r--devel/gide/Makefile22
1 files changed, 12 insertions, 10 deletions
diff --git a/devel/gide/Makefile b/devel/gide/Makefile
index 8404cf34e661..66c2e3b2b922 100644
--- a/devel/gide/Makefile
+++ b/devel/gide/Makefile
@@ -1,15 +1,16 @@
# New ports collection makefile for: gIDE
-# Version required: 0.1.6
+# Version required: 0.1.7
# Date created: 29 Jul 1998
# Whom: rom
#
# $FreeBSD$
#
-DISTNAME= gIDE-0.1.6
-PKGNAME= gide-0.1.6
+DISTNAME= gIDE-0.1.7
+PKGNAME= gide-0.1.7
CATEGORIES= devel gnome
-MASTER_SITES= ${MASTER_SITE_GNOME}
+MASTER_SITES= ${MASTER_SITE_GNOME} \
+ http://gide.pn.org/
MASTER_SITE_SUBDIR= unstable/sources/gIDE
MAINTAINER= ports@FreeBSD.org
@@ -24,15 +25,16 @@ USE_GMAKE= yes
USE_LIBTOOL= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
GTK_CONFIG="${GTK_CONFIG}" \
- LIBS="-L${LOCALBASE}/lib"
-CONFIGURE_ARGS= --localstatedir=${PREFIX}/share/gnome \
- --datadir=${PREFIX}/share/gnome \
- --with-gnome=${PREFIX}
+ LIBS="-L${LOCALBASE}/lib -lgnuregex"
+CONFIGURE_ARGS= --with-gnome=${PREFIX}
MAN1= gide.1 gdbio.1
+VERSION= ${DISTNAME:S/gIDE-//}
+PLIST_SUB= VERSION=${VERSION}
+
post-patch:
- @${PERL} -pi -e 's|%%LOCALBASE%%|${LOCALBASE}|g' ${WRKSRC}/src/*.c
- @${PERL} -pi -e 's|%%X11BASE%%|${X11BASE}|g' ${WRKSRC}/src/*.c
+ @${PERL} -pi -e "s|%%LOCALBASE%%|${LOCALBASE}|g" ${WRKSRC}/src/*.c
+ @${PERL} -pi -e "s|%%X11BASE%%|${X11BASE}|g" ${WRKSRC}/src/*.c
.include <bsd.port.mk>