aboutsummaryrefslogtreecommitdiff
path: root/devel/gindent
diff options
context:
space:
mode:
authorJohan van Selst <johans@FreeBSD.org>2013-11-04 07:30:34 +0000
committerJohan van Selst <johans@FreeBSD.org>2013-11-04 07:30:34 +0000
commitc6f42c9aef0a0fea034b368ef82b2a99d29fce0b (patch)
treeaed23439404e67f22e269b1247593e97c6c1021c /devel/gindent
parentf674dd0388b2cdb97cc8e4aec1f3bf5c0719b50c (diff)
downloadports-c6f42c9aef0a0fea034b368ef82b2a99d29fce0b.tar.gz
ports-c6f42c9aef0a0fea034b368ef82b2a99d29fce0b.zip
Notes
Diffstat (limited to 'devel/gindent')
-rw-r--r--devel/gindent/Makefile10
-rw-r--r--devel/gindent/files/patch-ab11
-rw-r--r--devel/gindent/files/patch-args.c20
-rw-r--r--devel/gindent/files/patch-doc:Makefile.in4
-rw-r--r--devel/gindent/files/patch-indent.h4
-rw-r--r--devel/gindent/pkg-plist1
6 files changed, 19 insertions, 31 deletions
diff --git a/devel/gindent/Makefile b/devel/gindent/Makefile
index a384bd3fec45..5e91e0da33bd 100644
--- a/devel/gindent/Makefile
+++ b/devel/gindent/Makefile
@@ -3,7 +3,7 @@
PORTNAME= gindent
PORTVERSION= 2.2.10
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= indent
@@ -18,7 +18,6 @@ LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ARGS= --program-prefix=g
MAKE_JOBS_UNSAFE= yes
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MNLS}
@@ -29,7 +28,6 @@ CONFIGURE_ARGS+=--disable-nls
PLIST_SUB+= NLS="@comment "
.endif
-MAN1= gindent.1
INFO= indent
.include <bsd.port.pre.mk>
@@ -39,9 +37,9 @@ post-patch:
's|malloc\.h|stdlib.h|g'
post-install:
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/doc/indent.html ${DOCSDIR}
+.if ${PORT_OPTIONS:MDOCS}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/indent.html ${STAGEDIR}${DOCSDIR}
.endif
.include <bsd.port.post.mk>
diff --git a/devel/gindent/files/patch-ab b/devel/gindent/files/patch-ab
deleted file mode 100644
index 63642a8ad7f5..000000000000
--- a/devel/gindent/files/patch-ab
+++ /dev/null
@@ -1,11 +0,0 @@
---- doc/indent.texinfo.orig 2008-03-11 19:50:42.000000000 +0100
-+++ doc/indent.texinfo 2010-06-27 16:29:17.000000000 +0200
-@@ -13,7 +13,7 @@
-
- @dircategory Indent Code Formatter
- @direntry
--* Indent: (indent). C code formatter.
-+* GNU indent: (indent). C code formatter.
- @end direntry
-
-
diff --git a/devel/gindent/files/patch-args.c b/devel/gindent/files/patch-args.c
index 81fc4266598b..a54f169b53c1 100644
--- a/devel/gindent/files/patch-args.c
+++ b/devel/gindent/files/patch-args.c
@@ -1,6 +1,6 @@
--- src/args.c.orig 2008-03-11 19:50:42.000000000 +0100
-+++ src/args.c 2010-06-27 16:29:54.000000000 +0200
-@@ -163,6 +163,7 @@
++++ src/args.c 2013-11-04 07:16:35.000000000 +0100
+@@ -163,6 +163,7 @@ static int exp_hnl = 0;
static int exp_i = 0;
static int exp_il = 0;
static int exp_ip = 0;
@@ -8,7 +8,7 @@
static int exp_kr = 0;
static int exp_l = 0;
static int exp_lc = 0;
-@@ -237,6 +238,30 @@
+@@ -237,6 +238,30 @@ typedef struct
static void usage (void);
@@ -39,7 +39,7 @@
#ifdef BERKELEY_DEFAULTS
/**
-@@ -264,63 +289,66 @@
+@@ -264,63 +289,66 @@ const pro_ty pro[] =
#endif
{"pi", PRO_INT, -1, ONOFF_NA, &settings.paren_indent, &exp_pi},
{"pcs", PRO_BOOL, false, ON, &settings.proc_calls_space, &exp_pcs},
@@ -113,8 +113,8 @@
+/* This is now the default. */
+ KNF_PRO_SETTINGS,
+ {"ip", PRO_INT, 8, ONOFF_NA, &settings.indent_parameters, &exp_ip},
-+ {"i", PRO_INT, 8, ONOFF_NA, &settings.ind_size, &exp_i},
{"il", PRO_INT, DEFAULT_LABEL_INDENT, ONOFF_NA, &settings.label_offset, &exp_il},
++ {"i", PRO_INT, 8, ONOFF_NA, &settings.ind_size, &exp_i},
{"hnl", PRO_BOOL, true, ON, &settings.honour_newlines, &exp_hnl},
{"h", PRO_FUNCTION, 0, ONOFF_NA, (int *) usage, &exp_version},
- {"gnu", PRO_SETTINGS, 0, ONOFF_NA, GNU_SETTINGS_STRING, &exp_gnu},
@@ -133,7 +133,7 @@
{"cp", PRO_INT, 33, ONOFF_NA, &settings.else_endif_col, &exp_cp},
{"cli", PRO_INT, 0, ONOFF_NA, &settings.case_indent, &exp_cli},
{"ci", PRO_INT, 4, ONOFF_NA, &settings.continuation_indent, &exp_ci},
-@@ -341,12 +369,12 @@
+@@ -341,12 +369,12 @@ const pro_ty pro[] =
{"bl", PRO_BOOL, true, OFF, &settings.btype_2, &exp_bl},
{"bfda", PRO_BOOL, false, ON, &settings.break_function_decl_args, &exp_bfda},
{"bfde", PRO_BOOL, false, ON, &settings.break_function_decl_args_end, &exp_bfde},
@@ -150,7 +150,7 @@
{"bacc", PRO_BOOL, false, ON, &settings.blanklines_around_conditional_compilation, &exp_bacc},
{"T", PRO_KEY, 0, ONOFF_NA, 0, &exp_T},
{"ppi", PRO_INT, 0, ONOFF_NA, &settings.force_preproc_width, &exp_ppi},
-@@ -381,7 +409,7 @@
+@@ -381,7 +409,7 @@ const pro_ty pro[] =
#endif
{"pi", PRO_INT, -1, ONOFF_NA, &settings.paren_indent, &exp_pi},
{"pcs", PRO_BOOL, true, ON, &settings.proc_calls_space, &exp_pcs},
@@ -159,7 +159,7 @@
{"o", PRO_BOOL, false, ON, &settings.expect_output_file, &exp_o},
{"nv", PRO_BOOL, false, OFF, &settings.verbose, &exp_v},
{"nut", PRO_BOOL, true, OFF, &settings.use_tabs, &exp_ut},
-@@ -425,14 +453,15 @@
+@@ -425,14 +453,15 @@ const pro_ty pro[] =
{"lp", PRO_BOOL, true, ON, &settings.lineup_to_parens, &exp_lp},
{"lc", PRO_INT, DEFAULT_RIGHT_COMMENT_MARGIN, ONOFF_NA, &settings.comment_max_col, &exp_lc},
{"l", PRO_INT, DEFAULT_RIGHT_MARGIN, ONOFF_NA, &settings.max_col, &exp_l},
@@ -177,7 +177,7 @@
{"fca", PRO_BOOL, false, ON, &settings.format_comments, &exp_fca},
{"fc1", PRO_BOOL, false, ON, &settings.format_col1_comments, &exp_fc1},
{"eei", PRO_BOOL, false, ON, &settings.extra_expression_indent, &exp_eei},
-@@ -593,6 +622,9 @@
+@@ -593,6 +622,9 @@ const long_option_conversion_ty option_c
{"blank-lines-after-declarations", "bad"},
{"blank-lines-after-commas", "bc"},
{"blank-before-sizeof", "bs"},
@@ -187,7 +187,7 @@
{"berkeley-style", "orig"},
{"berkeley", "orig"},
{"Bill-Shannon", "bs"},
-@@ -798,7 +830,7 @@
+@@ -798,7 +830,7 @@ extern int set_option(
if (!found)
{
diff --git a/devel/gindent/files/patch-doc:Makefile.in b/devel/gindent/files/patch-doc:Makefile.in
index fe00ee8130c5..810e924349ae 100644
--- a/devel/gindent/files/patch-doc:Makefile.in
+++ b/devel/gindent/files/patch-doc:Makefile.in
@@ -1,6 +1,6 @@
--- doc/Makefile.in.orig 2008-03-11 19:54:15.000000000 +0100
-+++ doc/Makefile.in 2010-06-27 16:29:17.000000000 +0200
-@@ -602,10 +602,10 @@
++++ doc/Makefile.in 2013-11-04 06:57:00.000000000 +0100
+@@ -602,10 +602,10 @@ uninstall-am: uninstall-dvi-am uninstall
uninstall-pdf-am uninstall-ps-am
diff --git a/devel/gindent/files/patch-indent.h b/devel/gindent/files/patch-indent.h
index 50a47d49475f..ad8de6cea422 100644
--- a/devel/gindent/files/patch-indent.h
+++ b/devel/gindent/files/patch-indent.h
@@ -1,6 +1,6 @@
--- src/indent.h.orig 2008-03-11 19:50:42.000000000 +0100
-+++ src/indent.h 2010-06-27 16:29:17.000000000 +0200
-@@ -135,9 +135,9 @@
++++ src/indent.h 2013-11-04 06:57:00.000000000 +0100
+@@ -135,9 +135,9 @@ typedef enum bb_code
bb_cast
} bb_code_ty;
diff --git a/devel/gindent/pkg-plist b/devel/gindent/pkg-plist
index 4f9606384db3..b0438ba549db 100644
--- a/devel/gindent/pkg-plist
+++ b/devel/gindent/pkg-plist
@@ -1,5 +1,6 @@
bin/gindent
bin/gtexinfo2man
+man/man1/gindent.1.gz
%%PORTDOCS%%%%DOCSDIR%%/indent.html
%%NLS%%share/locale/ca/LC_MESSAGES/indent.mo
%%NLS%%share/locale/da/LC_MESSAGES/indent.mo