aboutsummaryrefslogtreecommitdiff
path: root/devel/gir-repository
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2010-11-20 15:37:08 +0000
committerKoop Mast <kwm@FreeBSD.org>2010-11-20 15:37:08 +0000
commit3680f27ebff58ece429c4e032f9ad84fb1372114 (patch)
tree6c5ff4664c1a779ddad350ac887e5706dbfdd4eb /devel/gir-repository
parent02c6e6b485454dc3f5a27cbc887d9e4aaf376a36 (diff)
downloadports-3680f27ebff58ece429c4e032f9ad84fb1372114.tar.gz
ports-3680f27ebff58ece429c4e032f9ad84fb1372114.zip
Notes
Diffstat (limited to 'devel/gir-repository')
-rw-r--r--devel/gir-repository/Makefile6
-rw-r--r--devel/gir-repository/bsd.gir.mk64
-rw-r--r--devel/gir-repository/files/patch-gir_Makefile.in24
3 files changed, 24 insertions, 70 deletions
diff --git a/devel/gir-repository/Makefile b/devel/gir-repository/Makefile
index 37942954c509..c92dac7b8e5b 100644
--- a/devel/gir-repository/Makefile
+++ b/devel/gir-repository/Makefile
@@ -3,7 +3,7 @@
# Whom: Pawel Worach <pawel.worach@gmail.com>
#
# $FreeBSD$
-# $MCom: ports/devel/gir-repository/Makefile,v 1.16 2010/03/14 01:32:00 kwm Exp $
+# $MCom: ports/devel/gir-repository/Makefile,v 1.21 2010/10/24 16:26:19 avl Exp $
#
MASTER_SITES= # Empty
@@ -17,14 +17,10 @@ COMMENT= Introspection information for various libraries
NO_BUILD= yes
RUN_DEPENDS= ${GIRDIR}/${poppler_GIR}.gir:${PORTSDIR}/${poppler_CATEGORY}/gir-repository-poppler \
- ${GIRDIR}/${libsoup_GIR}.gir:${PORTSDIR}/${libsoup_CATEGORY}/gir-repository-libsoup \
${GIRDIR}/${dbus_GIR}.gir:${PORTSDIR}/${dbus_CATEGORY}/gir-repository-dbus \
- ${GIRDIR}/${gconf2_GIR}.gir:${PORTSDIR}/${gconf2_CATEGORY}/gir-repository-gconf2 \
${GIRDIR}/${babl_GIR}.gir:${PORTSDIR}/${babl_CATEGORY}/gir-repository-babl \
- ${GIRDIR}/${nautilus_GIR}.gir:${PORTSDIR}/${nautilus_CATEGORY}/gir-repository-nautilus \
${GIRDIR}/${gnomekeyring_GIR}.gir:${PORTSDIR}/${gnomekeyring_CATEGORY}/gir-repository-gnome-keyring \
${GIRDIR}/${libnotify_GIR}.gir:${PORTSDIR}/${libnotify_CATEGORY}/gir-repository-libnotify \
- ${GIRDIR}/${gtksourceview2_GIR}.gir:${PORTSDIR}/${gtksourceview2_CATEGORY}/gir-repository-gtksourceview2 \
${GIRDIR}/${vte_GIR}.gir:${PORTSDIR}/${vte_CATEGORY}/gir-repository-vte \
${GIRDIR}/${goocanvas_GIR}.gir:${PORTSDIR}/${goocanvas_CATEGORY}/gir-repository-goocanvas
diff --git a/devel/gir-repository/bsd.gir.mk b/devel/gir-repository/bsd.gir.mk
index 62fea33aad2d..cb9b4f1d1b9f 100644
--- a/devel/gir-repository/bsd.gir.mk
+++ b/devel/gir-repository/bsd.gir.mk
@@ -1,6 +1,6 @@
PORTNAME= gir-repository
PORTVERSION= 0.6.5
-PORTREVISION?= 4
+PORTREVISION?= 5
MAINTAINER= gnome@FreeBSD.org
@@ -9,31 +9,12 @@ GIRDIR= ${LOCALBASE}/share/gir-1.0
poppler_CATEGORY= graphics
poppler_GIR= Poppler-0.8
-libsoup_CATEGORY= devel
-libsoup_GIR= Soup-2.4
-libsoup_GIR_TMPL= soup
-
-dbus_CATEGORY= devel
-dbus_GIR= DBus-1.0
-
-gconf2_CATEGORY= devel
-gconf2_GIR= GConf-2.0
-
babl_CATEGORY= x11
babl_GIR= Babl-0.1
-nautilus_CATEGORY= x11-fm
-nautilus_GIR= Nautilus-1.0
-
-gnomekeyring_CATEGORY= security
-gnomekeyring_GIR= GnomeKeyring-2.0
-
libnotify_CATEGORY= devel
libnotify_GIR= Notify-0.4
-gtksourceview2_CATEGORY= x11-toolkits
-gtksourceview2_GIR= GtkSource-2.2
-
vte_CATEGORY= x11-toolkits
vte_GIR= Vte-1.0
@@ -48,7 +29,7 @@ DIST_SUBDIR= gnome2
COMMENT?= Introspection information for ${GIR_NAME}
BUILD_DEPENDS= g-ir-scanner:${PORTSDIR}/devel/gobject-introspection
-RUN_DEPENDS= ${GIRDIR}/Everything-1.0.gir:${PORTSDIR}/devel/gobject-introspection
+RUN_DEPENDS= g-ir-scanner:${PORTSDIR}/devel/gobject-introspection
USE_BZIP2= yes
GNU_CONFIGURE= yes
@@ -68,44 +49,20 @@ PLIST= ${NONEXISTENT}
_USE_GIR_ALL= dbus atk pango pangoxft poppler gtk gconf soup babl nautilusextension \
gnomekeyring webkit notify gnio clutter clutter_gtk clutter_cairo \
gstreamer gstbufferlist_h gstreamer_plugins_base gtksourceview vte \
- goocanvas gssdp gupnp unique gmenu wnck
+ goocanvas gssdp gupnp avahi unique gmenu wnck
.if ${GIR_NAME} == "poppler"
-LIB_DEPENDS+= poppler-glib.4:${PORTSDIR}/graphics/poppler-gtk
+LIB_DEPENDS+= poppler-glib.5:${PORTSDIR}/graphics/poppler-gtk
USE_GNOME+= gtk20
GIR_FILES= Poppler-0.8
CLEAR_DEPS+= Gdk-2.0
.endif
-.if ${GIR_NAME} == "libsoup"
-LIB_DEPENDS+= soup-2.4.1:${PORTSDIR}/devel/libsoup
-GIR_FILES= Soup-2.4
-DEP_NAMES= soup
-.endif
-
-.if ${GIR_NAME} == "gconf2"
-USE_GNOME+= gconf2
-GIR_FILES= GConf-2.0
-DEP_NAMES= gconf
-.endif
-
.if ${GIR_NAME} == "babl"
LIB_DEPENDS+= babl-0.1.0:${PORTSDIR}/x11/babl
GIR_FILES= Babl-0.1
.endif
-.if ${GIR_NAME} == "nautilus"
-USE_GNOME+= nautilus2
-GIR_FILES= Nautilus-1.0
-DEP_NAMES= nautilusextension
-CLEAR_DEPS+= Gtk-2.0
-.endif
-
-.if ${GIR_NAME} == "gnomekeyring"
-LIB_DEPENDS+= gnome-keyring.0:${PORTSDIR}/security/gnome-keyring
-GIR_FILES= GnomeKeyring-2.0
-.endif
-
.if ${GIR_NAME} == "libnotify"
LIB_DEPENDS+= notify.1:${PORTSDIR}/devel/libnotify
USE_GNOME+= gtk20
@@ -114,19 +71,6 @@ DEP_NAMES= notify
CLEAR_DEPS+= Gtk-2.0
.endif
-.if ${GIR_NAME} == "dbus"
-LIB_DEPENDS+= dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib
-GIR_FILES= DBus-1.0
-LIB_FILES= DBus
-.endif
-
-.if ${GIR_NAME} == "gtksourceview2"
-USE_GNOME+= gtksourceview2
-GIR_FILES= GtkSource-2.2
-DEP_NAMES= gtksourceview
-CLEAR_DEPS+= Gtk-2.0
-.endif
-
.if ${GIR_NAME} == "vte"
USE_GNOME+= vte
GIR_FILES= Vte-1.0
diff --git a/devel/gir-repository/files/patch-gir_Makefile.in b/devel/gir-repository/files/patch-gir_Makefile.in
index 5c559acda3b4..8932e4d3fd19 100644
--- a/devel/gir-repository/files/patch-gir_Makefile.in
+++ b/devel/gir-repository/files/patch-gir_Makefile.in
@@ -1,5 +1,5 @@
---- gir/Makefile.in.orig 2009-09-09 21:31:46.000000000 +0200
-+++ gir/Makefile.in 2010-04-07 15:17:19.000000000 +0200
+--- gir/Makefile.in.orig 2010-11-02 16:00:41.000000000 +0100
++++ gir/Makefile.in 2010-11-02 16:02:11.000000000 +0100
@@ -86,7 +86,7 @@ host_triplet = @host@
@BUILD_GSSDP_TRUE@am__append_33 = GSSDP-1.0.gir
@BUILD_GUPNP_TRUE@am__append_34 = GUPnP-1.0.gir
@@ -36,7 +36,17 @@
@BUILD_POPPLER_TRUE@ $(INTROSPECTION_SCANNER) -v --namespace Poppler --nsversion=0.8 \
@BUILD_POPPLER_TRUE@ --add-include-path=$(srcdir) --add-include-path=. \
@BUILD_POPPLER_TRUE@ --include=GObject-2.0 \
-@@ -1384,16 +1384,16 @@ uninstall-am: uninstall-dist_girDATA uni
+@@ -1228,7 +1228,8 @@ uninstall-am: uninstall-dist_girDATA uni
+ @BUILD_VTE_TRUE@ --pkg gtk+-2.0 \
+ @BUILD_VTE_TRUE@ --pkg vte \
+ @BUILD_VTE_TRUE@ --output $@ \
+-@BUILD_VTE_TRUE@ $(VTE_INCLUDEDIR)/vte/*.h
++@BUILD_VTE_TRUE@ -DVTE_COMPILATION \
++@BUILD_VTE_TRUE@ $(VTE_INCLUDEDIR)/vte-0.0/vte/*.h
+ @BUILD_CLUTTER_TRUE@ClutterJson-0.8.gir: $(INTROSPECTION_SCANNER)
+ @BUILD_CLUTTER_TRUE@ $(INTROSPECTION_SCANNER) -v --namespace ClutterJson --nsversion=0.8 \
+ @BUILD_CLUTTER_TRUE@ --add-include-path=$(srcdir) --add-include-path=. \
+@@ -1384,16 +1385,16 @@ uninstall-am: uninstall-dist_girDATA uni
@BUILD_GSTREAMER_PLUGINS_BASE_TRUE@ --output $@ \
@BUILD_GSTREAMER_PLUGINS_BASE_TRUE@ $(GSTFFT_INCLUDEDIR)/gst/fft/*h
@BUILD_GSTREAMER_PLUGINS_BASE_TRUE@GstInterfaces-0.10.gir: Gst-0.10.gir $(INTROSPECTION_SCANNER)
@@ -56,7 +66,7 @@
@BUILD_GSTREAMER_PLUGINS_BASE_TRUE@GstNetbuffer-0.10.gir: Gst-0.10.gir $(INTROSPECTION_SCANNER)
@BUILD_GSTREAMER_PLUGINS_BASE_TRUE@ $(DEBUG) $(INTROSPECTION_SCANNER) -v --namespace GstNetbuffer --nsversion=0.10 \
@BUILD_GSTREAMER_PLUGINS_BASE_TRUE@ --add-include-path=$(srcdir) --add-include-path=. \
-@@ -1479,6 +1479,7 @@ uninstall-am: uninstall-dist_girDATA uni
+@@ -1479,6 +1480,7 @@ uninstall-am: uninstall-dist_girDATA uni
@BUILD_GSTREAMER_PLUGINS_BASE_TRUE@ --include=Gst-0.10 \
@BUILD_GSTREAMER_PLUGINS_BASE_TRUE@ --include=GstBase-0.10 \
@BUILD_GSTREAMER_PLUGINS_BASE_TRUE@ --library=gstvideo-0.10 \
@@ -64,7 +74,7 @@
@BUILD_GSTREAMER_PLUGINS_BASE_TRUE@ --libtool="$(LIBTOOL)" \
@BUILD_GSTREAMER_PLUGINS_BASE_TRUE@ --pkg gobject-2.0 \
@BUILD_GSTREAMER_PLUGINS_BASE_TRUE@ --pkg gstreamer-0.10 \
-@@ -1529,11 +1530,11 @@ uninstall-am: uninstall-dist_girDATA uni
+@@ -1529,14 +1531,15 @@ uninstall-am: uninstall-dist_girDATA uni
@BUILD_AVAHI_TRUE@ --output $@ \
@BUILD_AVAHI_TRUE@ --pkg avahi-gobject \
@BUILD_AVAHI_TRUE@ $(AVAHI_INCLUDEDIR)/*.h
@@ -79,3 +89,7 @@
@BUILD_BABL_TRUE@ --libtool="$(LIBTOOL)" \
@BUILD_BABL_TRUE@ --output $@ \
@BUILD_BABL_TRUE@ --pkg babl \
++@BUILD_BABL_TRUE@ -DBABL_INSIDE_BABL_H \
+ @BUILD_BABL_TRUE@ $(BABL_INCLUDEDIR)/babl/*.h
+ @BUILD_UNIQUE_TRUE@Unique-1.0.gir: Gtk-2.0.gir $(INTROSPECTION_SCANNER)
+ @BUILD_UNIQUE_TRUE@ $(INTROSPECTION_SCANNER) -v --namespace Unique --nsversion=1.0 \