aboutsummaryrefslogtreecommitdiff
path: root/devel/git/Makefile
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2017-07-17 17:33:35 +0000
committerRenato Botelho <garga@FreeBSD.org>2017-07-17 17:33:35 +0000
commit2e50c364c03ccb3aaaf7c647d732c89ed5af1f97 (patch)
tree462bacba2ce2e70e689e5363996b1828093580d4 /devel/git/Makefile
parentce3d99b886605db7d640290d9b6ba5bb0001c1f2 (diff)
downloadports-2e50c364c03ccb3aaaf7c647d732c89ed5af1f97.tar.gz
ports-2e50c364c03ccb3aaaf7c647d732c89ed5af1f97.zip
Notes
Diffstat (limited to 'devel/git/Makefile')
-rw-r--r--devel/git/Makefile10
1 files changed, 9 insertions, 1 deletions
diff --git a/devel/git/Makefile b/devel/git/Makefile
index 0f2618a4a072..3403abc6cb72 100644
--- a/devel/git/Makefile
+++ b/devel/git/Makefile
@@ -3,6 +3,7 @@
PORTNAME= git
DISTVERSION= 2.13.3
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= KERNEL_ORG/software/scm/git
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} \
@@ -42,7 +43,6 @@ SHEBANG_FILES= *.perl */*.perl */*/*.perl */*.pl */*/*.pl */*/*/*.pl \
contrib/remote-helpers/git-remote-bzr \
contrib/remote-helpers/git-remote-hg \
contrib/credential/netrc/git-credential-netrc \
- contrib/diff-highlight/diff-highlight.perl \
contrib/buildsystems/generate contrib/contacts/git-contacts \
contrib/svn-fe/svnrdump_sim.py
TEST_TARGET= test
@@ -155,6 +155,10 @@ post-patch:
.endfor
@${REINPLACE_CMD} -e 's|share/man/man3|man/man3|' ${WRKSRC}/perl/Makefile.PL
+post-patch-CONTRIB-on:
+ @${REINPLACE_CMD} -e "s,/usr/bin/perl,${PERL}," \
+ ${WRKSRC}/contrib/diff-highlight/Makefile
+
post-patch-CVS-off:
@${REINPLACE_CMD} -e '/git-cvsexportcommit.perl/d; \
/git-cvsimport.perl/d; \
@@ -180,6 +184,10 @@ post-build:
@${FIND} ${WRKSRC} -name "*.bak" -delete
.endif
+post-build-CONTRIB-on:
+ ${SETENV} ${MAKE_ENV} ${MAKE_CMD} -C ${WRKSRC}/contrib/diff-highlight
+ ${RM} ${WRKSRC}/contrib/diff-highlight/shebang.perl
+
post-install:
(cd ${WRKDIR}/man1/ && ${COPYTREE_SHARE} . ${STAGEDIR}${MANPREFIX}/man/man1)
(cd ${WRKDIR}/man5/ && ${COPYTREE_SHARE} . ${STAGEDIR}${MANPREFIX}/man/man5)