aboutsummaryrefslogtreecommitdiff
path: root/devel/git/Makefile
diff options
context:
space:
mode:
authorEric Anholt <anholt@FreeBSD.org>2006-02-08 08:30:38 +0000
committerEric Anholt <anholt@FreeBSD.org>2006-02-08 08:30:38 +0000
commitca58d02f957b19e8cf971db129547df1b02eb162 (patch)
treea585f967268aee58a68bcfaa59c900d6c471c785 /devel/git/Makefile
parent2eed5a45cbc362faf72ea171f9f1ac5992ac634e (diff)
downloadports-ca58d02f957b19e8cf971db129547df1b02eb162.tar.gz
ports-ca58d02f957b19e8cf971db129547df1b02eb162.zip
Notes
Diffstat (limited to 'devel/git/Makefile')
-rw-r--r--devel/git/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/devel/git/Makefile b/devel/git/Makefile
new file mode 100644
index 000000000000..d51da030dbf3
--- /dev/null
+++ b/devel/git/Makefile
@@ -0,0 +1,34 @@
+# Ports collection makefile for: git
+# Date created: 7 Feb 2006
+# Whom: Eric Anholt
+#
+# $FreeBSD$
+#
+
+PORTNAME= git
+PORTVERSION= 1.1.6
+CATEGORIES= devel
+MASTER_SITES= http://www.kernel.org/pub/software/scm/git/
+
+MAINTAINER= anholt@FreeBSD.org
+COMMENT= Distributed source code management tool
+
+BUILD_DEPENDS= curl:${PORTSDIR}/ftp/curl
+RUN_DEPENDS= curl:${PORTSDIR}/ftp/curl \
+ wish8.4:${PORTSDIR}/x11-toolkits/tk84
+
+USE_PERL5= yes
+USE_PYTHON= yes
+USE_ICONV= yes
+USE_GMAKE= yes
+CFLAGS+= -I${LOCALBASE}/include
+MAKE_ENV+= CURLDIR=${LOCALBASE} \
+ NEEDS_LIBICONV=yes \
+ LDFLAGS="-L${LOCALBASE}/lib"
+MAKE_ARGS+= prefix="${PREFIX}"
+
+pre-patch:
+ ${REINPLACE_CMD} "s|/usr/bin/python|${LOCALBASE}/bin/python|g" \
+ ${WRKSRC}/git-merge-recursive.py
+
+.include <bsd.port.mk>