aboutsummaryrefslogtreecommitdiff
path: root/devel/git
diff options
context:
space:
mode:
authorWesley Shields <wxs@FreeBSD.org>2013-03-18 15:10:43 +0000
committerWesley Shields <wxs@FreeBSD.org>2013-03-18 15:10:43 +0000
commit183061fc74d58ef4f9dfe18ac07e00d6a8c5c545 (patch)
tree933d316b3693a067bd6e2d6f7b800c40ea95d655 /devel/git
parente288f50da1bf70560efff7397f736aee304c434b (diff)
downloadports-183061fc74d58ef4f9dfe18ac07e00d6a8c5c545.tar.gz
ports-183061fc74d58ef4f9dfe18ac07e00d6a8c5c545.zip
Notes
Diffstat (limited to 'devel/git')
-rw-r--r--devel/git/Makefile3
-rw-r--r--devel/git/distinfo12
-rw-r--r--devel/git/files/patch-wrapper.c16
-rw-r--r--devel/git/pkg-plist22
4 files changed, 37 insertions, 16 deletions
diff --git a/devel/git/Makefile b/devel/git/Makefile
index 08f6690dfd2a..7c72caa68477 100644
--- a/devel/git/Makefile
+++ b/devel/git/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= git
-PORTVERSION= 1.8.1.5
+PORTVERSION= 1.8.2
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
DISTFILES= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX} \
@@ -34,6 +34,7 @@ MAN1= git.1 \
git-bundle.1 \
git-cat-file.1 \
git-check-attr.1 \
+ git-check-ignore.1 \
git-check-ref-format.1 \
git-checkout-index.1 \
git-checkout.1 \
diff --git a/devel/git/distinfo b/devel/git/distinfo
index 95a2b685cf91..4147f8a061c2 100644
--- a/devel/git/distinfo
+++ b/devel/git/distinfo
@@ -1,6 +1,6 @@
-SHA256 (git-1.8.1.5.tar.gz) = f8b0be6e53e866f83cde64fa947011ebac56077bd1273c2e894038878986b955
-SIZE (git-1.8.1.5.tar.gz) = 4306780
-SHA256 (git-manpages-1.8.1.5.tar.gz) = b171761f13deb738a2464c9d3967c12539067a34d6f2bfa5739a1006786fd24a
-SIZE (git-manpages-1.8.1.5.tar.gz) = 528540
-SHA256 (git-htmldocs-1.8.1.5.tar.gz) = 108e34217b2668945ca78b36b08ceeb9fe283617fe68b8f181219076bb225de0
-SIZE (git-htmldocs-1.8.1.5.tar.gz) = 2060977
+SHA256 (git-1.8.2.tar.gz) = c2f35bcefa4f62a54c4bde41cc0f1cd3ddf03e9a6bc8a79557f1683789f213e6
+SIZE (git-1.8.2.tar.gz) = 4389957
+SHA256 (git-manpages-1.8.2.tar.gz) = c164bf40a11b1cc7e6a70fa39749c7c6aaf385429cfdfa2ebcc7386f49bb897a
+SIZE (git-manpages-1.8.2.tar.gz) = 535376
+SHA256 (git-htmldocs-1.8.2.tar.gz) = 0ee46fb610a2a632d62fd37450330ca26301721cef7a4327bb7eb3cab32ba7ff
+SIZE (git-htmldocs-1.8.2.tar.gz) = 2088111
diff --git a/devel/git/files/patch-wrapper.c b/devel/git/files/patch-wrapper.c
index ad095f151938..bc31f9d8a1a7 100644
--- a/devel/git/files/patch-wrapper.c
+++ b/devel/git/files/patch-wrapper.c
@@ -1,6 +1,14 @@
---- ./wrapper.c.orig 2010-07-28 13:03:43.000000000 -0400
-+++ ./wrapper.c 2010-08-16 21:56:14.250979872 -0400
-@@ -131,7 +131,7 @@
+--- wrapper.c.orig 2013-03-13 15:15:22.000000000 -0400
++++ wrapper.c 2013-03-17 20:55:29.000000000 -0400
+@@ -1,6 +1,7 @@
+ /*
+ * Various trivial helper wrappers around standard functions
+ */
++#include <sys/param.h>
+ #include "cache.h"
+
+ static void do_nothing(size_t size)
+@@ -139,7 +140,7 @@
{
ssize_t nr;
while (1) {
@@ -9,7 +17,7 @@
if ((nr < 0) && (errno == EAGAIN || errno == EINTR))
continue;
return nr;
-@@ -147,7 +147,7 @@
+@@ -155,7 +156,7 @@
{
ssize_t nr;
while (1) {
diff --git a/devel/git/pkg-plist b/devel/git/pkg-plist
index 5dbf86c94e96..4b0734df61c7 100644
--- a/devel/git/pkg-plist
+++ b/devel/git/pkg-plist
@@ -38,6 +38,7 @@ libexec/git-core/git-branch
libexec/git-core/git-bundle
libexec/git-core/git-cat-file
libexec/git-core/git-check-attr
+libexec/git-core/git-check-ignore
libexec/git-core/git-check-ref-format
libexec/git-core/git-checkout
libexec/git-core/git-checkout-index
@@ -139,7 +140,7 @@ libexec/git-core/git-relink
libexec/git-core/git-remote
libexec/git-core/git-remote-ext
libexec/git-core/git-remote-fd
-libexec/git-core/git-remote-testgit
+libexec/git-core/git-remote-testpy
libexec/git-core/git-remote-testsvn
%%CURL%%libexec/git-core/git-remote-http
%%CURL%%libexec/git-core/git-remote-https
@@ -197,14 +198,16 @@ libexec/git-core/mergetools/tortoisemerge
libexec/git-core/mergetools/tkdiff
libexec/git-core/mergetools/bc3
libexec/git-core/mergetools/kdiff3
-libexec/git-core/mergetools/vim
+libexec/git-core/mergetools/gvimdiff
+libexec/git-core/mergetools/gvimdiff2
+libexec/git-core/mergetools/vimdiff
+libexec/git-core/mergetools/vimdiff2
libexec/git-core/mergetools/meld
libexec/git-core/mergetools/ecmerge
libexec/git-core/mergetools/diffuse
libexec/git-core/mergetools/p4merge
libexec/git-core/mergetools/kompare
libexec/git-core/mergetools/opendiff
-libexec/git-core/mergetools/defaults
libexec/git-core/mergetools/emerge
libexec/git-core/mergetools/araxis
%%GUI%%bin/gitk
@@ -241,6 +244,7 @@ share/git-core/templates/hooks/commit-msg.sample
share/git-core/templates/hooks/post-update.sample
share/git-core/templates/hooks/pre-applypatch.sample
share/git-core/templates/hooks/pre-commit.sample
+share/git-core/templates/hooks/pre-push.sample
share/git-core/templates/hooks/pre-rebase.sample
share/git-core/templates/hooks/prepare-commit-msg.sample
share/git-core/templates/hooks/update.sample
@@ -663,6 +667,10 @@ share/git-core/templates/info/exclude
%%HTMLDOCS%%%%DOCSDIR%%/technical/protocol-capabilities.html
%%HTMLDOCS%%%%DOCSDIR%%/technical/index-format.txt
%%HTMLDOCS%%%%DOCSDIR%%/technical/index-format.html
+%%HTMLDOCS%%%%DOCSDIR%%/git-check-ignore.txt
+%%HTMLDOCS%%%%DOCSDIR%%/git-check-ignore.html
+%%HTMLDOCS%%%%DOCSDIR%%/mergetools-diff.txt
+%%HTMLDOCS%%%%DOCSDIR%%/mergetools-merge.txt
%%HTMLDOCS%%%%DOCSDIR%%/gittutorial.txt
%%HTMLDOCS%%%%DOCSDIR%%/git-help.txt
%%HTMLDOCS%%%%DOCSDIR%%/git-remote.txt
@@ -986,6 +994,7 @@ share/git-core/templates/info/exclude
%%HTMLDOCS%%%%DOCSDIR%%/RelNotes/1.8.1.3.txt
%%HTMLDOCS%%%%DOCSDIR%%/RelNotes/1.8.1.4.txt
%%HTMLDOCS%%%%DOCSDIR%%/RelNotes/1.8.1.5.txt
+%%HTMLDOCS%%%%DOCSDIR%%/RelNotes/1.8.2.txt
%%GITWEB%%%%EXAMPLESDIR%%/gitweb/gitweb.cgi
%%GITWEB%%%%EXAMPLESDIR%%/gitweb/static/gitweb.js
%%GITWEB%%%%EXAMPLESDIR%%/gitweb/static/gitweb.css
@@ -1070,7 +1079,8 @@ share/git-core/templates/info/exclude
%%CONTRIB%%share/git-core/contrib/hooks/pre-auto-gc-battery
%%CONTRIB%%share/git-core/contrib/hooks/setgitperms.perl
%%CONTRIB%%share/git-core/contrib/hooks/update-paranoid
-%%CONTRIB%%share/git-core/contrib/mw-to-git/git-remote-mediawiki
+%%CONTRIB%%share/git-core/contrib/mw-to-git/.gitignore
+%%CONTRIB%%share/git-core/contrib/mw-to-git/git-remote-mediawiki.perl
%%CONTRIB%%share/git-core/contrib/mw-to-git/git-remote-mediawiki.txt
%%CONTRIB%%share/git-core/contrib/mw-to-git/Makefile
%%CONTRIB%%share/git-core/contrib/mw-to-git/t/install-wiki/.gitignore
@@ -1104,7 +1114,9 @@ share/git-core/templates/info/exclude
%%CONTRIB%%share/git-core/contrib/persistent-https/proxy.go
%%CONTRIB%%share/git-core/contrib/persistent-https/socket.go
%%CONTRIB%%share/git-core/contrib/remote-helpers/Makefile
+%%CONTRIB%%share/git-core/contrib/remote-helpers/git-remote-bzr
%%CONTRIB%%share/git-core/contrib/remote-helpers/git-remote-hg
+%%CONTRIB%%share/git-core/contrib/remote-helpers/test-bzr.sh
%%CONTRIB%%share/git-core/contrib/remote-helpers/test-hg.sh
%%CONTRIB%%share/git-core/contrib/remote-helpers/test-hg-bidi.sh
%%CONTRIB%%share/git-core/contrib/remote-helpers/test-hg-hg-git.sh
@@ -1180,7 +1192,7 @@ share/git-core/templates/info/exclude
%%CONTRIB%%@dirrm share/git-core/contrib/hooks
%%CONTRIB%%@dirrm share/git-core/contrib/mw-to-git/t/install-wiki
%%CONTRIB%%@dirrm share/git-core/contrib/mw-to-git/t/
-%%CONTRIB%%@dirrm share/git-core/contrib/mw-to-git
+%%CONTRIB%%@dirrm share/git-core/contrib/mw-to-git/
%%CONTRIB%%@dirrm share/git-core/contrib/p4import
%%CONTRIB%%@dirrm share/git-core/contrib/patches
%%CONTRIB%%@dirrm share/git-core/contrib/persistent-https