aboutsummaryrefslogtreecommitdiff
path: root/devel/git
diff options
context:
space:
mode:
authorWesley Shields <wxs@FreeBSD.org>2012-07-07 03:07:57 +0000
committerWesley Shields <wxs@FreeBSD.org>2012-07-07 03:07:57 +0000
commitcb5734da63f69a86d283776c33769f6f17c59c41 (patch)
tree3cd16dab28de908946d73fe30db38d827bcff376 /devel/git
parent7a935b8848b568476c143ff3c622d2bc85015079 (diff)
downloadports-cb5734da63f69a86d283776c33769f6f17c59c41.tar.gz
ports-cb5734da63f69a86d283776c33769f6f17c59c41.zip
Notes
Diffstat (limited to 'devel/git')
-rw-r--r--devel/git/Makefile85
-rw-r--r--devel/git/distinfo12
-rw-r--r--devel/git/pkg-plist42
3 files changed, 92 insertions, 47 deletions
diff --git a/devel/git/Makefile b/devel/git/Makefile
index d587839dd256..e0a6b9e13e26 100644
--- a/devel/git/Makefile
+++ b/devel/git/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= git
-PORTVERSION= 1.7.10.3
+PORTVERSION= 1.7.11.1
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
DISTFILES= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX} \
@@ -41,6 +41,7 @@ MAN1= git.1 \
git-cherry.1 \
git-clean.1 \
git-clone.1 \
+ git-column.1 \
git-commit-tree.1 \
git-commit.1 \
git-config.1 \
@@ -198,21 +199,20 @@ WANT_PERL= yes
CONFIGURE_ARGS= --enable-pthreads=${PTHREAD_LIBS}
-OPTIONS= GUI "Enable building of GUI tools" off \
- SVN "Enable required dependencies for SVN tools" off \
- GITWEB "Install gitweb" off \
- CONTRIB "Install contributed scripts" on \
- P4 "Enable Perforce support" on \
- CVS "Enable CVS support" on \
- HTMLDOCS "Install additional documentation" off \
- PERL "Build perl based git tools" on \
- ICONV "Support for multiple character encodings" on \
- CURL "Support HTTP push and pull" on \
- ETCSHELLS "Modify /etc/shells" on
+OPTIONS_DEFINE= GUI SVN GITWEB CONTRIB P4 CVS HTMLDOCS PERL ICONV CURL \
+ ETCSHELLS NLS
+OPTIONS_DEFAULT= CONTRIB P4 CVS PERL ICONV CURL ETCSHELLS NLS
+
+GITWEB_DESC= Install gitweb
+CONTRIB_DESC= Install contributed scripts
+P4_DESC= Enable Perforce support
+CVS_DESC= Enable CVS support
+HTMLDOCS_DESC= Install additional documentation
+ETCSHELLS_DESC= Modify /etc/shells
.include <bsd.port.options.mk>
-.ifndef (WITHOUT_NLS)
+.if ${PORT_OPTIONS:MNLS}
USE_GETTEXT= yes
PLIST_SUB+= NLS=""
.else
@@ -220,11 +220,12 @@ PLIST_SUB+= NLS="@comment "
MAKE_ENV+= NO_GETTEXT=yes
.endif
+# This is intentionally not exposed as an option.
.ifndef (WITH_DEBUG)
ALL_TARGET= all strip
.endif
-.ifdef (WITH_P4) || defined (WITH_CONTRIB)
+.if ${PORT_OPTIONS:MP4} || ${PORT_OPTIONS:MCONTRIB}
USE_PYTHON= yes
PLIST_SUB+= PYTHON_VER=${PYTHON_VER} PYTHON=""
CONFIGURE_ARGS+= --with-python=${LOCALBASE}/bin/python
@@ -233,21 +234,26 @@ CONFIGURE_ARGS+= --without-python
PLIST_SUB+= PYTHON="@comment "
.endif
-.ifdef (WITH_PERL)
+.if ${PORT_OPTIONS:MPERL}
USE_PERL5= yes
MAKE_ENV+= PERL_PATH=${PERL}
BUILD_DEPENDS+= p5-Error>=0:${PORTSDIR}/lang/p5-Error
RUN_DEPENDS+= p5-Error>=0:${PORTSDIR}/lang/p5-Error \
p5-Net-SMTP-SSL>=0:${PORTSDIR}/mail/p5-Net-SMTP-SSL
MAN3= Git.3 \
- Git::I18N.3
+ Git::I18N.3 \
+ Git::SVN::Editor.3 \
+ Git::SVN::Fetcher.3 \
+ Git::SVN::Memoize::YAML.3 \
+ Git::SVN::Prompt.3 \
+ Git::SVN::Ra.3
PLIST_SUB+= PERLSUB=""
.else
MAKE_ENV+= NO_PERL=1
PLIST_SUB+= PERLSUB="@comment "
.endif
-.ifdef (WITH_ICONV)
+.if ${PORT_OPTIONS:MICONV}
USE_ICONV= yes
MAKE_ENV+= NEEDS_LIBICONV=yes \
ICONVDIR=${LOCALBASE}
@@ -256,7 +262,7 @@ CONFIGURE_ARGS+= --with-iconv=${LOCALBASE}
MAKE_ENV+= NO_ICONV=1
.endif
-.ifdef (WITH_CURL)
+.if ${PORT_OPTIONS:MCURL}
MAKE_ENV+= CURLDIR=${LOCALBASE}
BUILD_DEPENDS+= curl:${PORTSDIR}/ftp/curl
RUN_DEPENDS+= curl:${PORTSDIR}/ftp/curl
@@ -270,14 +276,14 @@ PLIST_SUB+= CURL="@comment "
# Always fetch the htmldocs distfile in maintainer mode.
# Always include it when building distinfo (makesum)
-.if defined (WITH_HTMLDOCS) || make(makesum) || (defined(MAINTAINER_MODE) && make(fetch))
+.if ${PORT_OPTIONS:MHTMLDOCS} || make(makesum) || (defined(MAINTAINER_MODE) && make(fetch))
DISTFILES+= ${PORTNAME}-htmldocs-${PORTVERSION}${EXTRACT_SUFX}
PLIST_SUB+= HTMLDOCS=""
.else
PLIST_SUB+= HTMLDOCS="@comment "
.endif
-.ifdef (WITH_GUI)
+.if ${PORT_OPTIONS:MGUI}
USE_TK= 84+
.include "${PORTSDIR}/Mk/bsd.tcl.mk"
MAN1+= git-citool.1 \
@@ -298,7 +304,7 @@ MAKE_ARGS+= NO_TCLTK=yes
# to have git use devel/subversion16 it will be brought in through
# devel/p5-subversion if you set WITH_SUBVERSION_VER=16. Otherwise
# devel/subversion will be brought in.
-.ifdef (WITH_SVN)
+.if ${PORT_OPTIONS:MSVN}
RUN_DEPENDS+= p5-Term-ReadKey>=0:${PORTSDIR}/devel/p5-Term-ReadKey \
p5-subversion>=0:${PORTSDIR}/devel/p5-subversion
PLIST_SUB+= SVN=""
@@ -308,29 +314,29 @@ PLIST_SUB+= SVN="@comment "
RMMAN1+= git-svn.1
.endif
-.ifdef (WITH_GITWEB)
+.if ${PORT_OPTIONS:MGITWEB}
PLIST_SUB+= GITWEB=""
.else
PLIST_SUB+= GITWEB="@comment "
.endif
-.ifdef (WITH_GITWEB) && !defined (WITH_PERL)
+.if ${PORT_OPTIONS:MGITWEB} && empty(PORT_OPTIONS:MPERL)
IGNORE= using GITWEB support requires PERL support
.endif
-.ifdef (WITH_CONTRIB)
+.if ${PORT_OPTIONS:MCONTRIB}
PLIST_SUB+= CONTRIB=""
.else
PLIST_SUB+= CONTRIB="@comment "
.endif
-.ifdef (WITH_P4)
+.if ${PORT_OPTIONS:MP4}
PLIST_SUB+= P4=""
.else
PLIST_SUB+= P4="@comment "
.endif
-.ifdef (WITH_CVS)
+.if ${PORT_OPTIONS:MCVS}
MAN1+= git-cvsimport.1 git-cvsexportcommit.1 git-cvsserver.1
MAN7+= gitcvs-migration.7
PLIST_SUB+= CVS=""
@@ -341,7 +347,7 @@ RMMAN1+= git-cvsimport.1 git-cvsexportcommit.1 git-cvsserver.1
RMMAN7+= gitcvs-migration.7
.endif
-.ifdef (WITH_ETCSHELLS)
+.if ${PORT_OPTIONS:METCSHELLS}
SHELLS= /etc/shells
PLIST_SUB+= ETCSHELLS=""
.else
@@ -349,7 +355,7 @@ PLIST_SUB+= ETCSHELLS="@comment "
.endif
post-extract:
-.if defined (WITH_HTMLDOCS)
+.if ${PORT_OPTIONS:MHTMLDOCS}
@${MKDIR} ${WRKDIR}/htmldocs
@cd ${WRKDIR}/htmldocs && ${EXTRACT_CMD} ${EXTRACT_BEFORE_ARGS} \
${DISTDIR}/${PORTNAME}-htmldocs-${PORTVERSION}${EXTRACT_SUFX} \
@@ -364,7 +370,7 @@ post-patch:
@${RM} ${WRKDIR}/man7/${FILE}
.endfor
@${REINPLACE_CMD} -e 's|share/man/man3|man/man3|' ${WRKSRC}/perl/Makefile.PL
-.ifndef (WITH_CVS)
+.if empty(PORT_OPTIONS:MCVS)
@${REINPLACE_CMD} -e '/git-cvsexportcommit.perl/d; \
/git-cvsimport.perl/d; \
/git-cvsserver.perl/d; \
@@ -372,15 +378,18 @@ post-patch:
s/git-cvsserver//' \
${WRKSRC}/Makefile
.endif
-.ifndef (WITH_SVN)
+.if empty(PORT_OPTIONS:MSVN)
@${REINPLACE_CMD} -e '/git-svn.perl/d' ${WRKSRC}/Makefile
.endif
-.ifndef (WITH_GITWEB)
+.if empty(PORT_OPTIONS:MGITWEB)
@${REINPLACE_CMD} -e '/$$(MAKE) -C gitweb install/d' ${WRKSRC}/Makefile
.endif
+.if empty(PORT_OPTIONS:MP4)
+ @${REINPLACE_CMD} -e '/^SCRIPT_PYTHON += git-p4.py$$/d' ${WRKSRC}/Makefile
+.endif
post-build:
-.ifdef (WITH_P4) || defined (WITH_CONTRIB)
+.if ${PORT_OPTIONS:MP4} || ${PORT_OPTIONS:MCONTRIB}
@${REINPLACE_CMD} -e '1s|#!/usr/bin/python|#!${PYTHON_CMD}|' \
${WRKSRC}/contrib/p4import/git-p4import.py
@${CP} ${WRKSRC}/contrib/p4import/git-p4import.py \
@@ -392,7 +401,7 @@ post-install:
(cd ${WRKDIR}/man1/ && ${COPYTREE_SHARE} \* ${MANPREFIX}/man/man1)
(cd ${WRKDIR}/man5/ && ${COPYTREE_SHARE} \* ${MANPREFIX}/man/man5)
(cd ${WRKDIR}/man7/ && ${COPYTREE_SHARE} \* ${MANPREFIX}/man/man7)
-.if defined (WITH_HTMLDOCS)
+.if ${PORT_OPTIONS:MHTMLDOCS}
# Manually remove the index.html symlink before installing, and then
# recreate it after. This is necessary because the distfile is
# extracted with --no-same-owner. If the distfile is extracted as a
@@ -413,23 +422,23 @@ post-install:
${PREFIX}/lib/xemacs/site-lisp/git/git.el
${LN} -sf ${PREFIX}/share/emacs/site-lisp/git/git-blame.el \
${PREFIX}/lib/xemacs/site-lisp/git/git-blame.el
-.ifdef (WITH_CONTRIB)
+.if ${PORT_OPTIONS:MCONTRIB}
@${ECHO_MSG} "===> Installing contributed scripts"
${MKDIR} ${PREFIX}/share/git-core/contrib
${CP} -R ${WRKSRC}/contrib/* ${PREFIX}/share/git-core/contrib
.endif
-.ifdef (WITH_P4)
+.if ${PORT_OPTIONS:MP4}
${INSTALL_SCRIPT} ${WRKSRC}/contrib/p4import/git-p4import ${PREFIX}/bin/
- ${INSTALL_SCRIPT} ${WRKSRC}/contrib/fast-import/git-p4 ${PREFIX}/bin/
+ ${INSTALL_SCRIPT} ${WRKSRC}/git-p4 ${PREFIX}/bin/
.endif
-.ifdef (WITH_ETCSHELLS)
+.if ${PORT_OPTIONS:METCSHELLS}
@${ECHO_MSG} "===> Updating ${SHELLS}"
@${CP} ${SHELLS} ${SHELLS}.bak
@(${GREP} -v ${PREFIX}/libexec/git-core/git-shell ${SHELLS}.bak; \
${ECHO_CMD} ${PREFIX}/libexec/git-core/git-shell) > ${SHELLS}
@${RM} ${SHELLS}.bak
.endif
-.ifdef (WITH_GITWEB) || defined (WITH_CONTRIB)
+.if ${PORT_OPTIONS:MGITWEB} || ${PORT_OPTIONS:MCONTRIB}
@${CAT} ${PKGMESSAGE}
.endif
diff --git a/devel/git/distinfo b/devel/git/distinfo
index f09aba880b16..844605840f7c 100644
--- a/devel/git/distinfo
+++ b/devel/git/distinfo
@@ -1,6 +1,6 @@
-SHA256 (git-1.7.10.3.tar.gz) = b804058554fc58336b3daf8825e314041f24a83e9204c133a58641ed06abd6f7
-SIZE (git-1.7.10.3.tar.gz) = 3811707
-SHA256 (git-manpages-1.7.10.3.tar.gz) = 811df53ad4736589e0f9473f1651ed0eb4dcdfe01b379a1a7f9129a6bc0b36cd
-SIZE (git-manpages-1.7.10.3.tar.gz) = 511308
-SHA256 (git-htmldocs-1.7.10.3.tar.gz) = fd04afe02405d474a72d4dc898a599940c6c9b7ca8b5f1cfcaa4d6002004d284
-SIZE (git-htmldocs-1.7.10.3.tar.gz) = 1763705
+SHA256 (git-1.7.11.1.tar.gz) = b0d90066f3e929b84787d10270461d0d81314898b8f335884e257f4b3091e89e
+SIZE (git-1.7.11.1.tar.gz) = 4000383
+SHA256 (git-manpages-1.7.11.1.tar.gz) = aaf8593c85400406ccd1a87af21401ed967fa9d4ff6f0cf04a1e121af1b47e77
+SIZE (git-manpages-1.7.11.1.tar.gz) = 514150
+SHA256 (git-htmldocs-1.7.11.1.tar.gz) = 24cf2400deba4b07a8723e59e033848dd56f3539a5196b5f35aa0782dd682ecb
+SIZE (git-htmldocs-1.7.11.1.tar.gz) = 1775348
diff --git a/devel/git/pkg-plist b/devel/git/pkg-plist
index 7331d2f4fb74..2a113ee02fde 100644
--- a/devel/git/pkg-plist
+++ b/devel/git/pkg-plist
@@ -46,6 +46,7 @@ libexec/git-core/git-cherry-pick
%%GUI%%libexec/git-core/git-citool
libexec/git-core/git-clean
libexec/git-core/git-clone
+libexec/git-core/git-column
libexec/git-core/git-commit
libexec/git-core/git-commit-tree
libexec/git-core/git-config
@@ -114,6 +115,7 @@ libexec/git-core/git-mktree
libexec/git-core/git-mv
libexec/git-core/git-name-rev
libexec/git-core/git-notes
+%%P4%%libexec/git-core/git-p4
libexec/git-core/git-pack-objects
libexec/git-core/git-pack-redundant
libexec/git-core/git-pack-refs
@@ -157,9 +159,9 @@ libexec/git-core/git-sh-i18n
libexec/git-core/git-sh-i18n--envsubst
libexec/git-core/git-sh-setup
libexec/git-core/git-shell
-libexec/git-core/git-stage
%%ETCSHELLS%%@exec echo "Updating /etc/shells"; cp /etc/shells /etc/shells.bak; (grep -v %D/%F /etc/shells.bak; echo %D/%F) >/etc/shells; rm -f /etc/shells.bak
%%ETCSHELLS%%@unexec echo "Updating /etc/shells"; cp /etc/shells /etc/shells.bak; (grep -v %D/%F /etc/shells.bak) >/etc/shells; rm -f /etc/shells.bak
+libexec/git-core/git-stage
libexec/git-core/git-shortlog
libexec/git-core/git-show
libexec/git-core/git-show-branch
@@ -206,14 +208,21 @@ libexec/git-core/mergetools/araxis
%%PERLSUB%%%%SITE_PERL%%/Git.pm
%%PERLSUB%%%%SITE_PERL%%/%%PERL_ARCH%%/auto/Git/.packlist
%%PERLSUB%%%%SITE_PERL%%/Git/I18N.pm
+%%PERLSUB%%%%SITE_PERL%%/Git/SVN/Memoize/YAML.pm
+%%PERLSUB%%%%SITE_PERL%%/Git/SVN/Ra.pm
+%%PERLSUB%%%%SITE_PERL%%/Git/SVN/Prompt.pm
+%%PERLSUB%%%%SITE_PERL%%/Git/SVN/Editor.pm
+%%PERLSUB%%%%SITE_PERL%%/Git/SVN/Fetcher.pm
lib/xemacs/site-lisp/git/git.el
lib/xemacs/site-lisp/git/git-blame.el
%%NLS%%share/locale/da/LC_MESSAGES/git.mo
%%NLS%%share/locale/de/LC_MESSAGES/git.mo
%%NLS%%share/locale/is/LC_MESSAGES/git.mo
+%%NLS%%share/locale/it/LC_MESSAGES/git.mo
%%NLS%%share/locale/nl/LC_MESSAGES/git.mo
%%NLS%%share/locale/pt_PT/LC_MESSAGES/git.mo
%%NLS%%share/locale/sv/LC_MESSAGES/git.mo
+%%NLS%%share/locale/vi/LC_MESSAGES/git.mo
%%NLS%%share/locale/zh_CN/LC_MESSAGES/git.mo
share/emacs/site-lisp/git/git.el
share/emacs/site-lisp/git/git-blame.el
@@ -311,6 +320,8 @@ share/git-core/templates/info/exclude
%%HTMLDOCS%%%%DOCSDIR%%/git-citool.html
%%HTMLDOCS%%%%DOCSDIR%%/git-clean.html
%%HTMLDOCS%%%%DOCSDIR%%/git-clone.html
+%%HTMLDOCS%%%%DOCSDIR%%/git-column.html
+%%HTMLDOCS%%%%DOCSDIR%%/git-column.txt
%%HTMLDOCS%%%%DOCSDIR%%/git-commit-tree.html
%%HTMLDOCS%%%%DOCSDIR%%/git-commit.html
%%HTMLDOCS%%%%DOCSDIR%%/git-config.html
@@ -917,6 +928,10 @@ share/git-core/templates/info/exclude
%%HTMLDOCS%%%%DOCSDIR%%/RelNotes/1.7.10.1.txt
%%HTMLDOCS%%%%DOCSDIR%%/RelNotes/1.7.10.2.txt
%%HTMLDOCS%%%%DOCSDIR%%/RelNotes/1.7.10.3.txt
+%%HTMLDOCS%%%%DOCSDIR%%/RelNotes/1.7.10.4.txt
+%%HTMLDOCS%%%%DOCSDIR%%/RelNotes/1.7.10.5.txt
+%%HTMLDOCS%%%%DOCSDIR%%/RelNotes/1.7.11.txt
+%%HTMLDOCS%%%%DOCSDIR%%/RelNotes/1.7.11.1.txt
%%GITWEB%%%%EXAMPLESDIR%%/gitweb/gitweb.cgi
%%GITWEB%%%%EXAMPLESDIR%%/gitweb/static/gitweb.js
%%GITWEB%%%%EXAMPLESDIR%%/gitweb/static/gitweb.css
@@ -972,10 +987,9 @@ share/git-core/templates/info/exclude
%%CONTRIB%%share/git-core/contrib/examples/git-svnimport.txt
%%CONTRIB%%share/git-core/contrib/examples/git-tag.sh
%%CONTRIB%%share/git-core/contrib/examples/git-verify-tag.sh
+%%CONTRIB%%share/git-core/contrib/fast-import/git-p4.README
%%CONTRIB%%share/git-core/contrib/fast-import/git-import.perl
%%CONTRIB%%share/git-core/contrib/fast-import/git-import.sh
-%%CONTRIB%%share/git-core/contrib/fast-import/git-p4
-%%CONTRIB%%share/git-core/contrib/fast-import/git-p4.bat
%%CONTRIB%%share/git-core/contrib/fast-import/import-directories.perl
%%CONTRIB%%share/git-core/contrib/fast-import/import-tars.perl
%%CONTRIB%%share/git-core/contrib/fast-import/import-zips.py
@@ -1002,6 +1016,23 @@ share/git-core/templates/info/exclude
%%CONTRIB%%share/git-core/contrib/patches/docbook-xsl-manpages-charmap.patch
%%CONTRIB%%share/git-core/contrib/remotes2config.sh
%%CONTRIB%%share/git-core/contrib/rerere-train.sh
+%%CONTRIB%%share/git-core/contrib/persistent-https/client.go
+%%CONTRIB%%share/git-core/contrib/persistent-https/Makefile
+%%CONTRIB%%share/git-core/contrib/persistent-https/README
+%%CONTRIB%%share/git-core/contrib/persistent-https/LICENSE
+%%CONTRIB%%share/git-core/contrib/persistent-https/main.go
+%%CONTRIB%%share/git-core/contrib/persistent-https/proxy.go
+%%CONTRIB%%share/git-core/contrib/persistent-https/socket.go
+%%CONTRIB%%share/git-core/contrib/subtree/t/Makefile
+%%CONTRIB%%share/git-core/contrib/subtree/t/t7900-subtree.sh
+%%CONTRIB%%share/git-core/contrib/subtree/COPYING
+%%CONTRIB%%share/git-core/contrib/subtree/INSTALL
+%%CONTRIB%%share/git-core/contrib/subtree/Makefile
+%%CONTRIB%%share/git-core/contrib/subtree/README
+%%CONTRIB%%share/git-core/contrib/subtree/git-subtree.sh
+%%CONTRIB%%share/git-core/contrib/subtree/git-subtree.txt
+%%CONTRIB%%share/git-core/contrib/subtree/.gitignore
+%%CONTRIB%%share/git-core/contrib/subtree/todo
%%CONTRIB%%share/git-core/contrib/stats/git-common-hash
%%CONTRIB%%share/git-core/contrib/stats/mailmap.pl
%%CONTRIB%%share/git-core/contrib/stats/packinfo.pl
@@ -1017,6 +1048,8 @@ share/git-core/templates/info/exclude
%%GITWEB%%@dirrm %%EXAMPLESDIR%%/gitweb
%%GITWEB%%@dirrm %%EXAMPLESDIR%%
%%PERLSUB%%@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Git
+%%PERLSUB%%@dirrmtry %%SITE_PERL%%/Git/SVN/Memoize
+%%PERLSUB%%@dirrmtry %%SITE_PERL%%/Git/SVN
%%PERLSUB%%@dirrmtry %%SITE_PERL%%/Git
@dirrm lib/xemacs/site-lisp/git
@dirrmtry lib/xemacs/site-lisp
@@ -1060,6 +1093,9 @@ share/git-core/templates/info/exclude
%%CONTRIB%%@dirrm share/git-core/contrib/mw-to-git
%%CONTRIB%%@dirrm share/git-core/contrib/p4import
%%CONTRIB%%@dirrm share/git-core/contrib/patches
+%%CONTRIB%%@dirrm share/git-core/contrib/persistent-https
+%%CONTRIB%%@dirrm share/git-core/contrib/subtree/t
+%%CONTRIB%%@dirrm share/git-core/contrib/subtree
%%CONTRIB%%@dirrm share/git-core/contrib/stats
%%CONTRIB%%@dirrm share/git-core/contrib/svn-fe
%%CONTRIB%%@dirrm share/git-core/contrib/thunderbird-patch-inline