aboutsummaryrefslogtreecommitdiff
path: root/devel/git
diff options
context:
space:
mode:
authorWesley Shields <wxs@FreeBSD.org>2011-10-05 16:30:35 +0000
committerWesley Shields <wxs@FreeBSD.org>2011-10-05 16:30:35 +0000
commit05883c3adcba1cab8a9323914bc7ee9808f370ac (patch)
treee45010a443b8953bfd612f34851d55be356b5aee /devel/git
parentcb7500ecc09c86012dec9039ca6e543583e6c4de (diff)
Notes
Diffstat (limited to 'devel/git')
-rw-r--r--devel/git/Makefile18
-rw-r--r--devel/git/distinfo12
-rw-r--r--devel/git/files/patch-Makefile13
-rw-r--r--devel/git/pkg-plist27
4 files changed, 45 insertions, 25 deletions
diff --git a/devel/git/Makefile b/devel/git/Makefile
index 83d9ed957373..8bca25ae3d84 100644
--- a/devel/git/Makefile
+++ b/devel/git/Makefile
@@ -6,13 +6,10 @@
#
PORTNAME= git
-PORTVERSION= 1.7.6.1
+PORTVERSION= 1.7.7
CATEGORIES= devel
-MASTER_SITES= ${MASTER_SITE_GENTOO} \
- http://www.glenbarber.us/ports/${CATEGORIES}/${PORTNAME}
-
-MASTER_SITE_SUBDIR= software/scm/${PORTNAME} \
- distfiles
+MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
+PROJECTHOST= git-core
DISTFILES= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX} \
${PORTNAME}-manpages-${PORTVERSION}${EXTRACT_SUFX}
# We manually extract the htmldocs.
@@ -117,6 +114,7 @@ MAN1= git.1 \
git-remote-ext.1 \
git-remote-fd.1 \
git-remote-helpers.1 \
+ git-remote-testgit.1 \
git-remote.1 \
git-repack.1 \
git-replace.1 \
@@ -172,14 +170,14 @@ MAN7= gitcli.7 \
gitdiffcore.7 \
gittutorial-2.7 \
gitworkflows.7 \
- gitrevisions.7
+ gitrevisions.7 \
+ gitnamespaces.7
CONFLICTS?= git-subversion-[0-9]*
SUB_FILES= pkg-message
PKGMESSAGE= ${WRKDIR}/pkg-message
-USE_BZIP2= yes
GNU_CONFIGURE= yes
USE_GMAKE= yes
CFLAGS+= -I${LOCALBASE}/include
@@ -383,10 +381,8 @@ post-build:
${WRKSRC}/contrib/p4import/git-p4import.py
@${CP} ${WRKSRC}/contrib/p4import/git-p4import.py \
${WRKSRC}/contrib/p4import/git-p4import
-.endif
- @${REINPLACE_CMD} -e 's|#\. /usr/share/doc/git-core/contrib/hooks/post-receive-email|#. ${PREFIX}/share/git-core/contrib/hooks/post-receive-email|' \
- ${WRKSRC}/templates/blt/hooks/post-receive.sample
@${FIND} ${WRKSRC} -name "*.bak" -delete
+.endif
post-install:
(cd ${WRKDIR}/man1/ && ${COPYTREE_SHARE} \* ${MANPREFIX}/man/man1)
diff --git a/devel/git/distinfo b/devel/git/distinfo
index fc30883e4f3a..783c781f76d3 100644
--- a/devel/git/distinfo
+++ b/devel/git/distinfo
@@ -1,6 +1,6 @@
-SHA256 (git-1.7.6.1.tar.bz2) = 856d4197ef7172938b0b44e55174c7d7ddfaf5e844e04960322c49eda9f3a246
-SIZE (git-1.7.6.1.tar.bz2) = 2811203
-SHA256 (git-manpages-1.7.6.1.tar.bz2) = faece1418e72d90ed9ee65e59fe89489e504db9b76e8325a2505e8fb61598a44
-SIZE (git-manpages-1.7.6.1.tar.bz2) = 318418
-SHA256 (git-htmldocs-1.7.6.1.tar.bz2) = 6f03a7ed0c2db4d47c22bb27c27249be9bc3c50b72e108d7dca5227917b2de7a
-SIZE (git-htmldocs-1.7.6.1.tar.bz2) = 978820
+SHA256 (git-1.7.7.tar.gz) = 5a977bc01e4989b9928345e99aab15ce896cf5897c6e32eb449538574df377f6
+SIZE (git-1.7.7.tar.gz) = 3475448
+SHA256 (git-manpages-1.7.7.tar.gz) = dde1ffaee0d90cce80f98126c5d9013c6687dc6f0b26bd12d61e229346701ecb
+SIZE (git-manpages-1.7.7.tar.gz) = 476036
+SHA256 (git-htmldocs-1.7.7.tar.gz) = bcb11eda56ac74687cc6852f6ee104ab5dcf13039546616c608783cebc7f4a40
+SIZE (git-htmldocs-1.7.7.tar.gz) = 1391354
diff --git a/devel/git/files/patch-Makefile b/devel/git/files/patch-Makefile
index 844cfb06741a..5c4f305f6316 100644
--- a/devel/git/files/patch-Makefile
+++ b/devel/git/files/patch-Makefile
@@ -1,6 +1,6 @@
---- Makefile.orig 2011-05-26 18:12:35.000000000 -0400
-+++ Makefile 2011-05-27 10:45:37.874486678 -0400
-@@ -262,8 +262,8 @@
+--- ./Makefile.orig 2011-10-05 10:02:13.605889189 -0400
++++ ./Makefile 2011-10-05 10:05:22.414881672 -0400
+@@ -278,8 +278,8 @@
# CFLAGS and LDFLAGS are for the users to override from the command line.
@@ -11,7 +11,7 @@
ALL_CFLAGS = $(CPPFLAGS) $(CFLAGS)
ALL_LDFLAGS = $(LDFLAGS)
STRIP ?= strip
-@@ -283,13 +283,13 @@
+@@ -299,14 +299,14 @@
prefix = $(HOME)
bindir_relative = bin
bindir = $(prefix)/$(bindir_relative)
@@ -20,6 +20,7 @@
+mandir = $(prefix)/man
+infodir = $(prefix)/info
gitexecdir = libexec/git-core
+ mergetoolsdir = $(gitexecdir)/mergetools
sharedir = $(prefix)/share
-gitwebdir = $(sharedir)/gitweb
+gitwebdir = $(sharedir)/examples/git/gitweb
@@ -29,7 +30,7 @@
ETC_GITCONFIG = $(sysconfdir)/gitconfig
ETC_GITATTRIBUTES = $(sysconfdir)/gitattributes
lib = lib
-@@ -298,20 +298,20 @@
+@@ -315,20 +315,20 @@
export prefix bindir sharedir sysconfdir gitwebdir
@@ -64,7 +65,7 @@
export TCL_PATH TCLTK_PATH
-@@ -1290,9 +1290,9 @@
+@@ -1356,9 +1356,9 @@
ifndef NO_OPENSSL
OPENSSL_LIBSSL = -lssl
diff --git a/devel/git/pkg-plist b/devel/git/pkg-plist
index 16da9e1cae4e..75e541b44f76 100644
--- a/devel/git/pkg-plist
+++ b/devel/git/pkg-plist
@@ -183,6 +183,21 @@ libexec/git-core/git-verify-tag
libexec/git-core/git-web--browse
libexec/git-core/git-whatchanged
libexec/git-core/git-write-tree
+libexec/git-core/mergetools/xxdiff
+libexec/git-core/mergetools/tortoisemerge
+libexec/git-core/mergetools/tkdiff
+libexec/git-core/mergetools/bc3
+libexec/git-core/mergetools/kdiff3
+libexec/git-core/mergetools/vim
+libexec/git-core/mergetools/meld
+libexec/git-core/mergetools/ecmerge
+libexec/git-core/mergetools/diffuse
+libexec/git-core/mergetools/p4merge
+libexec/git-core/mergetools/kompare
+libexec/git-core/mergetools/opendiff
+libexec/git-core/mergetools/defaults
+libexec/git-core/mergetools/emerge
+libexec/git-core/mergetools/araxis
%%GUI%%bin/gitk
%%PERLSUB%%%%SITE_PERL%%/Git.pm
%%PERLSUB%%%%SITE_PERL%%/%%PERL_ARCH%%/auto/Git/.packlist
@@ -193,8 +208,6 @@ share/emacs/site-lisp/git/git-blame.el
share/git-core/templates/description
share/git-core/templates/hooks/applypatch-msg.sample
share/git-core/templates/hooks/commit-msg.sample
-share/git-core/templates/hooks/post-commit.sample
-share/git-core/templates/hooks/post-receive.sample
share/git-core/templates/hooks/post-update.sample
share/git-core/templates/hooks/pre-applypatch.sample
share/git-core/templates/hooks/pre-commit.sample
@@ -368,6 +381,8 @@ share/git-core/templates/info/exclude
%%HTMLDOCS%%%%DOCSDIR%%/git-remote-fd.txt
%%HTMLDOCS%%%%DOCSDIR%%/git-remote-helpers.html
%%HTMLDOCS%%%%DOCSDIR%%/git-remote-helpers.txt
+%%HTMLDOCS%%%%DOCSDIR%%/git-remote-testgit.html
+%%HTMLDOCS%%%%DOCSDIR%%/git-remote-testgit.txt
%%HTMLDOCS%%%%DOCSDIR%%/git-repack.html
%%HTMLDOCS%%%%DOCSDIR%%/git-replace.html
%%HTMLDOCS%%%%DOCSDIR%%/git-replace.txt
@@ -423,6 +438,9 @@ share/git-core/templates/info/exclude
%%HTMLDOCS%%%%DOCSDIR%%/gitignore.html
%%HTMLDOCS%%%%DOCSDIR%%/gitk.html
%%HTMLDOCS%%%%DOCSDIR%%/gitmodules.html
+%%HTMLDOCS%%%%DOCSDIR%%/gitmodules.html
+%%HTMLDOCS%%%%DOCSDIR%%/gitnamespaces.html
+%%HTMLDOCS%%%%DOCSDIR%%/gitnamespaces.txt
%%HTMLDOCS%%%%DOCSDIR%%/gitrepository-layout.html
%%HTMLDOCS%%%%DOCSDIR%%/gittutorial-2.html
%%HTMLDOCS%%%%DOCSDIR%%/gittutorial.html
@@ -830,6 +848,10 @@ share/git-core/templates/info/exclude
%%HTMLDOCS%%%%DOCSDIR%%/RelNotes/1.7.5.4.txt
%%HTMLDOCS%%%%DOCSDIR%%/RelNotes/1.7.6.txt
%%HTMLDOCS%%%%DOCSDIR%%/RelNotes/1.7.6.1.txt
+%%HTMLDOCS%%%%DOCSDIR%%/RelNotes/1.7.6.2.txt
+%%HTMLDOCS%%%%DOCSDIR%%/RelNotes/1.7.6.3.txt
+%%HTMLDOCS%%%%DOCSDIR%%/RelNotes/1.7.6.4.txt
+%%HTMLDOCS%%%%DOCSDIR%%/RelNotes/1.7.7.txt
%%GITWEB%%%%EXAMPLESDIR%%/gitweb/gitweb.cgi
%%GITWEB%%%%EXAMPLESDIR%%/gitweb/static/gitweb.js
%%GITWEB%%%%EXAMPLESDIR%%/gitweb/static/gitweb.css
@@ -934,6 +956,7 @@ share/git-core/templates/info/exclude
%%HTMLDOCS%%@dirrm %%DOCSDIR%%/RelNotes
%%HTMLDOCS%%@dirrm %%DOCSDIR%%/howto
%%HTMLDOCS%%@dirrm %%DOCSDIR%%
+@dirrm libexec/git-core/mergetools
@dirrm libexec/git-core
@dirrmtry share/git-core/templates/branches
@dirrmtry share/git-core/templates/hooks