aboutsummaryrefslogtreecommitdiff
path: root/devel/git
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2016-03-21 10:50:29 +0000
committerRenato Botelho <garga@FreeBSD.org>2016-03-21 10:50:29 +0000
commit45aff9f96b5eee9945a496e3933c0d2d4eeb8439 (patch)
treed47ae5cf930ffd4d920a2cb65160d15b1bed458b /devel/git
parent42ccace4e1119b7c0de5ed7718fe916d7a9e2c6c (diff)
downloadports-45aff9f96b5eee9945a496e3933c0d2d4eeb8439.tar.gz
ports-45aff9f96b5eee9945a496e3933c0d2d4eeb8439.zip
Notes
Diffstat (limited to 'devel/git')
-rw-r--r--devel/git/Makefile5
-rw-r--r--devel/git/files/patch-git-compat-util.h13
2 files changed, 14 insertions, 4 deletions
diff --git a/devel/git/Makefile b/devel/git/Makefile
index d41268e287a9..c7527aa1adbc 100644
--- a/devel/git/Makefile
+++ b/devel/git/Makefile
@@ -3,6 +3,7 @@
PORTNAME= git
DISTVERSION= 2.7.4
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= KERNEL_ORG/software/scm/git
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} \
@@ -97,10 +98,6 @@ CVS_RUN_DEPENDS= cvsps:${PORTSDIR}/devel/cvsps
.include <bsd.port.options.mk>
-.if ${OSVERSION} < 1000000
-USE_GCC= 4.8+
-.endif
-
# This is intentionally not exposed as an option.
.ifndef (WITH_DEBUG)
ALL_TARGET= all strip
diff --git a/devel/git/files/patch-git-compat-util.h b/devel/git/files/patch-git-compat-util.h
new file mode 100644
index 000000000000..92a9417304bc
--- /dev/null
+++ b/devel/git/files/patch-git-compat-util.h
@@ -0,0 +1,13 @@
+--- git-compat-util.h.orig 2016-03-21 10:34:43 UTC
++++ git-compat-util.h
+@@ -715,8 +715,8 @@ static inline size_t st_add(size_t a, si
+ (uintmax_t)a, (uintmax_t)b);
+ return a + b;
+ }
+-#define st_add3(a,b,c) st_add((a),st_add((b),(c)))
+-#define st_add4(a,b,c,d) st_add((a),st_add3((b),(c),(d)))
++#define st_add3(a,b,c) st_add(st_add((a),(b)),(c))
++#define st_add4(a,b,c,d) st_add(st_add3((a),(b),(c)),(d))
+
+ static inline size_t st_mult(size_t a, size_t b)
+ {