aboutsummaryrefslogtreecommitdiff
path: root/devel/git
diff options
context:
space:
mode:
authorWesley Shields <wxs@FreeBSD.org>2008-07-14 15:20:39 +0000
committerWesley Shields <wxs@FreeBSD.org>2008-07-14 15:20:39 +0000
commit493d7262ee710d08b0eeb7a72a988cc138ce9e2b (patch)
treebe7205c24d45a67f8567190395b7bf13b8b5a110 /devel/git
parent0317f0a5523ea5f965e0cd4dbd581adbf16b44f5 (diff)
downloadports-493d7262ee710d08b0eeb7a72a988cc138ce9e2b.tar.gz
ports-493d7262ee710d08b0eeb7a72a988cc138ce9e2b.zip
Notes
Diffstat (limited to 'devel/git')
-rw-r--r--devel/git/Makefile32
-rw-r--r--devel/git/distinfo12
-rw-r--r--devel/git/files/pkg-message.in14
-rw-r--r--devel/git/pkg-plist8
4 files changed, 56 insertions, 10 deletions
diff --git a/devel/git/Makefile b/devel/git/Makefile
index aa0299fd33be..0a3fed3cbee6 100644
--- a/devel/git/Makefile
+++ b/devel/git/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= git
-PORTVERSION= 1.5.6
+PORTVERSION= 1.5.6.2
CATEGORIES= devel
MASTER_SITES= http://www.kernel.org/pub/software/scm/git/
DISTFILES= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX} \
@@ -158,6 +158,9 @@ MAN5= gitattributes.5 \
gitignore.5 \
gitmodules.5
+SUB_FILES= pkg-message
+PKGMESSAGE= ${WRKDIR}/pkg-message
+
USE_BZIP2= yes
USE_PERL5= yes
USE_PYTHON= yes
@@ -177,11 +180,12 @@ USE_RC_SUBR= git_daemon
SHELLS= /etc/shells
OPTIONS= GUI "Enable building of GUI tools" on \
- SVN "Enable required dependencies for SVN tools" off
+ SVN "Enable required dependencies for SVN tools" off \
+ GITWEB "Install gitweb" off
.include <bsd.port.pre.mk>
-.ifndef WITHOUT_GUI
+.ifndef (WITHOUT_GUI)
MAN1+= git-citool.1 \
git-gui.1 \
gitk.1
@@ -193,11 +197,17 @@ PLIST_SUB+= GUI="@comment "
MAKE_ENV+= NO_TCLTK=yes
.endif
-.ifdef WITH_SVN
+.ifdef (WITH_SVN)
RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Term/ReadKey.pm:${PORTSDIR}/devel/p5-Term-ReadKey \
svn:${PORTSDIR}/devel/subversion
.endif
+.ifdef (WITH_GITWEB)
+PLIST_SUB+= GITWEB=""
+.else
+PLIST_SUB+= GITWEB="@comment "
+.endif
+
pre-patch:
@${REINPLACE_CMD} -e 's|OPENSSLDIR|OPENSSLBASE|g' ${WRKSRC}/Makefile
@@ -236,6 +246,16 @@ post-install:
${PREFIX}/bin/
${INSTALL_SCRIPT} ${WRKSRC}/contrib/fast-import/git-p4 \
${PREFIX}/bin/
+.ifdef (WITH_GITWEB)
+ @${ECHO_MSG} "===> Installing gitweb files"
+ ${MKDIR} ${EXAMPLESDIR}/gitweb
+ ${INSTALL_DATA} ${WRKSRC}/gitweb/INSTALL ${EXAMPLESDIR}/gitweb/
+ ${INSTALL_DATA} ${WRKSRC}/gitweb/README ${EXAMPLESDIR}/gitweb/
+ ${INSTALL_DATA} ${WRKSRC}/gitweb/git-favicon.png ${EXAMPLESDIR}/gitweb/
+ ${INSTALL_DATA} ${WRKSRC}/gitweb/git-logo.png ${EXAMPLESDIR}/gitweb/
+ ${INSTALL_DATA} ${WRKSRC}/gitweb/gitweb.css ${EXAMPLESDIR}/gitweb/
+ ${INSTALL_SCRIPT} ${WRKSRC}/gitweb/gitweb.cgi ${EXAMPLESDIR}/gitweb/
+.endif
@${ECHO_MSG} "===> Updating ${SHELLS}"
@${CP} ${SHELLS} ${SHELLS}.bak
@@ -243,4 +263,8 @@ post-install:
${ECHO_CMD} ${PREFIX}/bin/git-shell) > ${SHELLS}
@${RM} ${SHELLS}.bak
+.ifdef (WITH_GITWEB)
+ @${CAT} ${PKGMESSAGE}
+.endif
+
.include <bsd.port.post.mk>
diff --git a/devel/git/distinfo b/devel/git/distinfo
index f862e2256fa4..3177333fe282 100644
--- a/devel/git/distinfo
+++ b/devel/git/distinfo
@@ -1,6 +1,6 @@
-MD5 (git-1.5.6.tar.bz2) = 76c4efaaa5470a5385e22d99349a97b3
-SHA256 (git-1.5.6.tar.bz2) = 40c070c678821f9a791b23a149123121ddeab0be1747abccf9ac0eff0be4f717
-SIZE (git-1.5.6.tar.bz2) = 1732589
-MD5 (git-manpages-1.5.6.tar.bz2) = 9e74eefba7179944ab88e6f6d75506cf
-SHA256 (git-manpages-1.5.6.tar.bz2) = fffbbebc9f4a47599e33ff91cf7f54f256136e1005c8a22d45cdd16194cbf1bb
-SIZE (git-manpages-1.5.6.tar.bz2) = 210548
+MD5 (git-1.5.6.2.tar.bz2) = 233ed4d128c3f42abc9f39d5ddb4a7d4
+SHA256 (git-1.5.6.2.tar.bz2) = 12305f224c17eb0a67bc4ba491e39830f82ff1c6617dad5af8c5ba9914cf042f
+SIZE (git-1.5.6.2.tar.bz2) = 1739162
+MD5 (git-manpages-1.5.6.2.tar.bz2) = 8e37511848012dc15d6288686cb039d3
+SHA256 (git-manpages-1.5.6.2.tar.bz2) = 4a63bc8e10fb6e6bc2a7bed330444c19a7a7b172320560dec00e69f973408065
+SIZE (git-manpages-1.5.6.2.tar.bz2) = 214791
diff --git a/devel/git/files/pkg-message.in b/devel/git/files/pkg-message.in
new file mode 100644
index 000000000000..8c9fc7d326c3
--- /dev/null
+++ b/devel/git/files/pkg-message.in
@@ -0,0 +1,14 @@
+
+------------------------------------------------------------------------
+In the directory %%EXAMPLESDIR%%/gitweb you can find all files to
+make gitweb work as a public repository on the web.
+
+All you have to do to make gitweb work is:
+1) Copy the files %%EXAMPLESDIR%%/gitweb/git* to a directory on
+ your web server (e.g. Apache2) in which you are able to execute
+ CGI-scripts.
+2) In gitweb.cgi, adjust the variable $projectroot to point to
+ your git repository (that is where you have your *.git project
+ directories).
+------------------------------------------------------------------------
+
diff --git a/devel/git/pkg-plist b/devel/git/pkg-plist
index 0a3d17fe57ea..4dc49aa1a1b2 100644
--- a/devel/git/pkg-plist
+++ b/devel/git/pkg-plist
@@ -206,6 +206,14 @@ share/git-core/templates/info/exclude
%%GUI%%share/gitk/lib/msgs/de.msg
%%GUI%%share/gitk/lib/msgs/it.msg
%%GUI%%share/gitk/lib/msgs/sv.msg
+%%GITWEB%%%%EXAMPLESDIR%%/gitweb/INSTALL
+%%GITWEB%%%%EXAMPLESDIR%%/gitweb/README
+%%GITWEB%%%%EXAMPLESDIR%%/gitweb/git-favicon.png
+%%GITWEB%%%%EXAMPLESDIR%%/gitweb/git-logo.png
+%%GITWEB%%%%EXAMPLESDIR%%/gitweb/gitweb.cgi
+%%GITWEB%%%%EXAMPLESDIR%%/gitweb/gitweb.css
+%%GITWEB%%@dirrm %%EXAMPLESDIR%%/gitweb
+%%GITWEB%%@dirrm %%EXAMPLESDIR%%
@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Git
@dirrm lib/xemacs/site-lisp/git
@dirrmtry lib/xemacs/site-lisp