aboutsummaryrefslogtreecommitdiff
path: root/devel/gitaly
diff options
context:
space:
mode:
authorMatthias Fechner <mfechner@FreeBSD.org>2018-07-26 13:44:26 +0000
committerMatthias Fechner <mfechner@FreeBSD.org>2018-07-26 13:44:26 +0000
commit86798f5d9dd64015cde92b372e2e98ef5062e5ea (patch)
tree5f09d8d038250c8ad2db5efebae1fd58930ad4c8 /devel/gitaly
parent0086d1a50dcf5782fafa02d65cf1a35433945bbb (diff)
Notes
Diffstat (limited to 'devel/gitaly')
-rw-r--r--devel/gitaly/Makefile13
-rw-r--r--devel/gitaly/distinfo6
-rw-r--r--devel/gitaly/files/patch-ruby_Gemfile4
-rw-r--r--devel/gitaly/pkg-plist9
4 files changed, 20 insertions, 12 deletions
diff --git a/devel/gitaly/Makefile b/devel/gitaly/Makefile
index 64a328aaae5f..22b13ffdba12 100644
--- a/devel/gitaly/Makefile
+++ b/devel/gitaly/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= gitaly
-DISTVERSION= 0.105.0
-PORTREVISION= 1
+DISTVERSION= 0.111.2
CATEGORIES= devel
MAINTAINER= mfechner@FreeBSD.org
@@ -12,13 +11,13 @@ LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
# define dependencies that are required for build and run under MY_DEPENDS
-MY_DEPENDS= git>=2.16.2:devel/git \
+MY_DEPENDS= git>=2.17:devel/git \
rubygem-i18n>=0:devel/rubygem-i18n \
- rubygem-rugged>=0.27.1:devel/rubygem-rugged \
+ rubygem-rugged>=0.27.2:devel/rubygem-rugged \
rubygem-github-linguist53>=5.3.3:textproc/rubygem-github-linguist53 \
rubygem-bundler>0:sysutils/rubygem-bundler \
rubygem-gitlab-markup>=1.6.2:textproc/rubygem-gitlab-markup \
- rubygem-gitaly-proto>=0.101.0:net/rubygem-gitaly-proto \
+ rubygem-gitaly-proto>=0.105.0:net/rubygem-gitaly-proto \
rubygem-activesupport50>=5.0.2:devel/rubygem-activesupport50 \
rubygem-rdoc>=6.0:devel/rubygem-rdoc \
rubygem-gitlab-gollum-lib>=4.2:www/rubygem-gitlab-gollum-lib \
@@ -29,7 +28,7 @@ MY_DEPENDS= git>=2.16.2:devel/git \
rubygem-licensee8>=8.9.0:devel/rubygem-licensee8 \
rubygem-google-protobuf351>=3.5.1:devel/rubygem-google-protobuf351
-BUILD_DEPENDS= go>=1.8:lang/go \
+BUILD_DEPENDS= go>=1.9:lang/go \
gem:devel/ruby-gems \
${MY_DEPENDS}
@@ -42,7 +41,7 @@ USE_RUBY= yes
USE_GITLAB= yes
GL_ACCOUNT= gitlab-org
# Find this here: https://gitlab.com/gitlab-org/gitaly/tags
-GL_COMMIT= 90ec422b0e76840075010476898637a92f287245
+GL_COMMIT= 39b113e394a7773d3c5781180119f4dbcbec7bd5
post-patch:
${REINPLACE_CMD} -e "s|%%PREFIX%%|${PREFIX}|" ${WRKSRC}/config.toml.example
diff --git a/devel/gitaly/distinfo b/devel/gitaly/distinfo
index c0e9994697cb..d2883a119793 100644
--- a/devel/gitaly/distinfo
+++ b/devel/gitaly/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1530370061
-SHA256 (gitlab-org-gitaly-90ec422b0e76840075010476898637a92f287245_GL0.tar.gz) = 0ec6140877d53dae22247d16ddb89374cade68ab47800b74e649e2a073c63e71
-SIZE (gitlab-org-gitaly-90ec422b0e76840075010476898637a92f287245_GL0.tar.gz) = 4145322
+TIMESTAMP = 1532595343
+SHA256 (gitlab-org-gitaly-39b113e394a7773d3c5781180119f4dbcbec7bd5_GL0.tar.gz) = 881bd5b82e33462029d483bd416adba453330bd6d4f22197a11626fa140ecdde
+SIZE (gitlab-org-gitaly-39b113e394a7773d3c5781180119f4dbcbec7bd5_GL0.tar.gz) = 3604279
diff --git a/devel/gitaly/files/patch-ruby_Gemfile b/devel/gitaly/files/patch-ruby_Gemfile
index d83fc00a8cdb..2af73ae5404d 100644
--- a/devel/gitaly/files/patch-ruby_Gemfile
+++ b/devel/gitaly/files/patch-ruby_Gemfile
@@ -1,8 +1,8 @@
---- ruby/Gemfile.orig 2018-06-04 16:17:50 UTC
+--- ruby/Gemfile.orig 2018-07-20 10:35:57 UTC
+++ ruby/Gemfile
@@ -5,12 +5,13 @@ gem 'github-linguist', '~> 5.3.3', requi
gem 'gitlab-markup', '~> 1.6.2'
- gem 'gitaly-proto', '~> 0.101.0', require: 'gitaly'
+ gem 'gitaly-proto', '~> 0.105.0', require: 'gitaly'
gem 'activesupport', '~> 5.0.2'
-gem 'rdoc', '~> 4.2'
+gem 'rdoc', '~> 6.0'
diff --git a/devel/gitaly/pkg-plist b/devel/gitaly/pkg-plist
index 1d43d4c202b2..42dd7efb75ff 100644
--- a/devel/gitaly/pkg-plist
+++ b/devel/gitaly/pkg-plist
@@ -20,9 +20,15 @@
%%DATADIR%%/ruby/lib/gitaly_server/wiki_service.rb
%%DATADIR%%/ruby/lib/gitlab/config.rb
%%DATADIR%%/ruby/lib/gitlab/git.rb
+%%DATADIR%%/ruby/lib/gitlab/git/blob.rb
+%%DATADIR%%/ruby/lib/gitlab/git/commit.rb
%%DATADIR%%/ruby/lib/gitlab/git/gitaly_remote_repository.rb
%%DATADIR%%/ruby/lib/gitlab/git/gitlab_projects.rb
+%%DATADIR%%/ruby/lib/gitlab/git/lfs_changes.rb
+%%DATADIR%%/ruby/lib/gitlab/git/pre_receive_error.rb
+%%DATADIR%%/ruby/lib/gitlab/git/remote_mirror.rb
%%DATADIR%%/ruby/lib/gitlab/git/repository.rb
+%%DATADIR%%/ruby/lib/gitlab/git/wiki.rb
%%DATADIR%%/ruby/lib/gitlab/git_logger.rb
%%DATADIR%%/ruby/lib/gitlab/gitaly_client.rb
%%DATADIR%%/ruby/lib/gitlab/gollum.rb
@@ -69,6 +75,7 @@
%%DATADIR%%/ruby/vendor/gitlab_git/lib/gitlab/git/operation_service.rb
%%DATADIR%%/ruby/vendor/gitlab_git/lib/gitlab/git/path_helper.rb
%%DATADIR%%/ruby/vendor/gitlab_git/lib/gitlab/git/popen.rb
+%%DATADIR%%/ruby/vendor/gitlab_git/lib/gitlab/git/pre_receive_error.rb
%%DATADIR%%/ruby/vendor/gitlab_git/lib/gitlab/git/raw_diff_change.rb
%%DATADIR%%/ruby/vendor/gitlab_git/lib/gitlab/git/ref.rb
%%DATADIR%%/ruby/vendor/gitlab_git/lib/gitlab/git/remote_mirror.rb
@@ -89,11 +96,13 @@
%%DATADIR%%/ruby/vendor/gitlab_git/lib/gitlab/git/tree.rb
%%DATADIR%%/ruby/vendor/gitlab_git/lib/gitlab/git/user.rb
%%DATADIR%%/ruby/vendor/gitlab_git/lib/gitlab/git/util.rb
+%%DATADIR%%/ruby/vendor/gitlab_git/lib/gitlab/git/version.rb
%%DATADIR%%/ruby/vendor/gitlab_git/lib/gitlab/git/wiki.rb
%%DATADIR%%/ruby/vendor/gitlab_git/lib/gitlab/git/wiki_file.rb
%%DATADIR%%/ruby/vendor/gitlab_git/lib/gitlab/git/wiki_page.rb
%%DATADIR%%/ruby/vendor/gitlab_git/lib/gitlab/git/wiki_page_version.rb
%%DATADIR%%/ruby/vendor/gitlab_git/lib/gitlab/utils/strong_memoize.rb
+%%DATADIR%%/ruby/vendor/gitlab_git/lib/gitlab/version_info.rb
@(,,555) %%DATADIR%%/bin/gitaly
@(,,555) %%DATADIR%%/bin/gitaly-ssh
@sample %%DATADIR%%/config.toml.sample