aboutsummaryrefslogtreecommitdiff
path: root/devel/gitg
diff options
context:
space:
mode:
authorRuslan Makhmatkhanov <rm@FreeBSD.org>2015-02-15 20:31:14 +0000
committerRuslan Makhmatkhanov <rm@FreeBSD.org>2015-02-15 20:31:14 +0000
commit634a6a9f44a7166e361f22e3ff710f5fffeaded6 (patch)
tree9f29cf206c4f1811785c1809bb3a4ec644a0eec1 /devel/gitg
parent9370b71bc965de27a64b8b79b621cb6519d73520 (diff)
downloadports-634a6a9f44a7166e361f22e3ff710f5fffeaded6.tar.gz
ports-634a6a9f44a7166e361f22e3ff710f5fffeaded6.zip
Notes
Diffstat (limited to 'devel/gitg')
-rw-r--r--devel/gitg/Makefile29
-rw-r--r--devel/gitg/distinfo4
-rw-r--r--devel/gitg/pkg-plist77
3 files changed, 61 insertions, 49 deletions
diff --git a/devel/gitg/Makefile b/devel/gitg/Makefile
index b5b33f5a4daa..e1f7653716ba 100644
--- a/devel/gitg/Makefile
+++ b/devel/gitg/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= gitg
-PORTVERSION= 0.2.7
-PORTREVISION= 1
+PORTVERSION= 3.14.1
CATEGORIES= devel deskutils gnome
MASTER_SITES= GNOME
@@ -13,29 +12,39 @@ COMMENT= GTK-based git repository viewer
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
-BUILD_DEPENDS= gsettings-desktop-schemas>=0:${PORTSDIR}/devel/gsettings-desktop-schemas
-RUN_DEPENDS= gsettings-desktop-schemas>=0:${PORTSDIR}/devel/gsettings-desktop-schemas \
- git:${PORTSDIR}/devel/git
+LIB_DEPENDS= libjson-glib-1.0.so:${PORTSDIR}/devel/json-glib \
+ libgee-0.8.so:${PORTSDIR}/devel/libgee \
+ libgit2-glib-1.0.so:${PORTSDIR}/devel/libgit2-glib \
+ libpeas-1.0.so:${PORTSDIR}/devel/libpeas \
+ libgtkspell3-3.so:${PORTSDIR}/textproc/gtkspell3 \
+ libwebkit2gtk-3.0.so:${PORTSDIR}/www/webkit-gtk3
+BUILD_DEPENDS= gsettings-desktop-schemas>=0:${PORTSDIR}/devel/gsettings-desktop-schemas \
+ valac:${PORTSDIR}/lang/vala
+RUN_DEPENDS= gsettings-desktop-schemas>=0:${PORTSDIR}/devel/gsettings-desktop-schemas
CONFLICTS= gitg0-[0-9]*
-USES= tar:xz gettext gmake pkgconfig pathfix libtool
+USES= desktop-file-utils gmake libtool pathfix pkgconfig tar:xz
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-silent-rules \
--disable-maintainer-mode \
--enable-compile-warnings=no
-USE_GNOME= glib20 gtk30 gtksourceview3 intlhack
+USE_GNOME= glib20 gtk30 gtksourceview3 intlhack introspection
INSTALL_TARGET= install-strip
INSTALLS_ICONS= yes
GLIB_SCHEMAS= org.gnome.gitg.gschema.xml
CPPFLAGS+= -I${LOCALBASE}/include
-LIBS+= -L${LOCALBASE}/lib
+LDFLAGS+= -L${LOCALBASE}/lib
-OPTIONS_DEFINE= NLS
+OPTIONS_DEFINE= DEBUG NLS PYTHON
OPTIONS_SUB= yes
+DEBUG_CONFIGURE_ENABLE= debug
NLS_USES= gettext
-NLS_CONFIGURE_ENABLE=nls
+NLS_CONFIGURE_ENABLE= nls
+PYTHON_USES= python:3
+PYTHON_CONFIGURE_ENABLE= python
+PYTHON_PLIST_SUB= PYTHON_SUFFIX=${PYTHON_SUFFIX}
.include <bsd.port.mk>
diff --git a/devel/gitg/distinfo b/devel/gitg/distinfo
index c6b0f51b6b1e..d55b9a6ff1a0 100644
--- a/devel/gitg/distinfo
+++ b/devel/gitg/distinfo
@@ -1,2 +1,2 @@
-SHA256 (gitg-0.2.7.tar.xz) = c07fc4fc6cef31a06f0b9daa2ed23a5d0f6cb0a10a728324970675fc7001d095
-SIZE (gitg-0.2.7.tar.xz) = 528904
+SHA256 (gitg-3.14.1.tar.xz) = 8e485b35d918fddc255c3bf5d5c139d0a8b684bd922a8913153b1b7781357057
+SIZE (gitg-3.14.1.tar.xz) = 1197524
diff --git a/devel/gitg/pkg-plist b/devel/gitg/pkg-plist
index bd42bdf963da..4abee2da32fe 100644
--- a/devel/gitg/pkg-plist
+++ b/devel/gitg/pkg-plist
@@ -1,68 +1,71 @@
bin/gitg
-include/libgitg-1.0/libgitg/gitg-changed-file.h
-include/libgitg-1.0/libgitg/gitg-color.h
-include/libgitg-1.0/libgitg/gitg-command.h
-include/libgitg-1.0/libgitg/gitg-commit.h
-include/libgitg-1.0/libgitg/gitg-config.h
-include/libgitg-1.0/libgitg/gitg-hash.h
-include/libgitg-1.0/libgitg/gitg-io.h
-include/libgitg-1.0/libgitg/gitg-lane.h
-include/libgitg-1.0/libgitg/gitg-line-parser.h
-include/libgitg-1.0/libgitg/gitg-ref.h
-include/libgitg-1.0/libgitg/gitg-repository.h
-include/libgitg-1.0/libgitg/gitg-revision.h
-include/libgitg-1.0/libgitg/gitg-runner.h
-include/libgitg-1.0/libgitg/gitg-shell.h
-lib/libgitg-1.0.a
+include/libgitg-ext-1.0/libgitg-ext/libgitg-ext.h
+include/libgitg-1.0/libgitg/libgitg.h
lib/libgitg-1.0.so
lib/libgitg-1.0.so.0
lib/libgitg-1.0.so.0.0.0
+lib/libgitg-ext-1.0.so
+lib/libgitg-ext-1.0.so.0
+lib/libgitg-ext-1.0.so.0.0.0
+lib/gitg/plugins/diff.plugin
+lib/gitg/plugins/files.plugin
+lib/gitg/plugins/libdiff.so
+lib/gitg/plugins/libfiles.so
+%%PYTHON%%%%PYTHON_SITELIBDIR%%/gi/overrides/GitgExt.py
+%%PYTHON%%%%PYTHON_SITELIBDIR%%/gi/overrides/__pycache__/GitgExt.cpython-%%PYTHON_SUFFIX%%.pyc
+%%PYTHON%%%%PYTHON_SITELIBDIR%%/gi/overrides/__pycache__/GitgExt.cpython-%%PYTHON_SUFFIX%%.pyo
+lib/girepository-1.0/GitgExt-1.0.typelib
+lib/girepository-1.0/Gitg-1.0.typelib
+libdata/pkgconfig/libgitg-ext-1.0.pc
libdata/pkgconfig/libgitg-1.0.pc
man/man1/gitg.1.gz
+share/appdata/gitg.appdata.xml
share/applications/gitg.desktop
-%%DATADIR%%/icons/gitg.svg
-%%DATADIR%%/icons/gitg128x128.png
-%%DATADIR%%/icons/gitg16x16.png
-%%DATADIR%%/icons/gitg22x22.png
-%%DATADIR%%/icons/gitg24x24.png
-%%DATADIR%%/icons/gitg32x32.png
-%%DATADIR%%/icons/gitg48x48.png
-%%DATADIR%%/icons/gitg64x64.png
-%%DATADIR%%/language-specs/gitgdiff.lang
-%%DATADIR%%/styles/gitgstyle.xml
-%%DATADIR%%/ui/gitg-commit-menu.ui
-%%DATADIR%%/ui/gitg-menus.xml
-%%DATADIR%%/ui/gitg-new-branch.ui
-%%DATADIR%%/ui/gitg-preferences.ui
-%%DATADIR%%/ui/gitg-repository.ui
-%%DATADIR%%/ui/gitg-revision-changes-panel.ui
-%%DATADIR%%/ui/gitg-revision-details-panel.ui
-%%DATADIR%%/ui/gitg-revision-files-panel.ui
-%%DATADIR%%/ui/gitg-tag.ui
-%%DATADIR%%/ui/gitg-ui.xml
-%%DATADIR%%/ui/gitg-window.ui
+share/gir-1.0/Gitg-1.0.gir
+share/gir-1.0/GitgExt-1.0.gir
share/icons/hicolor/16x16/apps/gitg.png
share/icons/hicolor/22x22/apps/gitg.png
share/icons/hicolor/24x24/apps/gitg.png
share/icons/hicolor/32x32/apps/gitg.png
share/icons/hicolor/48x48/apps/gitg.png
-share/icons/hicolor/scalable/apps/gitg.svg
+share/icons/hicolor/256x256/apps/gitg.png
+%%NLS%%share/locale/as/LC_MESSAGES/gitg.mo
+%%NLS%%share/locale/ca/LC_MESSAGES/gitg.mo
+%%NLS%%share/locale/ca@valencia/LC_MESSAGES/gitg.mo
+%%NLS%%share/locale/cs/LC_MESSAGES/gitg.mo
%%NLS%%share/locale/da/LC_MESSAGES/gitg.mo
%%NLS%%share/locale/de/LC_MESSAGES/gitg.mo
+%%NLS%%share/locale/el/LC_MESSAGES/gitg.mo
%%NLS%%share/locale/en_GB/LC_MESSAGES/gitg.mo
%%NLS%%share/locale/es/LC_MESSAGES/gitg.mo
+%%NLS%%share/locale/fi/LC_MESSAGES/gitg.mo
%%NLS%%share/locale/fr/LC_MESSAGES/gitg.mo
%%NLS%%share/locale/gl/LC_MESSAGES/gitg.mo
+%%NLS%%share/locale/he/LC_MESSAGES/gitg.mo
+%%NLS%%share/locale/hu/LC_MESSAGES/gitg.mo
+%%NLS%%share/locale/id/LC_MESSAGES/gitg.mo
%%NLS%%share/locale/it/LC_MESSAGES/gitg.mo
%%NLS%%share/locale/ko/LC_MESSAGES/gitg.mo
%%NLS%%share/locale/lt/LC_MESSAGES/gitg.mo
+%%NLS%%share/locale/lv/LC_MESSAGES/gitg.mo
%%NLS%%share/locale/nb/LC_MESSAGES/gitg.mo
%%NLS%%share/locale/nl/LC_MESSAGES/gitg.mo
%%NLS%%share/locale/pa/LC_MESSAGES/gitg.mo
+%%NLS%%share/locale/pl/LC_MESSAGES/gitg.mo
+%%NLS%%share/locale/pt/LC_MESSAGES/gitg.mo
%%NLS%%share/locale/pt_BR/LC_MESSAGES/gitg.mo
%%NLS%%share/locale/ro/LC_MESSAGES/gitg.mo
%%NLS%%share/locale/ru/LC_MESSAGES/gitg.mo
+%%NLS%%share/locale/sk/LC_MESSAGES/gitg.mo
%%NLS%%share/locale/sl/LC_MESSAGES/gitg.mo
+%%NLS%%share/locale/sr/LC_MESSAGES/gitg.mo
+%%NLS%%share/locale/sr@latin/LC_MESSAGES/gitg.mo
%%NLS%%share/locale/sv/LC_MESSAGES/gitg.mo
+%%NLS%%share/locale/tr/LC_MESSAGES/gitg.mo
%%NLS%%share/locale/uk/LC_MESSAGES/gitg.mo
%%NLS%%share/locale/zh_CN/LC_MESSAGES/gitg.mo
+%%NLS%%share/locale/zh_HK/LC_MESSAGES/gitg.mo
+%%NLS%%share/locale/zh_TW/LC_MESSAGES/gitg.mo
+share/vala/vapi/libgitg-1.0.vapi
+share/vala/vapi/libgitg-ext-1.0.vapi
+%%DATADIR%%/icons/hicolor/scalable/actions/diff-symbolic.svg