aboutsummaryrefslogtreecommitdiff
path: root/devel/gitlab-shell
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2019-06-29 03:51:13 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2019-06-29 03:51:13 +0000
commit3726f942547e374490d375baf83216d7644a7162 (patch)
tree8c7c440762c72012824110ba9cdd44c8c1765017 /devel/gitlab-shell
parent1de291090d9121f4d238a639b441f64372c239c1 (diff)
Convert all Go ports to USES=go
This allows for port testing with lang/go-devel via GO_PORT, setting up the Go build environment in a single place, and is step one in simplifying Go ports that often define too complicated do-build targets themselves. USES=go gains new arguments 'run' to add lang/go to RUN_DEPENDS and 'no_targets' for ports with composite builds that call 'go' themselves and do not need the do-build/do-install targets of USES=go. PR: 238849 Submitted by: dg@syrec.org (also D20745) Reviewed by: mat, tobik Exp-run by: antoine Differential Revision: https://reviews.freebsd.org/D20746
Notes
Notes: svn path=/head/; revision=505321
Diffstat (limited to 'devel/gitlab-shell')
-rw-r--r--devel/gitlab-shell/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/devel/gitlab-shell/Makefile b/devel/gitlab-shell/Makefile
index 0990e55f92d8..107cf6b91df1 100644
--- a/devel/gitlab-shell/Makefile
+++ b/devel/gitlab-shell/Makefile
@@ -10,8 +10,9 @@ COMMENT= GitLab Shell handles git commands for GitLab
LICENSE= MIT
-BUILD_DEPENDS= gem:devel/ruby-gems \
- go>=1.5.3:lang/go
+BUILD_DEPENDS= gem:devel/ruby-gems
+
+USES= go
USE_GITLAB= yes
GL_ACCOUNT= gitlab-org