aboutsummaryrefslogtreecommitdiff
path: root/devel/gitlab-shell
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2016-03-30 19:30:07 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2016-03-30 19:30:07 +0000
commite58157fe938b26c861b853ce8d994ffa84100ba0 (patch)
tree999c40ad5ca5bb2c1ee672370360339105103f65 /devel/gitlab-shell
parent36bd3b6660142e14df3312cf47e9a1ee5fe7c17c (diff)
downloadports-e58157fe938b26c861b853ce8d994ffa84100ba0.tar.gz
ports-e58157fe938b26c861b853ce8d994ffa84100ba0.zip
Notes
Diffstat (limited to 'devel/gitlab-shell')
-rw-r--r--devel/gitlab-shell/Makefile10
-rw-r--r--devel/gitlab-shell/files/patch-config.yml.example2
-rw-r--r--devel/gitlab-shell/pkg-plist27
3 files changed, 16 insertions, 23 deletions
diff --git a/devel/gitlab-shell/Makefile b/devel/gitlab-shell/Makefile
index a47942d54207..a51001f91b10 100644
--- a/devel/gitlab-shell/Makefile
+++ b/devel/gitlab-shell/Makefile
@@ -3,6 +3,7 @@
PORTNAME= gitlab-shell
PORTVERSION= 2.6.10
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= http://ports.toco-domains.de/
DISTNAME= ${PORTNAME}-v${PORTVERSION}
@@ -19,13 +20,12 @@ GROUPS= git
NO_BUILD= yes
NO_ARCH= yes
-do-install:
+post-patch:
${MV} ${WRKSRC}/config.yml.example ${WRKSRC}/config.yml.sample
-post-install:
- ${MKDIR} ${STAGEDIR}/var/log/
- ${TOUCH} ${STAGEDIR}/var/log/gitlab-shell.log
- ${MKDIR} ${STAGEDIR}${DATADIR}
+do-install:
+ @${MKDIR} ${STAGEDIR}${DATADIR}
(cd ${WRKSRC} && ${COPYTREE_SHARE} . ${STAGEDIR}${DATADIR})
+ @${MKDIR} ${STAGEDIR}/var/log/gitlab-shell
.include <bsd.port.mk>
diff --git a/devel/gitlab-shell/files/patch-config.yml.example b/devel/gitlab-shell/files/patch-config.yml.example
index 3282b036414c..ec618f22a66e 100644
--- a/devel/gitlab-shell/files/patch-config.yml.example
+++ b/devel/gitlab-shell/files/patch-config.yml.example
@@ -5,7 +5,7 @@
# Log file.
# Default is gitlab-shell.log in the root directory.
-# log_file: "/home/git/gitlab-shell/gitlab-shell.log"
-+log_file: "/var/log/gitlab-shell.log"
++log_file: "/var/log/gitlab-shell/gitlab-shell.log"
# Log level. INFO by default
log_level: INFO
diff --git a/devel/gitlab-shell/pkg-plist b/devel/gitlab-shell/pkg-plist
index d5f9352bbdf6..a3d8b12c4c18 100644
--- a/devel/gitlab-shell/pkg-plist
+++ b/devel/gitlab-shell/pkg-plist
@@ -10,16 +10,16 @@
%%DATADIR%%/LICENSE
%%DATADIR%%/README.md
%%DATADIR%%/VERSION
-@(git,,555) %%DATADIR%%/bin/check
-@(git,,555) %%DATADIR%%/bin/create-hooks
-@(git,,555) %%DATADIR%%/bin/gitlab-keys
-@(git,,555) %%DATADIR%%/bin/gitlab-projects
-@(git,,555) %%DATADIR%%/bin/gitlab-shell
-@(git,,555) %%DATADIR%%/bin/install
+@(,,555) %%DATADIR%%/bin/check
+@(,,555) %%DATADIR%%/bin/create-hooks
+@(,,555) %%DATADIR%%/bin/gitlab-keys
+@(,,555) %%DATADIR%%/bin/gitlab-projects
+@(,,555) %%DATADIR%%/bin/gitlab-shell
+@(,,555) %%DATADIR%%/bin/install
@sample %%DATADIR%%/config.yml.sample
-%%DATADIR%%/hooks/post-receive
-%%DATADIR%%/hooks/pre-receive
-%%DATADIR%%/hooks/update
+@(,,555) %%DATADIR%%/hooks/post-receive
+@(,,555) %%DATADIR%%/hooks/pre-receive
+@(,,555) %%DATADIR%%/hooks/update
%%DATADIR%%/lib/gitlab_access.rb
%%DATADIR%%/lib/gitlab_access_status.rb
%%DATADIR%%/lib/gitlab_config.rb
@@ -55,11 +55,4 @@
%%DATADIR%%/spec/vcr_cassettes/discover-ok.yml
%%DATADIR%%/support/rewrite-hooks.sh
%%DATADIR%%/support/truncate_repositories.sh
-@(git,,664) /var/log/gitlab-shell.log
-@dir %%DATADIR%%/bin
-@dir %%DATADIR%%/hooks
-@dir %%DATADIR%%/lib
-@dir %%DATADIR%%/spec/vcr_cassettes
-@dir %%DATADIR%%/spec
-@dir %%DATADIR%%/support
-@dir %%DATADIR%%
+@dir(git,,755) /var/log/gitlab-shell