aboutsummaryrefslogtreecommitdiff
path: root/devel/gitlist/Makefile
diff options
context:
space:
mode:
authorBartek Rutkowski <robak@FreeBSD.org>2015-09-09 11:00:46 +0000
committerBartek Rutkowski <robak@FreeBSD.org>2015-09-09 11:00:46 +0000
commit9053462df93584f8b0c6dab151d59ea7861e8dee (patch)
tree91c4a12026b9cbc4b0d057fb8d3c3459fd79da7a /devel/gitlist/Makefile
parent6786f18b59616dd65649d114b6357cb74598eb36 (diff)
Notes
Diffstat (limited to 'devel/gitlist/Makefile')
-rw-r--r--devel/gitlist/Makefile48
1 files changed, 48 insertions, 0 deletions
diff --git a/devel/gitlist/Makefile b/devel/gitlist/Makefile
new file mode 100644
index 000000000000..a68240fdabb5
--- /dev/null
+++ b/devel/gitlist/Makefile
@@ -0,0 +1,48 @@
+# Created by: Andre Rikkert de Koe - ARK-ICT <andre@ark-ict.nl>
+# $FreeBSD$
+
+PORTNAME= gitlist
+PORTVERSION= 0.5.0
+CATEGORIES= devel www
+MASTER_SITES= https://s3.amazonaws.com/gitlist/ \
+ http://freebsd.ark-ict.nl/ports/
+
+MAINTAINER= andre@ark-ict.nl
+COMMENT= Web based Git repository browser written in PHP
+
+LICENSE= BSD2CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+RUN_DEPENDS= git:${PORTSDIR}/devel/git
+
+PLIST= ${WRKDIR}/plist
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+NO_BUILD= yes
+WANT_PHP_WEB= yes
+
+USERS?= ${WWWOWN}
+GROUPS?= ${WWWGRP}
+SUB_FILES= pkg-message
+
+post-patch:
+ ${MKDIR} ${WRKSRC}/cache
+ cd ${WRKSRC}; \
+ ${REINPLACE_CMD} -e 's|/usr/bin/git|/usr/local/bin/git|g' config.ini-example; \
+ ${FIND} . ! -type d | ${SORT} | ${SED} -e "s,^\.,%%WWWDIR%%," > ${PLIST};
+ ${ECHO} "@dir %%WWWDIR%%/vendor/phpmd/phpmd/setup" >> ${PLIST}
+ ${ECHO} "@dir(${WWWOWN},${WWWGRP},) %%WWWDIR%%/cache" >> ${PLIST}
+
+do-install:
+ cd ${WRKSRC}; \
+ IFS="$$(printf '\n\t')"; \
+ for src in $$( ${FIND} . ); do \
+ dst="${STAGEDIR}${WWWDIR}$${src#.}"; \
+ if ${TEST} -d "$$src"; then \
+ ${MKDIR} "$$dst"; \
+ else \
+ ${INSTALL_DATA} "$$src" "$$dst"; \
+ fi \
+ done
+
+.include <bsd.port.mk>