aboutsummaryrefslogtreecommitdiff
path: root/devel/glib20
diff options
context:
space:
mode:
authorJean-Yves Lefort <jylefort@FreeBSD.org>2006-10-05 16:14:14 +0000
committerJean-Yves Lefort <jylefort@FreeBSD.org>2006-10-05 16:14:14 +0000
commit0a85c7d685769d13f90aac5e6379277b22928a53 (patch)
tree616624440227c3e51a395dd840dc61e439749fce /devel/glib20
parent6fcf4bfc30c00565c605c846030f49cae6a3920b (diff)
downloadports-0a85c7d685769d13f90aac5e6379277b22928a53.tar.gz
ports-0a85c7d685769d13f90aac5e6379277b22928a53.zip
Notes
Diffstat (limited to 'devel/glib20')
-rw-r--r--devel/glib20/Makefile1
-rw-r--r--devel/glib20/files/extra-patch-glib_gunicollate.c6
2 files changed, 3 insertions, 4 deletions
diff --git a/devel/glib20/Makefile b/devel/glib20/Makefile
index 5e8e6925d304..78d103c31f24 100644
--- a/devel/glib20/Makefile
+++ b/devel/glib20/Makefile
@@ -54,7 +54,6 @@ EXTRA_PATCHES+= ${FILESDIR}/extra-patch-gthread_gthread-posix.c
LIB_DEPENDS+= icui18n:${PORTSDIR}/devel/icu
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-glib_Makefile.in \
${FILESDIR}/extra-patch-glib_gunicollate.c
-CFLAGS+= -O0 # avoid an icu crash in the gimp
.endif
post-patch:
diff --git a/devel/glib20/files/extra-patch-glib_gunicollate.c b/devel/glib20/files/extra-patch-glib_gunicollate.c
index 0ce4dbde855c..5d31cbd2ed72 100644
--- a/devel/glib20/files/extra-patch-glib_gunicollate.c
+++ b/devel/glib20/files/extra-patch-glib_gunicollate.c
@@ -1,5 +1,5 @@
--- glib/gunicollate.c.orig Sun Nov 27 21:15:41 2005
-+++ glib/gunicollate.c Wed Jul 19 01:06:32 2006
++++ glib/gunicollate.c Thu Oct 5 17:11:44 2006
@@ -26,10 +26,57 @@
#include <wchar.h>
#endif
@@ -99,14 +99,14 @@
+ UChar *wstr = utf8_to_uchar(str, len, &wstr_len);
+ if (wstr != NULL)
+ {
-+ uint8_t dummy;
+ int32_t result_len;
+
+ /* get size of result */
-+ result_len = ucol_getSortKey(icu_collator, wstr, wstr_len, &dummy, 1);
++ result_len = ucol_getSortKey(icu_collator, wstr, wstr_len, NULL, 0);
+
+ result = g_new(char, result_len);
+ ucol_getSortKey(icu_collator, wstr, wstr_len, result, result_len);
++ g_free(wstr);
+
+ return result;
+ }