aboutsummaryrefslogtreecommitdiff
path: root/devel/glib20
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2001-04-30 05:29:45 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2001-04-30 05:29:45 +0000
commite2d3b6a625c1f96a9c5fbc4d2922809e1b93b96d (patch)
tree25b11025cf83e4328c4aa641e3bd4305dc6d03ec /devel/glib20
parentea0c71f8ae283cc6f9355a86d8eb86f663ee5bed (diff)
downloadports-e2d3b6a625c1f96a9c5fbc4d2922809e1b93b96d.tar.gz
ports-e2d3b6a625c1f96a9c5fbc4d2922809e1b93b96d.zip
Notes
Diffstat (limited to 'devel/glib20')
-rw-r--r--devel/glib20/Makefile7
-rw-r--r--devel/glib20/distinfo2
-rw-r--r--devel/glib20/files/patch-ae36
-rw-r--r--devel/glib20/files/patch-ag26
-rw-r--r--devel/glib20/pkg-plist17
5 files changed, 49 insertions, 39 deletions
diff --git a/devel/glib20/Makefile b/devel/glib20/Makefile
index 1cfc1ab1dda0..815952dcc3f3 100644
--- a/devel/glib20/Makefile
+++ b/devel/glib20/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= glib
-PORTVERSION= 1.3.2
+PORTVERSION= 1.3.4
CATEGORIES= devel
MASTER_SITES= ftp://ftp.gimp.org/pub/%SUBDIR%/ \
ftp://ftp.cs.umn.edu/pub/gimp/%SUBDIR%/ \
@@ -16,8 +16,9 @@ MASTER_SITE_SUBDIR= gtk/v${PORTVERSION:R}
MAINTAINER= ade@FreeBSD.org
+BUILD_DEPENDS= pkg-config:${PORTSDIR}/devel/pkgconfig
LIB_DEPENDS= giconv.2:${PORTSDIR}/converters/libiconv
-#iconv.1:${PORTSDIR}/converters/iconv
+RUN_DEPENDS= pkg-config:${PORTSDIR}/devel/pkgconfig
NO_LATEST_LINK= "Unstable, development version."
@@ -31,5 +32,7 @@ MAN1= glib-config-2.0.1 glib-genmarshal.1
pre-patch:
@find ${WRKSRC} -type f | xargs ${GREP} -l iconv.h | \
xargs ${PERL} -pi -e "s|iconv\.h|giconv.h|g"
+ @find ${WRKSRC} -name Makefile.in | xargs ${PERL} -pi -e \
+ 's|\$\(libdir\)/pkgconfig|\$\(prefix\)/libdata/pkgconfig|g'
.include <bsd.port.mk>
diff --git a/devel/glib20/distinfo b/devel/glib20/distinfo
index c90ab9761b04..c43a763743b0 100644
--- a/devel/glib20/distinfo
+++ b/devel/glib20/distinfo
@@ -1 +1 @@
-MD5 (glib-1.3.2.tar.gz) = 64f11623bfd9809eb71a53acf4e93b47
+MD5 (glib-1.3.4.tar.gz) = 9d31a2283d135245e2f4c404ce662155
diff --git a/devel/glib20/files/patch-ae b/devel/glib20/files/patch-ae
index 3e306163ee3d..ac0d23c867e0 100644
--- a/devel/glib20/files/patch-ae
+++ b/devel/glib20/files/patch-ae
@@ -1,6 +1,9 @@
---- configure.orig Fri Nov 17 22:45:11 2000
-+++ configure Mon Nov 20 18:27:43 2000
-@@ -4230,6 +4230,12 @@
+
+$FreeBSD$
+
+--- configure.orig Mon Apr 16 19:12:05 2001
++++ configure Sun Apr 29 14:01:19 2001
+@@ -6287,6 +6287,12 @@
linux*)
G_MODULE_LDFLAGS='-rdynamic'
;;
@@ -13,7 +16,7 @@
esac
LIBS_orig="$LIBS"
LDFLAGS_orig="$LDFLAGS"
-@@ -4523,7 +4529,7 @@
+@@ -6753,7 +6759,7 @@
G_THREAD_CFLAGS="$G_THREAD_CFLAGS -mthreads"
fi
;;
@@ -22,7 +25,7 @@
G_THREAD_CFLAGS="$G_THREAD_CFLAGS -D_THREAD_SAFE"
# FreeBSD 2.2.x shiped with gcc 2.7.2.x, which doesn't support
-@@ -4610,8 +4616,8 @@
+@@ -6840,8 +6846,8 @@
add_thread_lib=""
IN=""
else
@@ -33,30 +36,31 @@
fi
if test x"$have_threads" = xposix; then
defattr=0
-@@ -4912,7 +4918,7 @@
+@@ -7142,7 +7148,7 @@
sizeof (buffer));
; return 0; }
EOF
--if { (eval echo configure:4916: \"$ac_compile\") 1>&5; (eval $ac_compile) 2>&5; }; then
-+if { (eval echo configure:4916: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext} && (./conftest; exit) 2>/dev/null; then
+-if { (eval echo configure:7146: \"$ac_compile\") 1>&5; (eval $ac_compile) 2>&5; }; then
++if { (eval echo configure:7146: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext} && (./conftest; exit) 2>/dev/null; then
rm -rf conftest*
ac_cv_func_nonposix_getpwuid_r=yes
else
-@@ -5413,6 +5419,7 @@
- if eval "test \"`echo '$''{'ac_cv_func_iconv_open'+set}'`\" = set"; then
- echo $ac_n "(cached) $ac_c" 1>&6
+@@ -7440,6 +7446,7 @@
+ if test "$cross_compiling" = yes; then
+ { echo "configure: error: can not run test program while cross compiling" 1>&2; exit 1; }
else
+# LIBS="-liconv $LIBS"
cat > conftest.$ac_ext <<EOF
- #line 5418 "configure"
+ #line 7445 "configure"
#include "confdefs.h"
-@@ -5462,14 +5469,14 @@
+@@ -7747,14 +7754,14 @@
#
# Check for libiconv
#
- echo $ac_n "checking for libiconv_open in -liconv""... $ac_c" 1>&6
+-echo "configure:7752: checking for libiconv_open in -liconv" >&5
+ echo $ac_n "checking for libiconv_open in -lgiconv""... $ac_c" 1>&6
- echo "configure:5467: checking for libiconv_open in -liconv" >&5
++echo "configure:7752: checking for libiconv_open in -lgiconv" >&5
ac_lib_var=`echo iconv'_'libiconv_open | sed 'y%./+-%__p_%'`
if eval "test \"`echo '$''{'ac_cv_lib_$ac_lib_var'+set}'`\" = set"; then
echo $ac_n "(cached) $ac_c" 1>&6
@@ -65,9 +69,9 @@
-LIBS="-liconv $LIBS"
+LIBS="-lgiconv $LIBS"
cat > conftest.$ac_ext <<EOF
- #line 5475 "configure"
+ #line 7760 "configure"
#include "confdefs.h"
-@@ -5509,7 +5516,7 @@
+@@ -7794,7 +7801,7 @@
fi
if test "x$with_libiconv" = "xyes" ; then
diff --git a/devel/glib20/files/patch-ag b/devel/glib20/files/patch-ag
index b91c8e5ed4be..d5dd9f5fdabf 100644
--- a/devel/glib20/files/patch-ag
+++ b/devel/glib20/files/patch-ag
@@ -1,29 +1,23 @@
---- Makefile.in.orig Fri Nov 17 22:45:29 2000
-+++ Makefile.in Mon Nov 20 12:01:17 2000
-@@ -108,7 +108,7 @@
+
+$FreeBSD$
+
+--- Makefile.in.orig Tue Apr 17 22:49:12 2001
++++ Makefile.in Sun Apr 29 14:07:07 2001
+@@ -133,7 +133,7 @@
AUTOMAKE_OPTIONS = 1.4
-SUBDIRS = . gobject gmodule gthread docs tests build
+SUBDIRS = . gobject gmodule gthread docs build
- bin_SCRIPTS = glib-config-2.0
+ INCLUDES = -DG_LOG_DOMAIN=g_log_domain_glib @GLIB_DEBUG_FLAGS@ -DG_DISABLE_DEPRECATED -DGLIB_COMPILATION
-@@ -134,7 +134,7 @@
- glibinclude_HEADERS = galloca.h garray.h gasyncqueue.h gbacktrace.h gcache.h gcompletion.h gconvert.h gdataset.h gdate.h gerror.h gfileutils.h ghash.h ghook.h giochannel.h glib.h glib-object.h glist.h gmacros.h gmain.h gmarkup.h gmem.h gmessages.h gnode.h gprimes.h gquark.h gqueue.h grand.h grel.h gscanner.h gshell.h gslist.h gspawn.h gstrfuncs.h gstring.h gthread.h gthreadpool.h gtimer.h gtree.h gtypes.h gunicode.h gutils.h gwin32.h
+@@ -157,7 +157,7 @@
+ glibinclude_HEADERS = galloca.h garray.h gasyncqueue.h gbacktrace.h gcache.h gcompletion.h gconvert.h gdataset.h gdate.h gerror.h gfileutils.h ghash.h ghook.h giochannel.h glib.h glib-object.h glist.h gmacros.h gmain.h gmarkup.h gmem.h gmessages.h gnode.h gpattern.h gprimes.h gqsort.h gquark.h gqueue.h grand.h grel.h gscanner.h gshell.h gslist.h gspawn.h gstrfuncs.h gstring.h gthread.h gthreadpool.h gtimer.h gtree.h gtypes.h gunicode.h gutils.h gwin32.h
-configexecincludedir = $(libdir)/glib-2.0/include
+configexecincludedir = $(glibincludedir)
CONFIGURE_DEPENDENCIES = acglib.m4
-
-@@ -594,7 +594,7 @@
- install-exec-local
- install-exec: install-exec-recursive
-
--install-data-am: install-m4dataDATA install-pkgconfigDATA \
-+install-data-am: install-m4dataDATA \
- install-glibincludeHEADERS
- install-data: install-data-recursive
-
+ BUILT_SOURCES = glib-config-2.0
diff --git a/devel/glib20/pkg-plist b/devel/glib20/pkg-plist
index 893c701acbcf..c2dbba96745b 100644
--- a/devel/glib20/pkg-plist
+++ b/devel/glib20/pkg-plist
@@ -1,6 +1,7 @@
bin/glib-config-2.0
bin/glib-genmarshal
bin/gobject-query
+bin/testgruntime
include/glib-2.0/galloca.h
include/glib-2.0/garray.h
include/glib-2.0/gasyncqueue.h
@@ -30,6 +31,7 @@ include/glib-2.0/gobject/gboxed.h
include/glib-2.0/gobject/gbsearcharray.h
include/glib-2.0/gobject/gclosure.h
include/glib-2.0/gobject/genums.h
+include/glib-2.0/gobject/gmarshal.h
include/glib-2.0/gobject/gobject.h
include/glib-2.0/gobject/gparam.h
include/glib-2.0/gobject/gparamspecs.h
@@ -38,9 +40,12 @@ include/glib-2.0/gobject/gtype.h
include/glib-2.0/gobject/gtypemodule.h
include/glib-2.0/gobject/gtypeplugin.h
include/glib-2.0/gobject/gvalue.h
+include/glib-2.0/gobject/gvaluearray.h
include/glib-2.0/gobject/gvaluecollector.h
include/glib-2.0/gobject/gvaluetypes.h
+include/glib-2.0/gpattern.h
include/glib-2.0/gprimes.h
+include/glib-2.0/gqsort.h
include/glib-2.0/gquark.h
include/glib-2.0/gqueue.h
include/glib-2.0/grand.h
@@ -61,16 +66,20 @@ include/glib-2.0/gutils.h
include/glib-2.0/gwin32.h
lib/libglib-1.3.a
lib/libglib-1.3.so
-lib/libglib-1.3.so.2
+lib/libglib-1.3.so.4
lib/libgmodule-1.3.a
lib/libgmodule-1.3.so
-lib/libgmodule-1.3.so.2
+lib/libgmodule-1.3.so.4
lib/libgobject-1.3.a
lib/libgobject-1.3.so
-lib/libgobject-1.3.so.2
+lib/libgobject-1.3.so.4
lib/libgthread-1.3.a
lib/libgthread-1.3.so
-lib/libgthread-1.3.so.2
+lib/libgthread-1.3.so.4
+libdata/pkgconfig/glib-2.0.pc
+libdata/pkgconfig/gmodule-2.0.pc
+libdata/pkgconfig/gobject-2.0.pc
+libdata/pkgconfig/gthread-2.0.pc
share/aclocal/glib-2.0.m4
@dirrm include/glib-2.0/gobject
@dirrm include/glib-2.0