aboutsummaryrefslogtreecommitdiff
path: root/devel/glib20
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2011-09-25 15:43:59 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2011-09-25 15:43:59 +0000
commita297c3d6c8eb57201b6ad603fc45d643ad4155e2 (patch)
treef4fe9bed9b66b639853848071d1caf2beb322b27 /devel/glib20
parent50c5674cf3b72851adad180eb1208f069805a847 (diff)
downloadports-a297c3d6c8eb57201b6ad603fc45d643ad4155e2.tar.gz
ports-a297c3d6c8eb57201b6ad603fc45d643ad4155e2.zip
Notes
Diffstat (limited to 'devel/glib20')
-rw-r--r--devel/glib20/Makefile2
-rw-r--r--devel/glib20/files/patch-gio_gdesktopappinfo.c35
-rw-r--r--devel/glib20/files/patch-gio_gunixcredentialsmessage.c16
3 files changed, 52 insertions, 1 deletions
diff --git a/devel/glib20/Makefile b/devel/glib20/Makefile
index 658a568b3042..0a0846e8c659 100644
--- a/devel/glib20/Makefile
+++ b/devel/glib20/Makefile
@@ -9,7 +9,7 @@
PORTNAME= glib
PORTVERSION= 2.28.8
-PORTREVISION?= 0
+PORTREVISION?= 1
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_GNOME:S,%SUBDIR%,sources/glib/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/},} \
ftp://ftp.gtk.org/pub/glib/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}/ \
diff --git a/devel/glib20/files/patch-gio_gdesktopappinfo.c b/devel/glib20/files/patch-gio_gdesktopappinfo.c
new file mode 100644
index 000000000000..73283b44dbab
--- /dev/null
+++ b/devel/glib20/files/patch-gio_gdesktopappinfo.c
@@ -0,0 +1,35 @@
+--- gio/gdesktopappinfo.c.orig 2011-09-25 11:41:14.000000000 -0400
++++ gio/gdesktopappinfo.c 2011-09-25 11:41:18.000000000 -0400
+@@ -1515,18 +1515,29 @@ update_mimeapps_list (const char *deskt
+ */
+ if (!explicit_default)
+ {
+- system_list = get_all_desktop_entries_for_mime_type (content_type, (const char **) list, FALSE, NULL);
++ char *user_default;
++ /* The system default can be in the list, don't exclude it */
++ system_list = get_all_desktop_entries_for_mime_type (content_type, NULL, FALSE, &user_default);
+
+- if (system_list != NULL)
++ string = NULL;
++ if (user_default != NULL)
++ {
++ /* There is an existing default set in a lower priority defaults file, re-use it */
++ string = user_default;
++ }
++ else if (system_list != NULL)
+ {
+ string = system_list->data;
+-
++ }
++ if (string)
++ {
+ g_key_file_set_string (key_file,
+ DEFAULT_APPLICATIONS_GROUP,
+ content_types[k],
+ string);
+ }
+
++ g_free (user_default);
+ g_list_free_full (system_list, g_free);
+ }
+ }
diff --git a/devel/glib20/files/patch-gio_gunixcredentialsmessage.c b/devel/glib20/files/patch-gio_gunixcredentialsmessage.c
new file mode 100644
index 000000000000..b81a6e282aa8
--- /dev/null
+++ b/devel/glib20/files/patch-gio_gunixcredentialsmessage.c
@@ -0,0 +1,16 @@
+--- gio/gunixcredentialsmessage.c.orig 2011-09-25 11:42:09.000000000 -0400
++++ gio/gunixcredentialsmessage.c 2011-09-25 11:42:22.000000000 -0400
+@@ -162,11 +162,11 @@ g_unix_credentials_message_deserialize (
+ {
+ goto out;
+ }
+- if (size < CMSG_LEN (sizeof *cred))
++ if (size < sizeof *cred)
+ {
+ g_warning ("Expected a struct cmsgcred (%" G_GSIZE_FORMAT " bytes) but "
+ "got %" G_GSIZE_FORMAT " bytes of data",
+- CMSG_LEN (sizeof *cred),
++ sizeof *cred,
+ size);
+ goto out;
+ }