aboutsummaryrefslogtreecommitdiff
path: root/devel/global/Makefile
diff options
context:
space:
mode:
authorSADA Kenji <sada@FreeBSD.org>2000-10-29 19:16:20 +0000
committerSADA Kenji <sada@FreeBSD.org>2000-10-29 19:16:20 +0000
commit9faa24a215c2f177465502b7a7fc2bc43a5c1a17 (patch)
tree22c698e197926a3a9ab6ce6bc1150b1923b78432 /devel/global/Makefile
parent544a3aab5083c1ede90379514f937c30e26a329c (diff)
downloadports-9faa24a215c2f177465502b7a7fc2bc43a5c1a17.tar.gz
ports-9faa24a215c2f177465502b7a7fc2bc43a5c1a17.zip
Notes
Diffstat (limited to 'devel/global/Makefile')
-rw-r--r--devel/global/Makefile16
1 files changed, 13 insertions, 3 deletions
diff --git a/devel/global/Makefile b/devel/global/Makefile
index 1fbc88d0ef3d..3ec14845f03e 100644
--- a/devel/global/Makefile
+++ b/devel/global/Makefile
@@ -6,15 +6,25 @@
#
PORTNAME= global
-PORTVERSION= 3.56
+PORTVERSION= 4.0.1
CATEGORIES= devel
MASTER_SITES= http://www.tamacom.com/global/
MAINTAINER= chuckr@freebsd.org
-MAKE_FLAGS+= INCDIR=$(LOCALBASE)/include LIBDIR=$(LOCALBASE)/lib BINDIR=$(LOCALBASE)/bin SHAREDIR=$(LOCALBASE)
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
MAN1= htags.1 btreeop.1 gtags.1 global.1 gctags.1
-MANCOMPRESSED= yes
+
+post-install:
+ install-info ${PREFIX}/info/global.info ${PREFIX}/info/dir
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${PREFIX}/share/doc/global
+.for file in AUTHORS COPYING ChangeLog FAQ INSTALL LICENSE NEWS README \
+ THANKS VERSION
+ ${INSTALL_MAN} ${WRKSRC}/${file} ${PREFIX}/share/doc/global
+.endfor
+.endif
.include <bsd.port.mk>