aboutsummaryrefslogtreecommitdiff
path: root/devel/gmake381
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2002-06-06 22:40:06 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2002-06-06 22:40:06 +0000
commit2e4c56c361f5edcd5cc4686a4384a53c1435c1e9 (patch)
tree24f10a3b9653e62430868d306a6bce0f208befc5 /devel/gmake381
parent6e22f2c4fcc0784e0ae1b66d13e72c2d49a76b24 (diff)
downloadports-2e4c56c361f5edcd5cc4686a4384a53c1435c1e9.tar.gz
ports-2e4c56c361f5edcd5cc4686a4384a53c1435c1e9.zip
Notes
Diffstat (limited to 'devel/gmake381')
-rw-r--r--devel/gmake381/Makefile11
-rw-r--r--devel/gmake381/files/patch-gettext.c16
2 files changed, 25 insertions, 2 deletions
diff --git a/devel/gmake381/Makefile b/devel/gmake381/Makefile
index a947aafac0cb..514955391721 100644
--- a/devel/gmake381/Makefile
+++ b/devel/gmake381/Makefile
@@ -7,7 +7,7 @@
PORTNAME= gmake
PORTVERSION= 3.79.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= make
@@ -18,11 +18,18 @@ MAINTAINER= portmgr@FreeBSD.org
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --program-prefix=g \
--with-included-gettext
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -DHAVE_LOCALE_H" \
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -DHAVE_LOCALE_H -DHAVE_LC_MESSAGES" \
LDFLAGS="-L${LOCALBASE}/lib"
MAN1= gmake.1
+# Fscking GNU developers put 777 dirs into their tarball, so that anybody
+# could insert evil code into gmake without you even noticing by modifying
+# files during do-extract or do-configure.
+
+pre-extract:
+ ${CHMOD} 700 ${WRKDIR}
+
# joerg@freebsd.org says our getloadavg() no longer requires setgid kmem
post-install:
diff --git a/devel/gmake381/files/patch-gettext.c b/devel/gmake381/files/patch-gettext.c
new file mode 100644
index 000000000000..51c63003effc
--- /dev/null
+++ b/devel/gmake381/files/patch-gettext.c
@@ -0,0 +1,16 @@
+
+$FreeBSD$
+
+--- gettext.c 2002/06/06 22:10:23 1.1
++++ gettext.c 2002/06/06 22:11:09
+@@ -22,6 +22,10 @@
+ # include <config.h>
+ #endif
+
++#if defined HAVE_LOCALE_H || defined _LIBC
++# include <locale.h>
++#endif
++
+ #ifdef __GNUC__
+ # define alloca __builtin_alloca
+ # define HAVE_ALLOCA 1