aboutsummaryrefslogtreecommitdiff
path: root/devel/gnatpython
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2014-05-16 14:32:33 +0000
committerJohn Marino <marino@FreeBSD.org>2014-05-16 14:32:33 +0000
commit998dc42e73ae1af4399655a73dbdcc7d457f2b8e (patch)
treea0ba39fe0ab22a27e6446e0ad9ad7c2c1c26005a /devel/gnatpython
parent84a741205e66627c39dc496c01903391aabf6081 (diff)
downloadports-998dc42e73ae1af4399655a73dbdcc7d457f2b8e.tar.gz
ports-998dc42e73ae1af4399655a73dbdcc7d457f2b8e.zip
Notes
Diffstat (limited to 'devel/gnatpython')
-rw-r--r--devel/gnatpython/Makefile3
-rw-r--r--devel/gnatpython/files/patch-setup__helpers.py11
2 files changed, 13 insertions, 1 deletions
diff --git a/devel/gnatpython/Makefile b/devel/gnatpython/Makefile
index e3d105fa0128..6b351102e8d9 100644
--- a/devel/gnatpython/Makefile
+++ b/devel/gnatpython/Makefile
@@ -3,6 +3,7 @@
PORTNAME= gnatpython
PORTVERSION= ${SNAPSHOT}
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= http://downloads.dragonlace.net/src/
@@ -12,7 +13,7 @@ COMMENT= Python package used in Ada testsuites
LICENSE= GPLv3
SNAPSHOT= 20140205
-USE_BZIP2= yes
+USES= tar:bzip2
USE_PYTHON= yes
USE_PYDISTUTILS= yes
diff --git a/devel/gnatpython/files/patch-setup__helpers.py b/devel/gnatpython/files/patch-setup__helpers.py
new file mode 100644
index 000000000000..51aa80ddbac9
--- /dev/null
+++ b/devel/gnatpython/files/patch-setup__helpers.py
@@ -0,0 +1,11 @@
+--- setup_helpers.py.orig 2014-02-14 10:41:26.000000000 +0000
++++ setup_helpers.py
+@@ -28,7 +28,7 @@ def build_scripts_gnatpython(root_dir=''
+ os.system('gcc -o %sscripts/rlimit %ssrc/rlimit/rlimit-NT.c' %
+ (root_dir, root_dir))
+ else:
+- os.system('gcc -o %sscripts/rlimit %ssrc/rlimit/rlimit.c' %
++ os.system('cc -o %sscripts/rlimit %ssrc/rlimit/rlimit.c' %
+ (root_dir, root_dir))
+
+ # Update the scripts list