aboutsummaryrefslogtreecommitdiff
path: root/devel/gnome-build/Makefile
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2004-02-23 21:07:36 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2004-02-23 21:07:36 +0000
commit0e41d871c0ce5bfd66c985400e01269f88c3a133 (patch)
treed0fd4878f8293a83af65c1f4ba714ba62eac8850 /devel/gnome-build/Makefile
parente34b41b9b633c09311330b29a11d0c5d44ec8bc0 (diff)
downloadports-0e41d871c0ce5bfd66c985400e01269f88c3a133.tar.gz
ports-0e41d871c0ce5bfd66c985400e01269f88c3a133.zip
Notes
Diffstat (limited to 'devel/gnome-build/Makefile')
-rw-r--r--devel/gnome-build/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/devel/gnome-build/Makefile b/devel/gnome-build/Makefile
index 64121dfa33ff..478587cd2120 100644
--- a/devel/gnome-build/Makefile
+++ b/devel/gnome-build/Makefile
@@ -24,6 +24,7 @@ USE_GNOME= gnomeprefix gnomehack gnometarget libgnomeui gnomevfs2
USE_LIBTOOL= yes
GNU_CONFIGURE= yes
INSTALLS_SHLIB= yes
+CONFIGURE_ARGS= --enable-compile-warnings=no
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib -lgnuregex"
@@ -31,7 +32,7 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
.if ${OSVERSION} >= 500000
EXTRA_PATCHES+= ${FILESDIR}/current-src_backends_libgbf_am_gbf-am-project.c
-.else
+.elif ${ARCH} != "i386"
EXTRA_PATCHES+= ${FILESDIR}/stable-src_backends_libgbf_am_gbf-am-project.c
.endif