aboutsummaryrefslogtreecommitdiff
path: root/devel/gnome-vfs1/Makefile
diff options
context:
space:
mode:
authorAde Lovett <ade@FreeBSD.org>2000-08-04 01:34:38 +0000
committerAde Lovett <ade@FreeBSD.org>2000-08-04 01:34:38 +0000
commit9594f3f8939f5178057c6a588135f0bab6d52511 (patch)
tree923d26a5ec2be934317cf261a38183917c93fe7a /devel/gnome-vfs1/Makefile
parent5035c4b32a83e9b13642c8ca8569d6ba2b001420 (diff)
Extensive patchfile cleanups using sobomax's wonderful
post-extract rule
Notes
Notes: svn path=/head/; revision=31296
Diffstat (limited to 'devel/gnome-vfs1/Makefile')
-rw-r--r--devel/gnome-vfs1/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/devel/gnome-vfs1/Makefile b/devel/gnome-vfs1/Makefile
index 96c899f3be6b..d461a53f3c15 100644
--- a/devel/gnome-vfs1/Makefile
+++ b/devel/gnome-vfs1/Makefile
@@ -16,7 +16,7 @@ MAINTAINER= ade@FreeBSD.org
LIB_DEPENDS= gnome.4:${PORTSDIR}/x11/gnomelibs \
capplet.4:${PORTSDIR}/sysutils/gnomecontrolcenter \
- gconf.8:${PORTSDIR}/devel/gconf \
+ gconf-1.0:${PORTSDIR}/devel/gconf \
bz2.1:${PORTSDIR}/archivers/bzip2
GLIB_CONFIG?= ${LOCALBASE}/bin/glib12-config
@@ -36,4 +36,11 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
MAN5= gnome-vfs-mime.5
+post-extract:
+ @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
+ @find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
+ 's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
+ s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
+
.include <bsd.port.mk>