aboutsummaryrefslogtreecommitdiff
path: root/devel/gnome-vfs
diff options
context:
space:
mode:
authorJeremy Messenger <mezz@FreeBSD.org>2005-01-29 20:21:04 +0000
committerJeremy Messenger <mezz@FreeBSD.org>2005-01-29 20:21:04 +0000
commit3f7a57ceaf7adb234f128db1d6506502aeb1b0c6 (patch)
tree264ae0da3e15aafc848d4992e55eaa40db463947 /devel/gnome-vfs
parentbf5fb93c4db7e9bb39a8f0bf375e79ce8a51c10f (diff)
downloadports-3f7a57ceaf7adb234f128db1d6506502aeb1b0c6.tar.gz
ports-3f7a57ceaf7adb234f128db1d6506502aeb1b0c6.zip
Notes
Diffstat (limited to 'devel/gnome-vfs')
-rw-r--r--devel/gnome-vfs/Makefile10
-rw-r--r--devel/gnome-vfs/pkg-deinstall.in19
-rw-r--r--devel/gnome-vfs/pkg-install.in19
3 files changed, 47 insertions, 1 deletions
diff --git a/devel/gnome-vfs/Makefile b/devel/gnome-vfs/Makefile
index 7f63607d6785..400cb9fb444a 100644
--- a/devel/gnome-vfs/Makefile
+++ b/devel/gnome-vfs/Makefile
@@ -7,7 +7,7 @@
PORTNAME= gnomevfs2
PORTVERSION= 2.8.3
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= devel gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/gnome-vfs/2.8
@@ -33,6 +33,9 @@ CONFIGURE_ENV= CPPFLAGS="${PTHREAD_CFLAGS} -I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}" \
BSD_PTHREAD_LIBS=${PTHREAD_LIBS}
+PKGINSTALL= ${WRKDIR}/pkg-install
+PKGDEINSTALL= ${WRKDIR}/pkg-deinstall
+
GCONF_SCHEMAS= desktop_default_applications.schemas \
desktop_gnome_url_handlers.schemas system_dns_sd.schemas \
system_http_proxy.schemas system_smb.schemas
@@ -114,6 +117,10 @@ post-patch:
.endif
@${REINPLACE_CMD} -e "/^SUBDIRS =/s/test//" \
${WRKSRC}/Makefile.in
+ @${SED} -e 's|%%X11BASE%%|${X11BASE}|g' \
+ < ${MASTERDIR}/pkg-install.in > ${PKGINSTALL}
+ @${SED} -e 's|%%X11BASE%%|${X11BASE}|g' \
+ < ${MASTERDIR}/pkg-deinstall.in > ${PKGDEINSTALL}
pre-configure:
@if [ -n "`${PKG_INFO} -xI '^bind[0-9]*-base-[0-9]'`" ]; then \
@@ -122,6 +129,7 @@ pre-configure:
fi
post-install:
+ @${SETENV} PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
.if !defined(WITHOUT_KDE_MENUS)
@${INSTALL_DATA} ${WRKSRC}/KDE.directory ${PREFIX}/share/gnome/vfolders
.endif
diff --git a/devel/gnome-vfs/pkg-deinstall.in b/devel/gnome-vfs/pkg-deinstall.in
new file mode 100644
index 000000000000..7e289a563dd1
--- /dev/null
+++ b/devel/gnome-vfs/pkg-deinstall.in
@@ -0,0 +1,19 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+# Restore gconf keys of libgnome.
+
+if [ "$2" != "POST-DEINSTALL" ]; then
+ exit 0
+fi
+
+SCHEMAS=%%X11BASE%%/etc/gconf/schemas/desktop_gnome_applications_terminal.schemas
+
+if [ -f ${SCHEMAS} ]; then
+ env GCONF_CONFIG_SOURCE=xml::%%X11BASE%%/etc/gconf/gconf.xml.defaults \
+ %%X11BASE%%/bin/gconftool-2 --makefile-install-rule ${SCHEMAS} \
+ > /dev/null || /usr/bin/true
+fi
+
+exit 0
diff --git a/devel/gnome-vfs/pkg-install.in b/devel/gnome-vfs/pkg-install.in
new file mode 100644
index 000000000000..6a407a1e4f42
--- /dev/null
+++ b/devel/gnome-vfs/pkg-install.in
@@ -0,0 +1,19 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+# Restore gconf keys of libgnome.
+
+if [ "$2" != "POST-INSTALL" ]; then
+ exit 0
+fi
+
+SCHEMAS=%%X11BASE%%/etc/gconf/schemas/desktop_gnome_applications_terminal.schemas
+
+if [ -f ${SCHEMAS} ]; then
+ env GCONF_CONFIG_SOURCE=xml::%%X11BASE%%/etc/gconf/gconf.xml.defaults \
+ %%X11BASE%%/bin/gconftool-2 --makefile-install-rule ${SCHEMAS} \
+ > /dev/null || /usr/bin/true
+fi
+
+exit 0