aboutsummaryrefslogtreecommitdiff
path: root/devel/gnome-vfs
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2005-11-05 04:53:48 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2005-11-05 04:53:48 +0000
commite18151212d3326dbf04797c6d5300fb1211ee875 (patch)
tree1ca56d6a4227efdb653cc8e2b2cbedbbc8de3d88 /devel/gnome-vfs
parentcc0f3248a2eb77d7e3df88333fd25eb8594223dc (diff)
downloadports-e18151212d3326dbf04797c6d5300fb1211ee875.tar.gz
ports-e18151212d3326dbf04797c6d5300fb1211ee875.zip
Notes
Diffstat (limited to 'devel/gnome-vfs')
-rw-r--r--devel/gnome-vfs/Makefile55
-rw-r--r--devel/gnome-vfs/distinfo4
-rw-r--r--devel/gnome-vfs/files/patch-ac14
-rw-r--r--devel/gnome-vfs/files/patch-devel-docs::Makefile.in1
-rw-r--r--devel/gnome-vfs/files/patch-gnome-vfs-2.0.pc.in10
-rw-r--r--devel/gnome-vfs/files/patch-gnome-vfs-module-2.0.pc.in9
-rw-r--r--devel/gnome-vfs/files/patch-libgnomevfs::gnome-vfs-application-registry.c29
-rw-r--r--devel/gnome-vfs/files/patch-libgnomevfs_gnome-vfs-mime-info.c11
-rw-r--r--devel/gnome-vfs/files/patch-libgnomevfs_gnome-vfs-mime.c38
-rw-r--r--devel/gnome-vfs/files/patch-libgnomevfs_gnome-vfs-resolve.c14
-rw-r--r--devel/gnome-vfs/files/patch-libgnomevfs_gnome-vfs-utils.c35
-rw-r--r--devel/gnome-vfs/files/patch-libgnomevfs_xdgmime.c6
-rw-r--r--devel/gnome-vfs/files/patch-modules_file-method.c12
-rw-r--r--devel/gnome-vfs/files/patch-modules_smb-method.c20
-rw-r--r--devel/gnome-vfs/pkg-deinstall.in1
-rw-r--r--devel/gnome-vfs/pkg-install.in1
-rw-r--r--devel/gnome-vfs/pkg-plist7
17 files changed, 98 insertions, 169 deletions
diff --git a/devel/gnome-vfs/Makefile b/devel/gnome-vfs/Makefile
index e152131a2aae..56cd876c36b4 100644
--- a/devel/gnome-vfs/Makefile
+++ b/devel/gnome-vfs/Makefile
@@ -3,14 +3,15 @@
# Whom: Ade Lovett <ade@FreeBSD.org>
#
# $FreeBSD$
+# $MCom: ports/devel/gnomevfs2/Makefile,v 1.115 2005/10/31 00:12:01 marcus Exp $
#
PORTNAME= gnomevfs2
-PORTVERSION= 2.10.1
-PORTREVISION= 1
+PORTVERSION= 2.12.1.1
+PORTREVISION= 2
CATEGORIES= devel gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= sources/gnome-vfs/2.10
+MASTER_SITE_SUBDIR= sources/gnome-vfs/2.12
DISTNAME= gnome-vfs-${PORTVERSION}
DIST_SUBDIR= gnome2
@@ -23,9 +24,9 @@ USE_BZIP2= yes
USE_GMAKE= yes
USE_X_PREFIX= yes
USE_GNOME= gnomeprefix gnomehack intlhack gnomemimedata gconf2 \
- libbonobo
+ libbonobo ltverhack
USE_REINPLACE= yes
-USE_LIBTOOL_VER=15
+USE_AUTOTOOLS= libtool:15
INSTALLS_SHLIB= yes
CONFIGURE_ARGS= --enable-openssl \
--disable-gnutls
@@ -38,37 +39,13 @@ PKGDEINSTALL= ${WRKDIR}/pkg-deinstall
GCONF_SCHEMAS= desktop_default_applications.schemas \
desktop_gnome_url_handlers.schemas system_dns_sd.schemas \
- system_http_proxy.schemas system_smb.schemas
+ system_http_proxy.schemas system_smb.schemas \
+ system_storage.schemas
-.include <bsd.port.pre.mk>
-
-.if defined(PACKAGE_BUILDING) || defined(PARALLEL_PACKAGE_BUILD)
-.undef WITHOUT_CDPARANOIA
-.undef WITHOUT_SAMBA
-.undef WITHOUT_MDNS
-WITH_MDNS= yes
-WITH_CDPARANOIA= yes
-WITH_SAMBA= yes
-.endif
-
-.if exists(${LOCALBASE}/lib/libcdda_paranoia.a)
-WITH_CDPARANOIA= yes
-.endif
-
-.if exists(${LOCALBASE}/lib/libsmbclient.so)
-WITH_SAMBA= yes
-.endif
+OPTIONS= SAMBA "Enable SMB volume support" on \
+ MDNS "Enable Bonjour/Rendezvous support" on
-.if exists(${LOCALBASE}/lib/libhowl.so)
-WITH_MDNS= yes
-.endif
-
-.if defined(WITH_CDPARANOIA)
-LIB_DEPENDS+= cdda_paranoia.0:${PORTSDIR}/audio/cdparanoia
-PLIST_SUB+= CDPARANOIA=""
-.else
-PLIST_SUB+= CDPARANOIA="@comment "
-.endif
+.include <bsd.port.pre.mk>
.if exists(${LOCALBASE}/lib/libfam.so) || !defined(WITHOUT_FAM)
USE_FAM= yes
@@ -78,15 +55,18 @@ USE_FAM= yes
LIB_DEPENDS+= krb5:${PORTSDIR}/security/heimdal
.endif
-.if defined(WITH_SAMBA)
+.if !defined(WITHOUT_SAMBA)
LIB_DEPENDS+= smbclient.0:${PORTSDIR}/net/samba-libsmbclient
PLIST_SUB+= SAMBA=""
.else
PLIST_SUB+= SAMBA="@comment "
+CONFIGURE_ARGS+=--disable-samba
.endif
-.if defined(WITH_MDNS)
+.if !defined(WITHOUT_MDNS)
LIB_DEPENDS+= howl:${PORTSDIR}/net/howl
+.else
+CONFIGURE_ARGS+=--disable-howl
.endif
post-patch:
@@ -94,8 +74,7 @@ post-patch:
${WRKSRC}/libgnomevfs/Makefile.in
@${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|g ; \
s|%%X11BASE%%|${X11BASE}|g' \
- ${WRKSRC}/libgnomevfs/xdgmime.c \
- ${WRKSRC}/libgnomevfs/gnome-vfs-mime-info.c
+ ${WRKSRC}/libgnomevfs/xdgmime.c
@${SED} -e 's|%%X11BASE%%|${X11BASE}|g' \
< ${MASTERDIR}/pkg-install.in > ${PKGINSTALL}
@${SED} -e 's|%%X11BASE%%|${X11BASE}|g' \
diff --git a/devel/gnome-vfs/distinfo b/devel/gnome-vfs/distinfo
index e4923630ccb0..df476c6026a5 100644
--- a/devel/gnome-vfs/distinfo
+++ b/devel/gnome-vfs/distinfo
@@ -1,2 +1,2 @@
-MD5 (gnome2/gnome-vfs-2.10.1.tar.bz2) = 88b520e5de748a310a2aef62fc095c8b
-SIZE (gnome2/gnome-vfs-2.10.1.tar.bz2) = 1905314
+MD5 (gnome2/gnome-vfs-2.12.1.1.tar.bz2) = bc62212600167acf78c9771add5cce7e
+SIZE (gnome2/gnome-vfs-2.12.1.1.tar.bz2) = 1726588
diff --git a/devel/gnome-vfs/files/patch-ac b/devel/gnome-vfs/files/patch-ac
index 9362cac1715f..383987654ef2 100644
--- a/devel/gnome-vfs/files/patch-ac
+++ b/devel/gnome-vfs/files/patch-ac
@@ -1,11 +1,11 @@
---- modules/Makefile.in.orig Tue May 6 15:39:48 2003
-+++ modules/Makefile.in Tue May 6 15:41:28 2003
-@@ -210,7 +210,7 @@
- @BUILD_CDEMENU_MODULE_TRUE@CDEMENU_LTLIBS = @BUILD_CDEMENU_MODULE_TRUE@libcdemenu-desktop.la
- @BUILD_CDEMENU_MODULE_FALSE@CDEMENU_LTLIBS =
-
+--- modules/Makefile.in.orig Mon Oct 3 11:55:14 2005
++++ modules/Makefile.in Mon Oct 3 11:55:55 2005
+@@ -465,7 +465,7 @@
+ @HAVE_SAMBA_TRUE@SMB_LTLIBS = libsmb.la
+ @OS_WIN32_FALSE@PLATFROM_SPECIFIC_LTLIBS = libdns-sd.la libnetwork.la libnntp.la libsftp.la $(HTTP_LTLIBS) libftp.la
+ @OS_WIN32_TRUE@PLATFROM_SPECIFIC_LTLIBS =
-module_flags = -export_dynamic -avoid-version -module -no-undefined
+module_flags = -export_dynamic -avoid-version -module -no-undefined $(PTHREAD_LIB)
modulesdir = $(libdir)/gnome-vfs-2.0/modules
-
modules_LTLIBRARIES = \
+ $(CDDA_LTLIBS) \
diff --git a/devel/gnome-vfs/files/patch-devel-docs::Makefile.in b/devel/gnome-vfs/files/patch-devel-docs::Makefile.in
index b02290aa2ebb..5d2778e291bf 100644
--- a/devel/gnome-vfs/files/patch-devel-docs::Makefile.in
+++ b/devel/gnome-vfs/files/patch-devel-docs::Makefile.in
@@ -1,5 +1,6 @@
$FreeBSD$
+ $MCom: ports/devel/gnomevfs2/files/patch-devel-docs::Makefile.in,v 1.18 2005/06/28 05:40:02 adamw Exp $
--- devel-docs/Makefile.in 2002/02/16 16:44:53 1.1
+++ devel-docs/Makefile.in 2002/02/16 16:45:47
diff --git a/devel/gnome-vfs/files/patch-gnome-vfs-2.0.pc.in b/devel/gnome-vfs/files/patch-gnome-vfs-2.0.pc.in
index 4acd9a1bc552..088433c51a28 100644
--- a/devel/gnome-vfs/files/patch-gnome-vfs-2.0.pc.in
+++ b/devel/gnome-vfs/files/patch-gnome-vfs-2.0.pc.in
@@ -1,13 +1,9 @@
-
-$FreeBSD$
-
---- gnome-vfs-2.0.pc.in.orig Thu Oct 28 13:25:35 2004
-+++ gnome-vfs-2.0.pc.in Thu Oct 28 13:25:51 2004
+--- gnome-vfs-2.0.pc.in.orig Wed Sep 14 05:30:25 2005
++++ gnome-vfs-2.0.pc.in Mon Oct 3 12:00:02 2005
@@ -8,5 +8,5 @@
Description: The GNOME virtual file-system libraries
Version: @VERSION@
- Requires: bonobo-activation-2.0 libbonobo-2.0 gconf-2.0 gthread-2.0 gmodule-2.0
+ Requires: bonobo-activation-2.0 libbonobo-2.0 gconf-2.0 gthread-2.0 gmodule-no-export-2.0 gobject-2.0
-Libs: -L${libdir} -lgnomevfs-2
+Libs: -L${libdir} -lgnomevfs-2 @PTHREAD_LIB@
Cflags: -I${includedir}/gnome-vfs-2.0 -I${libdir}/gnome-vfs-2.0/include
-
diff --git a/devel/gnome-vfs/files/patch-gnome-vfs-module-2.0.pc.in b/devel/gnome-vfs/files/patch-gnome-vfs-module-2.0.pc.in
index f9b09d46b7a3..c3f0d2c30ea2 100644
--- a/devel/gnome-vfs/files/patch-gnome-vfs-module-2.0.pc.in
+++ b/devel/gnome-vfs/files/patch-gnome-vfs-module-2.0.pc.in
@@ -1,12 +1,9 @@
-
-$FreeBSD$
-
---- gnome-vfs-module-2.0.pc.in 2002/02/16 13:07:42 1.1
-+++ gnome-vfs-module-2.0.pc.in 2002/02/16 13:07:51
+--- gnome-vfs-module-2.0.pc.in.orig Wed Sep 14 05:30:25 2005
++++ gnome-vfs-module-2.0.pc.in Mon Oct 3 12:01:04 2005
@@ -8,5 +8,5 @@
Description: The GNOME virtual file-system module include info
Version: @VERSION@
- Requires: bonobo-activation-2.0,gthread-2.0,gmodule-2.0
+ Requires: bonobo-activation-2.0 libbonobo-2.0 gconf-2.0 gthread-2.0 gmodule-no-export-2.0 gobject-2.0
-Libs: -L${libdir} -lgnomevfs-2
+Libs: -L${libdir} -lgnomevfs-2 @PTHREAD_LIB@
Cflags: -I${includedir}/gnome-vfs-2.0 -I${includedir}/gnome-vfs-module-2.0 -I${libdir}/gnome-vfs-2.0/include
diff --git a/devel/gnome-vfs/files/patch-libgnomevfs::gnome-vfs-application-registry.c b/devel/gnome-vfs/files/patch-libgnomevfs::gnome-vfs-application-registry.c
index bd679de032d2..2747466f7bd9 100644
--- a/devel/gnome-vfs/files/patch-libgnomevfs::gnome-vfs-application-registry.c
+++ b/devel/gnome-vfs/files/patch-libgnomevfs::gnome-vfs-application-registry.c
@@ -1,9 +1,6 @@
-
-$FreeBSD$
-
---- libgnomevfs/gnome-vfs-application-registry.c 2002/06/13 07:31:15 1.1
-+++ libgnomevfs/gnome-vfs-application-registry.c 2002/06/13 08:25:24
-@@ -940,6 +940,8 @@
+--- libgnomevfs/gnome-vfs-application-registry.c.orig Sun May 22 23:09:39 2005
++++ libgnomevfs/gnome-vfs-application-registry.c Sun May 22 23:14:22 2005
+@@ -943,6 +943,8 @@ load_application_info (void)
static void
gnome_vfs_application_registry_init (void)
{
@@ -12,18 +9,18 @@ $FreeBSD$
if (gnome_vfs_application_registry_initialized)
return;
-@@ -961,6 +963,14 @@
- gnome_registry_dir.dirname = g_strdup (DATADIR "/application-registry");
+@@ -963,6 +965,14 @@ gnome_vfs_application_registry_init (voi
+ "application-registry",
+ NULL);
gnome_registry_dir.system_dir = TRUE;
-
++
+ tmp = g_strconcat (g_get_home_dir(), "/.gnome", NULL);
+ if (mkdir (tmp, 0700) &&
-+ errno != EEXIST) {
-+ g_warning("Could not create per-user Gnome configuration directory: %s",
-+ tmp);
++ errno != EEXIST) {
++ g_warning("Could not create per-user GNOME configuration directory: %s",
++ tmp);
+ }
+ g_free(tmp);
-+
- user_registry_dir.dirname = g_strconcat (g_get_home_dir(), "/.gnome/application-info", NULL);
- user_registry_dir.system_dir = FALSE;
-
+
+ user_registry_dir.dirname = g_build_filename (g_get_home_dir(),
+ ".gnome",
diff --git a/devel/gnome-vfs/files/patch-libgnomevfs_gnome-vfs-mime-info.c b/devel/gnome-vfs/files/patch-libgnomevfs_gnome-vfs-mime-info.c
deleted file mode 100644
index a61e83417651..000000000000
--- a/devel/gnome-vfs/files/patch-libgnomevfs_gnome-vfs-mime-info.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- libgnomevfs/gnome-vfs-mime-info.c.orig Wed Aug 4 13:41:52 2004
-+++ libgnomevfs/gnome-vfs-mime-info.c Wed Aug 4 13:42:10 2004
-@@ -149,7 +149,7 @@
-
- xdg_data_dirs = g_getenv ("XDG_DATA_DIRS");
- if (!xdg_data_dirs) {
-- xdg_data_dirs = "/usr/local/share/:/usr/share/";
-+ xdg_data_dirs = "%%X11BASE%%/share/gnome/:/usr/local/share/gnome/:%%X11BASE%%/share/:/usr/local/share/:/usr/share/";
- }
-
- split_data_dirs = g_strsplit (xdg_data_dirs, ":", 0);
diff --git a/devel/gnome-vfs/files/patch-libgnomevfs_gnome-vfs-mime.c b/devel/gnome-vfs/files/patch-libgnomevfs_gnome-vfs-mime.c
deleted file mode 100644
index 698150125205..000000000000
--- a/devel/gnome-vfs/files/patch-libgnomevfs_gnome-vfs-mime.c
+++ /dev/null
@@ -1,38 +0,0 @@
---- libgnomevfs/gnome-vfs-mime.c.orig Sat Mar 19 18:59:45 2005
-+++ libgnomevfs/gnome-vfs-mime.c Sat Mar 19 19:02:24 2005
-@@ -167,7 +167,9 @@
- GnomeVFSResult result = GNOME_VFS_OK;
- const char *mime_type;
-
-+ G_LOCK (mime_mutex);
- max_extents = xdg_mime_get_max_buffer_extents ();
-+ G_UNLOCK (mime_mutex);
- max_extents = CLAMP (max_extents, 0, MAX_SNIFF_BUFFER_ALLOWED);
-
- if (!buffer->read_whole_file) {
-@@ -592,7 +594,9 @@
- g_return_val_if_fail (a != NULL, FALSE);
- g_return_val_if_fail (b != NULL, FALSE);
-
-+ G_LOCK (mime_mutex);
- xdg_mime_mime_type_equal (a, b);
-+ G_UNLOCK (mime_mutex);
-
- return FALSE;
- }
-@@ -626,8 +630,13 @@
-
- if (gnome_vfs_mime_type_is_equal (mime_type, base_mime_type)) {
- return GNOME_VFS_MIME_IDENTICAL;
-- } else if (xdg_mime_mime_type_subclass (mime_type, base_mime_type)) {
-- return GNOME_VFS_MIME_PARENT;
-+ } else {
-+ G_LOCK (mime_mutex);
-+ if (xdg_mime_mime_type_subclass (mime_type, base_mime_type)) {
-+ G_UNLOCK (mime_mutex);
-+ return GNOME_VFS_MIME_PARENT;
-+ }
-+ G_UNLOCK (mime_mutex);
- }
-
- return GNOME_VFS_MIME_UNRELATED;
diff --git a/devel/gnome-vfs/files/patch-libgnomevfs_gnome-vfs-resolve.c b/devel/gnome-vfs/files/patch-libgnomevfs_gnome-vfs-resolve.c
index c58be91fa94b..6e3660c845b0 100644
--- a/devel/gnome-vfs/files/patch-libgnomevfs_gnome-vfs-resolve.c
+++ b/devel/gnome-vfs/files/patch-libgnomevfs_gnome-vfs-resolve.c
@@ -1,13 +1,15 @@
---- libgnomevfs/gnome-vfs-resolve.c.orig Sat Jul 31 17:52:23 2004
-+++ libgnomevfs/gnome-vfs-resolve.c Sat Jul 31 17:52:45 2004
-@@ -171,8 +171,10 @@
+--- libgnomevfs/gnome-vfs-resolve.c.orig Tue Apr 19 07:54:52 2005
++++ libgnomevfs/gnome-vfs-resolve.c Sun May 22 23:25:22 2005
+@@ -171,10 +171,12 @@ _gnome_vfs_result_from_gai_error (int er
switch (error) {
case EAI_NONAME: return GNOME_VFS_ERROR_HOST_NOT_FOUND;
-+#if defined(EAI_ADDRFAMILY) && defined(EAI_NODATA)
++#ifdef EAI_NODATA
+ #ifdef EAI_ADDRFAMILY
case EAI_ADDRFAMILY:
+ #endif
case EAI_NODATA: return GNOME_VFS_ERROR_HOST_HAS_NO_ADDRESS;
+#endif
+ #ifdef EAI_SYSTEM
case EAI_SYSTEM: return gnome_vfs_result_from_errno ();
- case EAI_FAIL:
- case EAI_AGAIN: return GNOME_VFS_ERROR_NAMESERVER;
+ #endif
diff --git a/devel/gnome-vfs/files/patch-libgnomevfs_gnome-vfs-utils.c b/devel/gnome-vfs/files/patch-libgnomevfs_gnome-vfs-utils.c
index 9788a89f060e..9c558eefd4f2 100644
--- a/devel/gnome-vfs/files/patch-libgnomevfs_gnome-vfs-utils.c
+++ b/devel/gnome-vfs/files/patch-libgnomevfs_gnome-vfs-utils.c
@@ -1,11 +1,26 @@
---- libgnomevfs/gnome-vfs-utils.c.orig Mon Aug 16 11:11:09 2004
-+++ libgnomevfs/gnome-vfs-utils.c Mon Aug 16 11:11:16 2004
-@@ -871,7 +871,7 @@
- paths = g_strsplit (gnome_var, ":", 0);
-
+--- libgnomevfs/gnome-vfs-utils.c.orig Thu Sep 15 07:02:53 2005
++++ libgnomevfs/gnome-vfs-utils.c Sat Oct 22 02:12:32 2005
+@@ -839,6 +839,7 @@ gnome_vfs_icon_path_from_filename (const
for (temp_paths = paths; *temp_paths != NULL; temp_paths++) {
-- full_filename = g_strconcat (*temp_paths, "/share/pixmaps/", relative_filename, NULL);
-+ full_filename = g_strconcat (*temp_paths, "/share/gnome/pixmaps/", relative_filename, NULL);
- if (g_file_test (full_filename, G_FILE_TEST_EXISTS)) {
- g_strfreev (paths);
- return full_filename;
+ full_filename = g_build_filename (*temp_paths,
+ "share",
++ "gnome",
+ "pixmaps",
+ relative_filename,
+ NULL);
+@@ -1991,9 +1992,14 @@ _gnome_vfs_uri_resolve_all_symlinks_uri
+ resolved_uri = gnome_vfs_uri_resolve_relative (new_uri,
+ info->symlink_name);
+ if (*p != 0) {
++ gnome_vfs_uri_unref (new_uri);
++
++ new_uri = gnome_vfs_uri_append_string (resolved_uri, p);
++
+ gnome_vfs_uri_unref (uri);
+- uri = gnome_vfs_uri_append_string (resolved_uri, p);
+ gnome_vfs_uri_unref (resolved_uri);
++
++ uri = gnome_vfs_uri_ref (new_uri);
+ } else {
+ gnome_vfs_uri_unref (uri);
+ uri = resolved_uri;
diff --git a/devel/gnome-vfs/files/patch-libgnomevfs_xdgmime.c b/devel/gnome-vfs/files/patch-libgnomevfs_xdgmime.c
index 472a4b5f6c19..37cc69f1ea3b 100644
--- a/devel/gnome-vfs/files/patch-libgnomevfs_xdgmime.c
+++ b/devel/gnome-vfs/files/patch-libgnomevfs_xdgmime.c
@@ -1,6 +1,6 @@
---- libgnomevfs/xdgmime.c.orig Thu Jul 22 11:20:13 2004
-+++ libgnomevfs/xdgmime.c Thu Jul 22 11:20:52 2004
-@@ -189,7 +189,7 @@
+--- libgnomevfs/xdgmime.c.orig Wed Aug 24 16:52:03 2005
++++ libgnomevfs/xdgmime.c Wed Aug 24 16:52:47 2005
+@@ -234,7 +234,7 @@
xdg_data_dirs = getenv ("XDG_DATA_DIRS");
if (xdg_data_dirs == NULL)
diff --git a/devel/gnome-vfs/files/patch-modules_file-method.c b/devel/gnome-vfs/files/patch-modules_file-method.c
new file mode 100644
index 000000000000..dbb237226e99
--- /dev/null
+++ b/devel/gnome-vfs/files/patch-modules_file-method.c
@@ -0,0 +1,12 @@
+--- modules/file-method.c.orig Sun May 22 23:30:16 2005
++++ modules/file-method.c Sun May 22 23:31:08 2005
+@@ -66,6 +66,9 @@
+ #if HAVE_SYS_VFS_H
+ #include <sys/vfs.h>
+ #elif HAVE_SYS_MOUNT_H
++#if HAVE_SYS_PARAM_H
++#include <sys/param.h>
++#endif
+ #include <sys/mount.h>
+ #endif
+
diff --git a/devel/gnome-vfs/files/patch-modules_smb-method.c b/devel/gnome-vfs/files/patch-modules_smb-method.c
deleted file mode 100644
index 34c10cd54f08..000000000000
--- a/devel/gnome-vfs/files/patch-modules_smb-method.c
+++ /dev/null
@@ -1,20 +0,0 @@
---- modules/smb-method.c.orig Wed Mar 2 18:44:11 2005
-+++ modules/smb-method.c Mon Sep 12 02:36:28 2005
-@@ -1425,7 +1425,7 @@ do_close (GnomeVFSMethod *method,
-
- /* Important: perform_authentication leaves and re-enters the lock! */
- while (perform_authentication (&actx) > 0) {
-- r = smb_context->close (smb_context, handle->file);
-+ r = smb_context->close_fn (smb_context, handle->file);
- actx.res = (r >= 0) ? GNOME_VFS_OK : gnome_vfs_result_from_errno ();
- }
-
-@@ -1446,7 +1446,7 @@ do_read (GnomeVFSMethod *method,
- GnomeVFSContext *context)
- {
- FileHandle *handle = (FileHandle *)method_handle;
-- GnomeVFSResult res = GNOME_VFS_OK;;
-+ GnomeVFSResult res = GNOME_VFS_OK;
- SmbAuthContext actx;
- ssize_t n = 0;
-
diff --git a/devel/gnome-vfs/pkg-deinstall.in b/devel/gnome-vfs/pkg-deinstall.in
index 7e289a563dd1..ed494001730b 100644
--- a/devel/gnome-vfs/pkg-deinstall.in
+++ b/devel/gnome-vfs/pkg-deinstall.in
@@ -1,6 +1,7 @@
#!/bin/sh
#
# $FreeBSD$
+# $MCom: ports/devel/gnomevfs2/pkg-deinstall.in,v 1.5 2005/06/28 05:40:01 adamw Exp $
#
# Restore gconf keys of libgnome.
diff --git a/devel/gnome-vfs/pkg-install.in b/devel/gnome-vfs/pkg-install.in
index 6a407a1e4f42..f7ad446b9783 100644
--- a/devel/gnome-vfs/pkg-install.in
+++ b/devel/gnome-vfs/pkg-install.in
@@ -1,6 +1,7 @@
#!/bin/sh
#
# $FreeBSD$
+# $MCom: ports/devel/gnomevfs2/pkg-install.in,v 1.5 2005/06/28 05:40:01 adamw Exp $
#
# Restore gconf keys of libgnome.
diff --git a/devel/gnome-vfs/pkg-plist b/devel/gnome-vfs/pkg-plist
index 48f676f445a3..e3505b507a49 100644
--- a/devel/gnome-vfs/pkg-plist
+++ b/devel/gnome-vfs/pkg-plist
@@ -3,9 +3,9 @@ bin/gnomevfs-copy
bin/gnomevfs-info
bin/gnomevfs-ls
bin/gnomevfs-mkdir
+bin/gnomevfs-monitor
bin/gnomevfs-mv
bin/gnomevfs-rm
-%%CDPARANOIA%%etc/gnome-vfs-2.0/modules/cdda-module.conf
etc/gnome-vfs-2.0/modules/default-modules.conf
%%SAMBA%%etc/gnome-vfs-2.0/modules/smb-module.conf
etc/gnome-vfs-2.0/modules/ssl-modules.conf
@@ -58,7 +58,6 @@ include/gnome-vfs-module-2.0/libgnomevfs/gnome-vfs-ssl.h
include/gnome-vfs-module-2.0/libgnomevfs/gnome-vfs-transform.h
lib/bonobo/monikers/libmoniker_gnome_vfs_std.so
lib/gnome-vfs-2.0/modules/libbzip2.so
-%%CDPARANOIA%%lib/gnome-vfs-2.0/modules/libcdda.so
lib/gnome-vfs-2.0/modules/libcomputer.so
lib/gnome-vfs-2.0/modules/libdns-sd.so
lib/gnome-vfs-2.0/modules/libfile.so
@@ -70,12 +69,10 @@ lib/gnome-vfs-2.0/modules/libnntp.so
lib/gnome-vfs-2.0/modules/libsftp.so
%%SAMBA%%lib/gnome-vfs-2.0/modules/libsmb.so
lib/gnome-vfs-2.0/modules/libtar.so
-lib/gnome-vfs-2.0/modules/libvfs-pipe.so
lib/gnome-vfs-2.0/modules/libvfs-test.so
-lib/gnome-vfs-2.0/modules/libvfs-translate.so
lib/libgnomevfs-2.a
lib/libgnomevfs-2.so
-lib/libgnomevfs-2.so.1000
+lib/libgnomevfs-2.so.0
libdata/bonobo/servers/GNOME_VFS_Daemon.server
libdata/bonobo/servers/GNOME_VFS_Moniker_std.server
libdata/pkgconfig/gnome-vfs-2.0.pc