aboutsummaryrefslogtreecommitdiff
path: root/devel/gnome-vfs
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2007-10-24 23:37:25 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2007-10-24 23:37:25 +0000
commit4acc6fb2a411b291c9c210d82bafe7c62e71c77d (patch)
treebc16420eb52d65511ceb520c00171d219210a473 /devel/gnome-vfs
parent97dfcc1b41c5b4581b1d73128a866beec069c5bf (diff)
Presenting GNOME 2.20.1 and all related works for FreeBSD. The official
GNOME 2.20 release notes can be found at http://www.gnome.org/start/2.20/notes/en/ . Beyond that, this update includes the new GIMP 2.4 (courtesy of ahze). The GNOME 2.20 update also includes a huge change in the FreeBSD GNOME hierarchy. We are now using the more standard DATADIR of ${PREFIX}/share rather than ${PREFIX}/share/gnome. The result is that fewer patches and hacks are needed to port GNOME components to FreeBSD. This will mean some user changes may be required, so be sure to read /usr/ports/UPDATING for more details. This release and the things we accomplished in it would not have been possible without mezz's crazy idea to collapse DATADIR, and his persistence to make it happen successfully. Ahze and pav also deserve thanks for their work on porting modules and testing the whole ball of wax on pointyhat (respectively). The FreeBSD GNOME team would also like to thank our various testers and contributors: Yasuda Keisuke Frank Jahnke Pawel Worach Brian Gruber Franz Klammer Yuri Pankov Nick Barkas Cristian KLEIN Tony Maher Scot Hetzel Martin Matuska (mm) Benoit Dejean Martin Wilke (miwi) (And anyone else I may have missed) PRs fixed in this release: 111272, 113470, 115995, 116338
Notes
Notes: svn path=/head/; revision=201947
Diffstat (limited to 'devel/gnome-vfs')
-rw-r--r--devel/gnome-vfs/Makefile7
-rw-r--r--devel/gnome-vfs/distinfo6
-rw-r--r--devel/gnome-vfs/files/patch-libgnomevfs_gnome-vfs-filesystem-type.c11
-rw-r--r--devel/gnome-vfs/files/patch-libgnomevfs_gnome-vfs-utils.c10
-rw-r--r--devel/gnome-vfs/files/patch-libgnomevfs_xdgmime.c2
-rw-r--r--devel/gnome-vfs/pkg-deinstall.in2
-rw-r--r--devel/gnome-vfs/pkg-install.in2
-rw-r--r--devel/gnome-vfs/pkg-plist8
8 files changed, 27 insertions, 21 deletions
diff --git a/devel/gnome-vfs/Makefile b/devel/gnome-vfs/Makefile
index 798462e4d3aa..4946aa02a9a1 100644
--- a/devel/gnome-vfs/Makefile
+++ b/devel/gnome-vfs/Makefile
@@ -3,16 +3,15 @@
# Whom: Ade Lovett <ade@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports/devel/gnome-vfs/Makefile,v 1.167 2007/03/13 13:02:20 ahze Exp $
+# $MCom: ports/devel/gnome-vfs/Makefile,v 1.179 2007/10/22 21:07:02 ahze Exp $
#
PORTNAME= gnome-vfs
-PORTVERSION= 2.18.1
+PORTVERSION= 2.20.0
PORTREVISION?= 2
CATEGORIES= devel gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= sources/gnome-vfs/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}
-DISTNAME= gnome-vfs-${PORTVERSION}
+MASTER_SITE_SUBDIR= sources/${PORTNAME}/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}
DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
diff --git a/devel/gnome-vfs/distinfo b/devel/gnome-vfs/distinfo
index f5b3aa6c4eb0..dbfa59bea19e 100644
--- a/devel/gnome-vfs/distinfo
+++ b/devel/gnome-vfs/distinfo
@@ -1,3 +1,3 @@
-MD5 (gnome2/gnome-vfs-2.18.1.tar.bz2) = bf4a6d95180d05981893e5d021c6695c
-SHA256 (gnome2/gnome-vfs-2.18.1.tar.bz2) = 098d920cb7d4a50e245deaafabfd8e06b86c88771d56be567597c09c09207f5e
-SIZE (gnome2/gnome-vfs-2.18.1.tar.bz2) = 1916897
+MD5 (gnome2/gnome-vfs-2.20.0.tar.bz2) = b9fe0a066d0e693e74a000e55338235b
+SHA256 (gnome2/gnome-vfs-2.20.0.tar.bz2) = cd95ec5a4808799f033dcb9daf37ed38436c594d4014e5804967fa9e5893e91f
+SIZE (gnome2/gnome-vfs-2.20.0.tar.bz2) = 1918358
diff --git a/devel/gnome-vfs/files/patch-libgnomevfs_gnome-vfs-filesystem-type.c b/devel/gnome-vfs/files/patch-libgnomevfs_gnome-vfs-filesystem-type.c
new file mode 100644
index 000000000000..c7fb1cf36dba
--- /dev/null
+++ b/devel/gnome-vfs/files/patch-libgnomevfs_gnome-vfs-filesystem-type.c
@@ -0,0 +1,11 @@
+--- libgnomevfs/gnome-vfs-filesystem-type.c.orig 2007-09-17 14:48:45.000000000 -0400
++++ libgnomevfs/gnome-vfs-filesystem-type.c 2007-09-17 14:50:06.000000000 -0400
+@@ -65,6 +65,8 @@ static struct FSInfo fs_data[] = {
+ { "msdosfs" , N_("MSDOS Volume"), 0 },
+ { "nfs" , N_("NFS Network Volume"), 1 },
+ { "ntfs" , N_("Windows NT Volume"), 0 },
++ { "nullfs" , N_("BSD Loopback Volume"), 1 },
++ { "zfs" , N_("ZFS Volume"), 1 },
+ { "nwfs" , N_("Netware Volume"), 0 },
+ { "proc" , N_("System Volume"), 0 },
+ { "procfs" , N_("System Volume"), 0 },
diff --git a/devel/gnome-vfs/files/patch-libgnomevfs_gnome-vfs-utils.c b/devel/gnome-vfs/files/patch-libgnomevfs_gnome-vfs-utils.c
deleted file mode 100644
index 068d1773a9e9..000000000000
--- a/devel/gnome-vfs/files/patch-libgnomevfs_gnome-vfs-utils.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- libgnomevfs/gnome-vfs-utils.c.orig Thu Sep 15 07:02:53 2005
-+++ libgnomevfs/gnome-vfs-utils.c Sat Oct 22 02:12:32 2005
-@@ -839,6 +839,7 @@ gnome_vfs_icon_path_from_filename (const
- for (temp_paths = paths; *temp_paths != NULL; temp_paths++) {
- full_filename = g_build_filename (*temp_paths,
- "share",
-+ "gnome",
- "pixmaps",
- relative_filename,
- NULL);
diff --git a/devel/gnome-vfs/files/patch-libgnomevfs_xdgmime.c b/devel/gnome-vfs/files/patch-libgnomevfs_xdgmime.c
index aaa8ff29d555..a9879578af2c 100644
--- a/devel/gnome-vfs/files/patch-libgnomevfs_xdgmime.c
+++ b/devel/gnome-vfs/files/patch-libgnomevfs_xdgmime.c
@@ -5,7 +5,7 @@
xdg_data_dirs = getenv ("XDG_DATA_DIRS");
if (xdg_data_dirs == NULL)
- xdg_data_dirs = "/usr/local/share/:/usr/share/";
-+ xdg_data_dirs = "%%LOCALBASE%%/share/gnome/:%%LOCALBASE%%/share/:/usr/share/";
++ xdg_data_dirs = "%%LOCALBASE%%/share/";
ptr = xdg_data_dirs;
diff --git a/devel/gnome-vfs/pkg-deinstall.in b/devel/gnome-vfs/pkg-deinstall.in
index f920c5742ca1..dffcc3de9164 100644
--- a/devel/gnome-vfs/pkg-deinstall.in
+++ b/devel/gnome-vfs/pkg-deinstall.in
@@ -1,7 +1,7 @@
#!/bin/sh
#
# $FreeBSD$
-# $MCom: ports/devel/gnome-vfs/pkg-deinstall.in,v 1.12 2006/12/18 12:34:11 ahze Exp $
+# $MCom: ports/devel/gnome-vfs/pkg-deinstall.in,v 1.15 2007/08/15 17:52:05 mezz Exp $
#
# Restore gconf keys of libgnome.
diff --git a/devel/gnome-vfs/pkg-install.in b/devel/gnome-vfs/pkg-install.in
index ff583b731c6d..ea794171815f 100644
--- a/devel/gnome-vfs/pkg-install.in
+++ b/devel/gnome-vfs/pkg-install.in
@@ -1,7 +1,7 @@
#!/bin/sh
#
# $FreeBSD$
-# $MCom: ports/devel/gnome-vfs/pkg-install.in,v 1.12 2006/12/18 12:34:11 ahze Exp $
+# $MCom: ports/devel/gnome-vfs/pkg-install.in,v 1.15 2007/08/15 17:52:05 mezz Exp $
#
# Restore gconf keys of libgnome.
diff --git a/devel/gnome-vfs/pkg-plist b/devel/gnome-vfs/pkg-plist
index 81ed5c9a097f..606b21cb5f72 100644
--- a/devel/gnome-vfs/pkg-plist
+++ b/devel/gnome-vfs/pkg-plist
@@ -28,12 +28,12 @@ include/gnome-vfs-2.0/libgnomevfs/gnome-vfs-find-directory.h
include/gnome-vfs-2.0/libgnomevfs/gnome-vfs-handle.h
include/gnome-vfs-2.0/libgnomevfs/gnome-vfs-init.h
include/gnome-vfs-2.0/libgnomevfs/gnome-vfs-job-limit.h
-include/gnome-vfs-2.0/libgnomevfs/gnome-vfs-mime.h
include/gnome-vfs-2.0/libgnomevfs/gnome-vfs-mime-deprecated.h
include/gnome-vfs-2.0/libgnomevfs/gnome-vfs-mime-handlers.h
include/gnome-vfs-2.0/libgnomevfs/gnome-vfs-mime-info-cache.h
include/gnome-vfs-2.0/libgnomevfs/gnome-vfs-mime-monitor.h
include/gnome-vfs-2.0/libgnomevfs/gnome-vfs-mime-utils.h
+include/gnome-vfs-2.0/libgnomevfs/gnome-vfs-mime.h
include/gnome-vfs-2.0/libgnomevfs/gnome-vfs-module-callback.h
include/gnome-vfs-2.0/libgnomevfs/gnome-vfs-monitor.h
include/gnome-vfs-2.0/libgnomevfs/gnome-vfs-ops.h
@@ -160,6 +160,7 @@ share/locale/ne/LC_MESSAGES/gnome-vfs-2.0.mo
share/locale/nl/LC_MESSAGES/gnome-vfs-2.0.mo
share/locale/nn/LC_MESSAGES/gnome-vfs-2.0.mo
share/locale/nso/LC_MESSAGES/gnome-vfs-2.0.mo
+share/locale/oc/LC_MESSAGES/gnome-vfs-2.0.mo
share/locale/or/LC_MESSAGES/gnome-vfs-2.0.mo
share/locale/pa/LC_MESSAGES/gnome-vfs-2.0.mo
share/locale/pl/LC_MESSAGES/gnome-vfs-2.0.mo
@@ -176,6 +177,7 @@ share/locale/sr@Latn/LC_MESSAGES/gnome-vfs-2.0.mo
share/locale/sr@ije/LC_MESSAGES/gnome-vfs-2.0.mo
share/locale/sv/LC_MESSAGES/gnome-vfs-2.0.mo
share/locale/ta/LC_MESSAGES/gnome-vfs-2.0.mo
+share/locale/te/LC_MESSAGES/gnome-vfs-2.0.mo
share/locale/th/LC_MESSAGES/gnome-vfs-2.0.mo
share/locale/tr/LC_MESSAGES/gnome-vfs-2.0.mo
share/locale/uk/LC_MESSAGES/gnome-vfs-2.0.mo
@@ -200,10 +202,14 @@ share/locale/zu/LC_MESSAGES/gnome-vfs-2.0.mo
@dirrmtry share/locale/yi
@dirrmtry share/locale/xh/LC_MESSAGES
@dirrmtry share/locale/xh
+@dirrmtry share/locale/te/LC_MESSAGES
+@dirrmtry share/locale/te
@dirrmtry share/locale/sr@ije/LC_MESSAGES
@dirrmtry share/locale/sr@ije
@dirrmtry share/locale/rw/LC_MESSAGES
@dirrmtry share/locale/rw
+@dirrmtry share/locale/oc/LC_MESSAGES
+@dirrmtry share/locale/oc
@dirrmtry share/locale/nso/LC_MESSAGES
@dirrmtry share/locale/nso
@dirrmtry share/locale/mr/LC_MESSAGES