aboutsummaryrefslogtreecommitdiff
path: root/devel/gnome-vfs
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2004-04-17 04:52:38 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2004-04-17 04:52:38 +0000
commit284534483a58ed250974a40b147943fca2f9f042 (patch)
tree19dda16e9b0ae44a8fafe41420198f63987a6676 /devel/gnome-vfs
parente4d01a7f7627f66d74c3f479f4200d879d207308 (diff)
downloadports-284534483a58ed250974a40b147943fca2f9f042.tar.gz
ports-284534483a58ed250974a40b147943fca2f9f042.zip
Notes
Diffstat (limited to 'devel/gnome-vfs')
-rw-r--r--devel/gnome-vfs/Makefile2
-rw-r--r--devel/gnome-vfs/files/patch-libgnomevfs_gnome-vfs-unix-mounts.c26
2 files changed, 25 insertions, 3 deletions
diff --git a/devel/gnome-vfs/Makefile b/devel/gnome-vfs/Makefile
index bcaf1722a6b7..40cc95ad9d73 100644
--- a/devel/gnome-vfs/Makefile
+++ b/devel/gnome-vfs/Makefile
@@ -7,7 +7,7 @@
PORTNAME= gnomevfs2
PORTVERSION= 2.6.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/gnome-vfs/2.6
diff --git a/devel/gnome-vfs/files/patch-libgnomevfs_gnome-vfs-unix-mounts.c b/devel/gnome-vfs/files/patch-libgnomevfs_gnome-vfs-unix-mounts.c
index 21912f46e0ec..7028e5a91b8e 100644
--- a/devel/gnome-vfs/files/patch-libgnomevfs_gnome-vfs-unix-mounts.c
+++ b/devel/gnome-vfs/files/patch-libgnomevfs_gnome-vfs-unix-mounts.c
@@ -1,5 +1,27 @@
---- libgnomevfs/gnome-vfs-unix-mounts.c.orig Mon Mar 8 22:29:57 2004
-+++ libgnomevfs/gnome-vfs-unix-mounts.c Mon Mar 8 22:33:35 2004
+--- libgnomevfs/gnome-vfs-unix-mounts.c.orig Mon Feb 16 06:13:27 2004
++++ libgnomevfs/gnome-vfs-unix-mounts.c Sat Apr 17 00:45:01 2004
+@@ -141,9 +141,9 @@
+ FD_ZERO(&read_fds);
+ FD_SET(pipes[0], &read_fds);
+
+- /* Wait max half a second */
+- tv.tv_sec = 0;
+- tv.tv_usec = 500;
++ /* Wait max one second */
++ tv.tv_sec = 1;
++ tv.tv_usec = 0;
+
+ res = select(pipes[0] + 1,
+ &read_fds, NULL, NULL, &tv);
+@@ -428,7 +428,7 @@
+ mount_entry->mount_path = g_strdup (mntent[i].f_mntonname);
+ mount_entry->device_path = g_strdup (mntent[i].f_mntfromname);
+ mount_entry->filesystem_type = g_strdup (mntent[i].f_fstypename);
+- if (mntent[i].f_flags == MNT_RDONLY) {
++ if (mntent[i].f_flags & MNT_RDONLY) {
+ mount_entry->is_read_only = TRUE;
+ }
+
@@ -857,8 +857,9 @@
#ifdef HAVE_SYS_SYSCTL_H