aboutsummaryrefslogtreecommitdiff
path: root/devel/gnome-vfsmm/Makefile
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2005-03-12 10:39:38 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2005-03-12 10:39:38 +0000
commit190418a078b1eb7ea3c5d38a08bdab3cbd422086 (patch)
treebb336ccecde7052d26d3d8d8c97238744a373aad /devel/gnome-vfsmm/Makefile
parent6b0c40606cac591d75b88d05c7276bd16c369035 (diff)
Notes
Diffstat (limited to 'devel/gnome-vfsmm/Makefile')
-rw-r--r--devel/gnome-vfsmm/Makefile16
1 files changed, 12 insertions, 4 deletions
diff --git a/devel/gnome-vfsmm/Makefile b/devel/gnome-vfsmm/Makefile
index 6986ce0c5971..36a002449cfa 100644
--- a/devel/gnome-vfsmm/Makefile
+++ b/devel/gnome-vfsmm/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= gnome-vfsmm
-PORTVERSION= 2.6.1
-PORTREVISION= 1
+PORTVERSION= 2.10.0
CATEGORIES= devel gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/${PORTNAME}/${PORTVERSION:R}
@@ -23,8 +22,8 @@ USE_BZIP2= yes
USE_X_PREFIX= yes
USE_GCC= 3.4
USE_GMAKE= yes
-USE_GNOME= gnomehack lthack gnomevfs2
-USE_INC_LIBTOOL_VER=13
+USE_GNOME= gnomehack gnomevfs2
+USE_INC_LIBTOOL_VER=15
INSTALLS_SHLIB= yes
CONFIGURE_ARGS= --enable-static
@@ -34,4 +33,13 @@ post-patch:
@${REINPLACE_CMD} -e '/^SUBDIRS =/s/examples//' \
${WRKSRC}/Makefile.in
+patch-autotools:
+ @(cd ${PATCH_WRKSRC}; \
+ for file in ${LIBTOOLFILES}; do \
+ ${CP} $$file $$file.tmp; \
+ ${SED} -e "/^ltmain=/s^\$$ac_aux_dir/ltmain.sh^${LTMAIN}^g" \
+ $$file.tmp > $$file; \
+ ${RM} $$file.tmp; \
+ done);
+
.include <bsd.port.mk>