aboutsummaryrefslogtreecommitdiff
path: root/devel/gnomebuild/Makefile
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2001-07-24 12:19:37 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2001-07-24 12:19:37 +0000
commit6c2ea8b207adc41044a31b572fcdc6b1f0a61fde (patch)
treee640eb572d7c96ab364cd3d0e8d67c683857cb33 /devel/gnomebuild/Makefile
parent7d2d0a6b4a9296d6579a686059ac120b951b6ec5 (diff)
downloadports-6c2ea8b207adc41044a31b572fcdc6b1f0a61fde.tar.gz
ports-6c2ea8b207adc41044a31b572fcdc6b1f0a61fde.zip
Notes
Diffstat (limited to 'devel/gnomebuild/Makefile')
-rw-r--r--devel/gnomebuild/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/devel/gnomebuild/Makefile b/devel/gnomebuild/Makefile
new file mode 100644
index 000000000000..0505ea17116f
--- /dev/null
+++ b/devel/gnomebuild/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: gnomebuild
+# Date created: 24 July 2001
+# Whom: Maxim Sobolev <sobomax@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gnomebuild
+PORTVERSION= 0.0.2
+CATEGORIES?= devel gnome
+MASTER_SITES= ${MASTER_SITE_GNOME}
+MASTER_SITE_SUBDIR= unstable/sources/${PORTNAME:S/gnome/gnome-/}
+DISTNAME= ${PORTNAME:S/gnome/gnome-/}-${PORTVERSION}
+
+MAINTAINER?= gnome@FreeBSD.org
+
+LIB_DEPENDS= gdl.0:${PORTSDIR}/x11-toolkits/gdl
+
+USE_BZIP2= yes
+USE_X_PREFIX= yes
+USE_GNOME= yes
+GNU_CONFIGURE= yes
+INSTALLS_SHLIB= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LIBS="-L${LOCALBASE}/lib"
+
+pre-patch:
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
+ s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
+ @find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
+ 's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
+ s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
+
+.include <bsd.port.mk>