aboutsummaryrefslogtreecommitdiff
path: root/devel/gnomevfs/files
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2002-03-17 16:08:33 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2002-03-17 16:08:33 +0000
commit330120e6daa6ac01d57d786f6aa3de5b8a0321f5 (patch)
tree53fdcc8bd9977407529da015fd3e659e10fdffb2 /devel/gnomevfs/files
parent799f4c83bf9ce1782f7d06a9a4b72ce16055d31f (diff)
downloadports-330120e6daa6ac01d57d786f6aa3de5b8a0321f5.tar.gz
ports-330120e6daa6ac01d57d786f6aa3de5b8a0321f5.zip
Notes
Diffstat (limited to 'devel/gnomevfs/files')
-rw-r--r--devel/gnomevfs/files/patch-aa53
-rw-r--r--devel/gnomevfs/files/patch-ab20
-rw-r--r--devel/gnomevfs/files/patch-ac34
-rw-r--r--devel/gnomevfs/files/patch-libgnomevfs::Makefile.in6
-rw-r--r--devel/gnomevfs/files/patch-libgnomevfs::gnome-vfs-mime-info.c14
-rw-r--r--devel/gnomevfs/files/patch-libgnomevfs::libcharset::Makefile.in23
6 files changed, 97 insertions, 53 deletions
diff --git a/devel/gnomevfs/files/patch-aa b/devel/gnomevfs/files/patch-aa
index 430f97e1c0d7..858c3c9d85ec 100644
--- a/devel/gnomevfs/files/patch-aa
+++ b/devel/gnomevfs/files/patch-aa
@@ -1,29 +1,29 @@
$FreeBSD$
---- configure.orig Thu Jan 24 10:25:14 2002
-+++ configure Thu Jan 24 10:38:00 2002
-@@ -5949,7 +5949,7 @@
+--- configure.orig Sun Mar 17 15:24:47 2002
++++ configure Sun Mar 17 15:25:13 2002
+@@ -5953,7 +5953,7 @@
+ VFS_GNOME_LIBS="`gnome-config --libs gnome`"
VFS_GNOMEUI_LIBS="`gnome-config --libs gnome gnomeui`"
VFS_GNOMEGNORBA_LIBS="`gnome-config --libs gnome gnomeui gnorba`"
- VFS_CAPPLET_LIBS="`gnome-config --libs gnome gnomeui capplet`"
-VFS_GLIB_CONFIG="glib-config"
+VFS_GLIB_CONFIG="$GLIB_CONFIG"
-@@ -9854,8 +9854,8 @@
+@@ -9856,8 +9856,8 @@
done
fi
-echo $ac_n "checking for bzCompressInit in -lbz2""... $ac_c" 1>&6
--echo "configure:9859: checking for bzCompressInit in -lbz2" >&5
+-echo "configure:9861: checking for bzCompressInit in -lbz2" >&5
+echo $ac_n "checking for BZ2_bzCompressInit in -lbz2""... $ac_c" 1>&6
-+echo "configure:9859: checking for BZ2_bzCompressInit in -lbz2" >&5
++echo "configure:9861: checking for BZ2_bzCompressInit in -lbz2" >&5
ac_lib_var=`echo bz2'_'bzCompressInit | sed 'y%./+-%__p_%'`
if eval "test \"`echo '$''{'ac_cv_lib_$ac_lib_var'+set}'`\" = set"; then
echo $ac_n "(cached) $ac_c" 1>&6
-@@ -9868,10 +9868,10 @@
+@@ -9870,10 +9870,10 @@
/* Override any gcc2 internal prototype to avoid an error. */
/* We use char because int might match the return type of a gcc2
builtin and then its argument prototype would still apply. */
@@ -35,17 +35,17 @@ $FreeBSD$
+BZ2_bzCompressInit()
; return 0; }
EOF
- if { (eval echo configure:9878: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
-@@ -10101,7 +10101,7 @@
+ if { (eval echo configure:9880: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
+@@ -10103,7 +10103,7 @@
echo $ac_n "(cached) $ac_c" 1>&6
else
- LDFLAGS="$LDFLAGS -L$with_openssl_libs -lssl -lcrypto -ldl"
+ LDFLAGS="$LDFLAGS -L$with_openssl_libs -lssl -lcryptofoo"
cat > conftest.$ac_ext <<EOF
- #line 10107 "configure"
+ #line 10109 "configure"
#include "confdefs.h"
-@@ -10135,7 +10135,7 @@
+@@ -10137,7 +10137,7 @@
EOF
msg_openssl="yes"
@@ -54,7 +54,34 @@ $FreeBSD$
if true; then
-@@ -10594,7 +10594,7 @@
+@@ -10559,14 +10559,14 @@
+ #
+ # Check for libiconv
+ #
+- echo $ac_n "checking for libiconv_open in -liconv""... $ac_c" 1>&6
+-echo "configure:10564: checking for libiconv_open in -liconv" >&5
++ echo $ac_n "checking for libiconv_open in -lgiconv""... $ac_c" 1>&6
++echo "configure:10564: checking for libiconv_open in -lgiconv" >&5
+ ac_lib_var=`echo iconv'_'libiconv_open | sed 'y%./+-%__p_%'`
+ if eval "test \"`echo '$''{'ac_cv_lib_$ac_lib_var'+set}'`\" = set"; then
+ echo $ac_n "(cached) $ac_c" 1>&6
+ else
+ ac_save_LIBS="$LIBS"
+-LIBS="-liconv $LIBS"
++LIBS="-lgiconv $LIBS"
+ cat > conftest.$ac_ext <<EOF
+ #line 10572 "configure"
+ #include "confdefs.h"
+@@ -10606,7 +10606,7 @@
+ fi
+
+ if test "x$with_libiconv" = "xyes" ; then
+- ICONV_LIBS="-liconv"
++ ICONV_LIBS="-lgiconv"
+ cat >> confdefs.h <<\EOF
+ #define USE_LIBICONV 1
+ EOF
+@@ -10897,7 +10897,7 @@
s%@GTK_CFLAGS@%$GTK_CFLAGS%g
s%@GTK_LIBS@%$GTK_LIBS%g
s%@cflags_set@%$cflags_set%g
diff --git a/devel/gnomevfs/files/patch-ab b/devel/gnomevfs/files/patch-ab
index 5c79863db926..55058a4d496b 100644
--- a/devel/gnomevfs/files/patch-ab
+++ b/devel/gnomevfs/files/patch-ab
@@ -1,21 +1,23 @@
$FreeBSD$
---- Makefile.in.orig Tue Jan 22 11:51:36 2002
-+++ Makefile.in Tue Jan 22 11:53:19 2002
-@@ -186,9 +186,9 @@
+--- Makefile.in.orig Sun Mar 17 16:04:01 2002
++++ Makefile.in Sun Mar 17 16:14:05 2002
+@@ -187,10 +187,10 @@
+ cflags_set = @cflags_set@
cxxflags_set = @cxxflags_set@
l = @l@
- @PLATFORM_GNOME_2_TRUE@SUBDIRS_GNOME = doc
+-@PLATFORM_GNOME_2_TRUE@SUBDIRS_GNOME = doc
-@PLATFORM_GNOME_2_FALSE@SUBDIRS_GNOME = doc test
-+@PLATFORM_GNOME_2_FALSE@SUBDIRS_GNOME = doc
++@PLATFORM_GNOME_2_TRUE@SUBDIRS_GNOME =
++@PLATFORM_GNOME_2_FALSE@SUBDIRS_GNOME =
--SUBDIRS = libgnomevfs libgnomevfs-pthread idl modules man devel-docs $(SUBDIRS_GNOME) po
-+SUBDIRS = libgnomevfs libgnomevfs-pthread idl modules man $(SUBDIRS_GNOME) po
+-SUBDIRS = libgnomevfs libgnomevfs-pthread idl modules devel-docs $(SUBDIRS_GNOME) po
++SUBDIRS = libgnomevfs libgnomevfs-pthread idl modules $(SUBDIRS_GNOME) po
EXTRA_DIST = HACKING TODO autogen.sh gnome-vfs.spec vfsConf.sh.in xml-i18n-extract.in xml-i18n-merge.in xml-i18n-update.in gnome-vfs-config.in
-@@ -196,7 +196,7 @@
+@@ -198,7 +198,7 @@
bin_SCRIPTS = $(top_builddir)/gnome-vfs-config
@@ -24,7 +26,7 @@ $FreeBSD$
confexec_DATA = vfsConf.sh
ACLOCAL_M4 = $(top_srcdir)/aclocal.m4
-@@ -535,11 +535,13 @@
+@@ -537,11 +537,13 @@
-e 's?\@VFS_INCLUDEDIR\@?$(VFS_INCLUDEDIR)?g' \
-e 's?\@VERSION\@?$(VERSION)?g' \
-e 's?\@VFS_LIBS\@?$(VFS_LIBS)?g' \
diff --git a/devel/gnomevfs/files/patch-ac b/devel/gnomevfs/files/patch-ac
index 03b8559abc77..29014f5e1e52 100644
--- a/devel/gnomevfs/files/patch-ac
+++ b/devel/gnomevfs/files/patch-ac
@@ -1,9 +1,9 @@
$FreeBSD$
---- modules/Makefile.in.orig Thu Jan 24 10:25:14 2002
-+++ modules/Makefile.in Thu Jan 24 10:45:26 2002
-@@ -197,7 +197,7 @@
+--- modules/Makefile.in.orig Sun Mar 17 15:05:08 2002
++++ modules/Makefile.in Sun Mar 17 15:05:08 2002
+@@ -199,7 +199,7 @@
@HAVE_CDDA_TRUE@CDDA_LTLIBS = libcdda.la
@HAVE_CDDA_FALSE@CDDA_LTLIBS =
@@ -12,33 +12,11 @@ $FreeBSD$
modulesdir = $(libdir)/vfs/modules
modules_LTLIBRARIES = $(CDDA_LTLIBS) libextfs.la libfile.la libvfs-test.la $(HTTP_LTLIBS) libbzip2.la libgzip.la libftp.la libnntp.la libvfs-pipe.la libvfs-translate.la libdesktop.la $(NULL)
-@@ -216,7 +216,6 @@
+@@ -217,7 +217,6 @@
+ ### `cdda' method
libcdda_la_SOURCES = cdda-method.c cdda-method.h cdda-cddb.c cdda-cddb.h cdda-cdrom-extensions.h
-
-
+
libcdda_la_LDFLAGS = $(module_flags)
libcdda_la_LIBADD = -L/gnome/lib -lcdda_paranoia -lcdda_interface
-
-@@ -311,7 +310,7 @@
- libextfs_la_OBJECTS = extfs-method.lo
- libfile_la_LIBADD =
- libfile_la_OBJECTS = file-method.lo
--libvfs_test_la_LDFLAGS =
-+libvfs_test_la_LDFLAGS = $(module_flags)
- libvfs_test_la_DEPENDENCIES =
- libvfs_test_la_OBJECTS = test-method.lo
- libhttp_la_DEPENDENCIES =
-@@ -320,10 +319,10 @@
- libbzip2_la_OBJECTS = bzip2-method.lo
- libgzip_la_DEPENDENCIES =
- libgzip_la_OBJECTS = gzip-method.lo
--libftp_la_LDFLAGS =
-+libftp_la_LDFLAGS = $(module_flags)
- libftp_la_LIBADD =
- libftp_la_OBJECTS = ftp-method.lo
--libnntp_la_LDFLAGS =
-+libnntp_la_LDFLAGS = $(module_flags)
- libnntp_la_LIBADD =
- libnntp_la_OBJECTS = nntp-method.lo
- libvfs_pipe_la_DEPENDENCIES =
diff --git a/devel/gnomevfs/files/patch-libgnomevfs::Makefile.in b/devel/gnomevfs/files/patch-libgnomevfs::Makefile.in
index c8ca73f68d60..77e49d02b783 100644
--- a/devel/gnomevfs/files/patch-libgnomevfs::Makefile.in
+++ b/devel/gnomevfs/files/patch-libgnomevfs::Makefile.in
@@ -1,9 +1,9 @@
$FreeBSD$
---- libgnomevfs/Makefile.in 2001/09/17 14:32:27 1.1
-+++ libgnomevfs/Makefile.in 2001/09/17 14:33:02
-@@ -202,7 +202,7 @@
+--- libgnomevfs/Makefile.in.orig Sun Mar 17 16:04:01 2002
++++ libgnomevfs/Makefile.in Sun Mar 17 16:26:57 2002
+@@ -215,7 +215,7 @@
# Platform specific includes
diff --git a/devel/gnomevfs/files/patch-libgnomevfs::gnome-vfs-mime-info.c b/devel/gnomevfs/files/patch-libgnomevfs::gnome-vfs-mime-info.c
new file mode 100644
index 000000000000..cb57b3afd83d
--- /dev/null
+++ b/devel/gnomevfs/files/patch-libgnomevfs::gnome-vfs-mime-info.c
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- libgnomevfs/gnome-vfs-mime-info.c 2002/03/17 13:33:30 1.1
++++ libgnomevfs/gnome-vfs-mime-info.c 2002/03/17 13:33:39
+@@ -46,7 +46,7 @@
+ #include <time.h>
+ #include <unistd.h>
+
+-#include <iconv.h>
++#include <giconv.h>
+ #include <errno.h>
+ #include <stdlib.h>
+
diff --git a/devel/gnomevfs/files/patch-libgnomevfs::libcharset::Makefile.in b/devel/gnomevfs/files/patch-libgnomevfs::libcharset::Makefile.in
new file mode 100644
index 000000000000..090241b1c989
--- /dev/null
+++ b/devel/gnomevfs/files/patch-libgnomevfs::libcharset::Makefile.in
@@ -0,0 +1,23 @@
+
+$FreeBSD$
+
+--- libgnomevfs/libcharset/Makefile.in 2002/03/17 14:28:57 1.1
++++ libgnomevfs/libcharset/Makefile.in 2002/03/17 14:30:13
+@@ -188,7 +188,7 @@
+ cxxflags_set = @cxxflags_set@
+ l = @l@
+
+-INCLUDES = -DLIBDIR=\"$(libdir)\"
++INCLUDES = -DLIBDIR=\"$(prefix)/libdata\"
+
+
+ noinst_LTLIBRARIES = libcharset.la
+@@ -351,7 +351,7 @@
+ check: check-am
+ installcheck-am:
+ installcheck: installcheck-am
+-install-exec-am: install-exec-local
++install-exec-am:
+ install-exec: install-exec-am
+
+ install-data-am: