aboutsummaryrefslogtreecommitdiff
path: root/devel/gnu-libtool/Makefile
diff options
context:
space:
mode:
authorAde Lovett <ade@FreeBSD.org>2003-07-02 18:26:53 +0000
committerAde Lovett <ade@FreeBSD.org>2003-07-02 18:26:53 +0000
commitaba51095cc77e2ae5dd655d80528e86562ee0439 (patch)
treee022f0579f28796617d3bf7d5894ebab6d30d144 /devel/gnu-libtool/Makefile
parent7e9486d202724cb4f65b88cd6f994ce7fe88ac88 (diff)
downloadports-aba51095cc77e2ae5dd655d80528e86562ee0439.tar.gz
ports-aba51095cc77e2ae5dd655d80528e86562ee0439.zip
Notes
Diffstat (limited to 'devel/gnu-libtool/Makefile')
-rw-r--r--devel/gnu-libtool/Makefile16
1 files changed, 9 insertions, 7 deletions
diff --git a/devel/gnu-libtool/Makefile b/devel/gnu-libtool/Makefile
index d695e994da67..b6bb08299ae2 100644
--- a/devel/gnu-libtool/Makefile
+++ b/devel/gnu-libtool/Makefile
@@ -6,8 +6,8 @@
#
PORTNAME?= libtool
-PORTVERSION= 1.4.3
-PORTREVISION?= 1
+PORTVERSION= 1.5
+PORTREVISION?= 0
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= libtool
@@ -16,14 +16,14 @@ DISTNAME= libtool-${PORTVERSION}
MAINTAINER= ade@FreeBSD.org
COMMENT?= Generic shared library support script
-BUILD_VERSION= 14
+BUILD_VERSION= 15
LATEST_LINK?= libtool${BUILD_VERSION}
PLIST_SUB= BUILD_VERSION=${BUILD_VERSION}
GNU_CONFIGURE= yes
CONFIGURE_ARGS?= --disable-ltdl-install
CONFIGURE_ARGS+= --program-suffix=${BUILD_VERSION}
-INSTALLS_SHLIB= yes
CONFIGURE_ENV= PREFIX=${PREFIX} PACKAGE=libtool${BUILD_VERSION}
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
USE_REINPLACE= yes
.if defined(USE_LIBTOOL) || defined(USE_LIBTOOL_VER)
@@ -36,13 +36,15 @@ pre-everything:
@${FALSE}
.endif # defined(USE_LIBTOOL) || defined(USE_LIBTOOL_VER)
-post-extract:
+post-patch:
+ @(cd ${WRKSRC}/doc && \
+ ${RM} -f *.info* && \
+ ${MV} libtool.texi libtool${BUILD_VERSION}.texi && \
+ ${REINPLACE_CMD} -E 's,(libtool|libtoolize)\),\1${BUILDVERSION}\),g' libtool${BUILD_VERSION}.texi)
@${MV} -f ${WRKSRC}/libtool.m4 ${WRKSRC}/libtool${BUILD_VERSION}.m4
@${MV} -f ${WRKSRC}/ltdl.m4 ${WRKSRC}/ltdl${BUILD_VERSION}.m4
@${REINPLACE_CMD} -e 's|libtool.m4|libtool${BUILD_VERSION}.m4|g' \
-e 's|ltdl.m4|ltdl${BUILD_VERSION}.m4|g' ${WRKSRC}/Makefile.in
- @${MV} -f ${WRKSRC}/doc/libtool.info ${WRKSRC}/doc/libtool${BUILD_VERSION}.info
- @${MV} -f ${WRKSRC}/doc/libtool.texi ${WRKSRC}/doc/libtool${BUILD_VERSION}.texi
.if ${PORTNAME} == "libtool"
post-install: