aboutsummaryrefslogtreecommitdiff
path: root/devel/gnustep-make
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2006-09-13 04:59:22 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2006-09-13 04:59:22 +0000
commite23bc71a87b30dba5e78de334e051c5f2f647d0c (patch)
tree49599d914c1a1c841796a0b2ef67927c54d98550 /devel/gnustep-make
parent3d1dfa1fb577ecb7c5e71d2e019e1ea8bf85f13f (diff)
downloadports-e23bc71a87b30dba5e78de334e051c5f2f647d0c.tar.gz
ports-e23bc71a87b30dba5e78de334e051c5f2f647d0c.zip
Notes
Diffstat (limited to 'devel/gnustep-make')
-rw-r--r--devel/gnustep-make/Makefile7
-rw-r--r--devel/gnustep-make/pkg-plist14
2 files changed, 20 insertions, 1 deletions
diff --git a/devel/gnustep-make/Makefile b/devel/gnustep-make/Makefile
index 820ddc6dc2c1..4fa061dba63a 100644
--- a/devel/gnustep-make/Makefile
+++ b/devel/gnustep-make/Makefile
@@ -7,6 +7,7 @@
PORTNAME= gnustep-make
PORTVERSION= 1.13.0
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_GNUSTEP}
MASTER_SITE_SUBDIR= core
@@ -33,5 +34,11 @@ GNUSTEP_WITHOUT_LIBOBJC= yes
post-install:
${LN} -s Library/Makefiles ${PREFIX}/System/
+ -${MKDIR} ${PREFIX}/Local/Applications
+ -${MKDIR} ${PREFIX}/Local/Library/Bundles
+ -${MKDIR} ${PREFIX}/Local/Library/Frameworks
+ -${MKDIR} ${PREFIX}/Local/Library/Headers
+ -${MKDIR} ${PREFIX}/Local/Library/Libraries
+ -${MKDIR} ${PREFIX}/Local/Library/Preferences
.include <bsd.port.mk>
diff --git a/devel/gnustep-make/pkg-plist b/devel/gnustep-make/pkg-plist
index 3bc43e6c17eb..af8944c58662 100644
--- a/devel/gnustep-make/pkg-plist
+++ b/devel/gnustep-make/pkg-plist
@@ -154,9 +154,21 @@ System/share/config.site
@dirrm System/Library
@dirrm System/Applications
@dirrm System
+@dirrm Local/Library/Preferences
+@dirrm Local/Library/Libraries
+@dirrm Local/Library/Headers
+@dirrm Local/Library/Frameworks
+@dirrm Local/Library/Bundles
+@dirrm Local/Library
+@dirrm Local/Applications
@dirrm Local
@unexec rmdir %D
-@exec mkdir -p %D/Local
+@exec mkdir -p %D/Local/Applications
+@exec mkdir -p %D/Local/Library/Bundles
+@exec mkdir -p %D/Local/Library/Frameworks
+@exec mkdir -p %D/Local/Library/Headers
+@exec mkdir -p %D/Local/Library/Libraries
+@exec mkdir -p %D/Local/Library/Preferences
@exec mkdir -p %D/System/Applications
@exec mkdir -p %D/System/Library/ApplicationSupport
@exec mkdir -p %D/System/Library/Bundles