aboutsummaryrefslogtreecommitdiff
path: root/devel/gnustep-make
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2003-07-26 14:38:59 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2003-07-26 14:38:59 +0000
commit7c61939a92e7c053dc3c58764ea1b317265a0d2b (patch)
treede4b800e8c9cf502ef5d2ab3efb93d0ece787cff /devel/gnustep-make
parent49a9f07599e1d61d4772446d70f92cfd9afb4a9f (diff)
downloadports-7c61939a92e7c053dc3c58764ea1b317265a0d2b.tar.gz
ports-7c61939a92e7c053dc3c58764ea1b317265a0d2b.zip
Notes
Diffstat (limited to 'devel/gnustep-make')
-rw-r--r--devel/gnustep-make/Makefile17
-rw-r--r--devel/gnustep-make/distinfo2
-rw-r--r--devel/gnustep-make/files/configure.patch11
-rw-r--r--devel/gnustep-make/files/target.make.patch (renamed from devel/gnustep-make/files/patch-target.make)0
-rw-r--r--devel/gnustep-make/files/target.make.patch-devel13
-rw-r--r--devel/gnustep-make/pkg-plist15
6 files changed, 34 insertions, 24 deletions
diff --git a/devel/gnustep-make/Makefile b/devel/gnustep-make/Makefile
index 360f06f58714..ff7a9b41948a 100644
--- a/devel/gnustep-make/Makefile
+++ b/devel/gnustep-make/Makefile
@@ -7,7 +7,7 @@
PORTNAME= gnustep-make
.if defined(WITH_GNUSTEP_DEVEL)
-PORTVERSION= 1.7.1
+PORTVERSION= 1.7.2
.else
PORTVERSION= 1.6.0
.endif
@@ -18,7 +18,9 @@ MASTER_SITES= ${MASTER_SITE_GNUSTEP} \
ftp://ftp.easynet.nl/mirror/GNUstep/%SUBDIR%/
MASTER_SITE_SUBDIR= core
.if defined(WITH_GNUSTEP_DEVEL)
-EXTRA_PATCHES+= ${FILESDIR}/configure.patch
+EXTRA_PATCHES+= ${FILESDIR}/target.make.patch-devel
+.else
+EXTRA_PATCHES+= ${FILESDIR}/target.make.patch
.endif
MAINTAINER= dinoex@FreeBSD.org
@@ -34,6 +36,12 @@ USE_GMAKE= yes
MAKEFILE=
MAKE_FLAGS= OPTFLAG="${CFLAGS}"
+.if defined(WITH_GNUSTEP_DEVEL)
+PLIST_SUB+= NOFLAT2=""
+.else
+PLIST_SUB+= NOFLAT2="${GNU_ARCH}/${OPSYS:L}/"
+.endif
+
.include <bsd.port.pre.mk>
.include "${PORTSDIR}/devel/gnustep/bsd.gnustep.mk"
@@ -43,9 +51,4 @@ post-configure:
${SED} -e "s|\(objc_threaded:=\).*|\1 ${PTHREAD_LIBS}|" \
< ${WRKSRC}/config.make.sed > ${WRKSRC}/config.make
-.if defined(WITH_GNUSTEP_DEVEL)
-post-install:
- ${RM} -f ${PREFIX}/System/Makefiles/Makefiles
-
-.endif
.include <bsd.port.post.mk>
diff --git a/devel/gnustep-make/distinfo b/devel/gnustep-make/distinfo
index 26aeb4bfc334..48dbad60db5e 100644
--- a/devel/gnustep-make/distinfo
+++ b/devel/gnustep-make/distinfo
@@ -1,2 +1,2 @@
MD5 (gnustep-make-1.6.0.tar.gz) = e17e758ee9ab5bbe24dcc01fdafdb13c
-MD5 (gnustep-make-1.7.1.tar.gz) = 5b349dd804785f335392ef4749e72a6d
+MD5 (gnustep-make-1.7.2.tar.gz) = 4f6d66701ad909e57f2dba5db7f2bb54
diff --git a/devel/gnustep-make/files/configure.patch b/devel/gnustep-make/files/configure.patch
deleted file mode 100644
index 2bb5871d3242..000000000000
--- a/devel/gnustep-make/files/configure.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- configure.orig Tue May 20 05:22:53 2003
-+++ configure Tue May 27 23:48:05 2003
-@@ -2902,7 +2902,7 @@
- # Makefiles dir in the previous location, reset this variable to
- # 'Makefiles' and regenerate configure. Note this doesn't change all
- # occurances.
--MAKEFILES_SUFFIX=Library/Makefiles
-+MAKEFILES_SUFFIX=Makefiles
-
-
- # HOST_INSTALL is the name of the install program in config.make so set it up
diff --git a/devel/gnustep-make/files/patch-target.make b/devel/gnustep-make/files/target.make.patch
index 3cb68f66f430..3cb68f66f430 100644
--- a/devel/gnustep-make/files/patch-target.make
+++ b/devel/gnustep-make/files/target.make.patch
diff --git a/devel/gnustep-make/files/target.make.patch-devel b/devel/gnustep-make/files/target.make.patch-devel
new file mode 100644
index 000000000000..f9eb7ddccbad
--- /dev/null
+++ b/devel/gnustep-make/files/target.make.patch-devel
@@ -0,0 +1,13 @@
+--- target.make.orig Tue Jul 22 05:03:27 2003
++++ target.make Thu Jul 24 10:23:35 2003
+@@ -36,8 +36,8 @@
+ #
+ TARGET_SYSTEM_LIBS = $(CONFIG_SYSTEM_LIBS) -lm
+ ifneq ("$(objc_threaded)","")
+- INTERNAL_CFLAGS = -D_REENTRANT
+- INTERNAL_OBJCFLAGS = -D_REENTRANT
++ INTERNAL_CFLAGS = -D_REENTRANT -D_THREAD_SAFE
++ INTERNAL_OBJCFLAGS = -D_REENTRANT -D_THREAD_SAFE
+ AUXILIARY_OBJC_LIBS += $(objc_threaded)
+ ifeq ($(shared), no)
+ TARGET_SYSTEM_LIBS += $(objc_threaded)
diff --git a/devel/gnustep-make/pkg-plist b/devel/gnustep-make/pkg-plist
index 4ac250385208..9ad9ae505474 100644
--- a/devel/gnustep-make/pkg-plist
+++ b/devel/gnustep-make/pkg-plist
@@ -1,3 +1,5 @@
+%%GNUSTEP_DEVEL%%@exec mkdir -p %D/System/Library/Makefiles
+%%GNUSTEP_DEVEL%%@exec ln -s Library/Makefiles %D/System
System/Makefiles/GNUstep-reset.sh
System/Makefiles/GNUstep.csh
System/Makefiles/GNUstep.sh
@@ -76,9 +78,9 @@ System/Makefiles/framework.make
System/Makefiles/gswapp.make
System/Makefiles/gswbundle.make
System/Makefiles/install-sh
-System/Makefiles/%%GNU_ARCH%%/%%OPSYS%%/config.make
-System/Makefiles/%%GNU_ARCH%%/%%OPSYS%%/user_home
-System/Makefiles/%%GNU_ARCH%%/%%OPSYS%%/which_lib
+System/Makefiles/%%NOFLAT2%%config.make
+System/Makefiles/%%NOFLAT2%%user_home
+System/Makefiles/%%NOFLAT2%%which_lib
System/Makefiles/java-executable.template
System/Makefiles/java-tool.make
System/Makefiles/java.make
@@ -116,7 +118,7 @@ System/share/config.site
@dirrm System/Tools/Resources
@dirrm System/Tools/Java
@dirrm System/Tools
-@dirrm System/Makefiles/%%GNU_ARCH%%/%%OPSYS%%
+%%GNUSTEP_STABLE%%@dirrm System/Makefiles/%%GNU_ARCH%%/%%OPSYS%%
@dirrm System/Makefiles/%%GNU_ARCH%%
@dirrm System/Makefiles/Master
@dirrm System/Makefiles/Instance/Shared
@@ -124,7 +126,9 @@ System/share/config.site
@dirrm System/Makefiles/Instance
@dirrm System/Makefiles/Auxiliary
@dirrm System/Makefiles/Additional
-@dirrm System/Makefiles
+%%GNUSTEP_STABLE%%@dirrm System/Makefiles
+%%GNUSTEP_DEVEL%%@unexec rm -f %D/System/Makefiles
+%%GNUSTEP_DEVEL%%@dirrm System/Library/Makefiles
%%GNUSTEP_DEVEL%%@dirrm System/Library/Sounds
@dirrm System/Library/Services
@dirrm System/Library/PostScript
@@ -174,6 +178,7 @@ System/share/config.site
%%GNUSTEP_DEVEL%%@exec mkdir -p %D/System/Library/Images
%%GNUSTEP_DEVEL%%@exec mkdir -p %D/System/Library/KeyBindings
@exec mkdir -p %D/%%SYSTEMLIBRARY%%/Libraries/Java
+%%GNUSTEP_DEVEL%%@exec mkdir -p %D/System/Library/Makefiles/%%GNU_ARCH%%
@exec mkdir -p %D/%%SYSTEMLIBRARY%%/Libraries/Resources
@comment @exec mkdir -p %D/System/Library/Makefiles
@exec mkdir -p %D/System/Library/PostScript