aboutsummaryrefslogtreecommitdiff
path: root/devel/gnustep-make
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2008-12-24 07:51:07 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2008-12-24 07:51:07 +0000
commitdb7c4147a6ca51e353cc79a620cfe4858342c1dd (patch)
tree23dab237ee80d35689a4a52d173b1adf3ecb5e68 /devel/gnustep-make
parentba89e9ecd8969ceec0018ccefd12f741ae106ba9 (diff)
downloadports-db7c4147a6ca51e353cc79a620cfe4858342c1dd.tar.gz
ports-db7c4147a6ca51e353cc79a620cfe4858342c1dd.zip
Notes
Diffstat (limited to 'devel/gnustep-make')
-rw-r--r--devel/gnustep-make/Makefile72
-rw-r--r--devel/gnustep-make/distinfo6
-rw-r--r--devel/gnustep-make/pkg-plist2
3 files changed, 39 insertions, 41 deletions
diff --git a/devel/gnustep-make/Makefile b/devel/gnustep-make/Makefile
index 9018fb6d1cf5..31fec5e8b4bb 100644
--- a/devel/gnustep-make/Makefile
+++ b/devel/gnustep-make/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= gnustep-make
-PORTVERSION= 2.0.6
+PORTVERSION= 2.0.7
CATEGORIES= devel gnustep
MASTER_SITES= ${MASTER_SITE_GNUSTEP}
MASTER_SITE_SUBDIR= core
@@ -16,53 +16,53 @@ COMMENT= GNUstep makefile package
USE_GNUSTEP= yes
USE_GNUSTEP_PREFIX= yes
+GNU_CONFIGURE= yes
RESTRICTED= GPL3
-GNU_CONFIGURE= yes
MAKE_FLAGS= OPTFLAG="${CFLAGS}"
CFLAGS+= ${PTHREAD_CFLAGS}
CONFIGURE_ENV+= INSTALL_PROGRAM="${INSTALL} -c" INSTALL_DATA="${INSTALL} -c" \
CFLAGS="${CFLAGS}"
CONFIGURE_ARGS+= --with-thread-lib="${PTHREAD_LIBS}"
-CONFIGURE_ARGS+= --with-config-file=${PREFIX}/GNUstep.conf
+CONFIGURE_ARGS+= --with-config-file=${GNUSTEP_PREFIX}/GNUstep.conf
.if defined(GNUSTEP_WITH_BASE_GCC)
GNUSTEP_WITHOUT_LIBOBJC= yes
.endif
post-install:
- ${LN} -s Library/Makefiles ${PREFIX}/System/
- -${MKDIR} ${PREFIX}/System/Applications
- -${MKDIR} ${PREFIX}/System/Library/ApplicationSupport
- -${MKDIR} ${PREFIX}/System/Library/Bundles
- -${MKDIR} ${PREFIX}/System/Library/ColorPickers
- -${MKDIR} ${PREFIX}/System/Library/Colors
- -${MKDIR} ${PREFIX}/System/Library/DocTemplates
- -${MKDIR} ${PREFIX}/System/Library/Documentation/info
- -${MKDIR} ${PREFIX}/System/Library/Documentation/man
- -${MKDIR} ${PREFIX}/System/Library/Documentation/Developer
- -${MKDIR} ${PREFIX}/System/Library/Documentation/User
- -${MKDIR} ${PREFIX}/System/Library/Fonts
- -${MKDIR} ${PREFIX}/System/Library/Frameworks
- -${MKDIR} ${PREFIX}/System/Library/Headers
- -${MKDIR} ${PREFIX}/System/Library/Images
- -${MKDIR} ${PREFIX}/System/Library/KeyBindings
- -${MKDIR} ${PREFIX}/System/Library/Libraries/Java
- -${MKDIR} ${PREFIX}/System/Library/Libraries/Resources
- -${MKDIR} ${PREFIX}/System/Library/PostScript
- -${MKDIR} ${PREFIX}/System/Library/Services
- -${MKDIR} ${PREFIX}/System/Library/Sounds
- -${MKDIR} ${PREFIX}/System/Tools/Java
- -${MKDIR} ${PREFIX}/System/Tools/Resources
- -${MKDIR} ${PREFIX}/Local/Applications
- -${MKDIR} ${PREFIX}/Local/Library/ApplicationSupport
- -${MKDIR} ${PREFIX}/Local/Library/Bundles
- -${MKDIR} ${PREFIX}/Local/Library/Documentation
- -${MKDIR} ${PREFIX}/Local/Library/Frameworks
- -${MKDIR} ${PREFIX}/Local/Library/Headers
- -${MKDIR} ${PREFIX}/Local/Library/Libraries
- -${MKDIR} ${PREFIX}/Local/Library/Preferences
- -${MKDIR} ${PREFIX}/Local/Library/Services
- -${MKDIR} ${PREFIX}/Local/Tools/Resources
+ ${LN} -s Library/Makefiles ${GNUSTEP_PREFIX}/System/
+ -${MKDIR} ${GNUSTEP_PREFIX}/System/Applications
+ -${MKDIR} ${GNUSTEP_PREFIX}/System/Library/ApplicationSupport
+ -${MKDIR} ${GNUSTEP_PREFIX}/System/Library/Bundles
+ -${MKDIR} ${GNUSTEP_PREFIX}/System/Library/ColorPickers
+ -${MKDIR} ${GNUSTEP_PREFIX}/System/Library/Colors
+ -${MKDIR} ${GNUSTEP_PREFIX}/System/Library/DocTemplates
+ -${MKDIR} ${GNUSTEP_PREFIX}/System/Library/Documentation/info
+ -${MKDIR} ${GNUSTEP_PREFIX}/System/Library/Documentation/man
+ -${MKDIR} ${GNUSTEP_PREFIX}/System/Library/Documentation/Developer
+ -${MKDIR} ${GNUSTEP_PREFIX}/System/Library/Documentation/User
+ -${MKDIR} ${GNUSTEP_PREFIX}/System/Library/Fonts
+ -${MKDIR} ${GNUSTEP_PREFIX}/System/Library/Frameworks
+ -${MKDIR} ${GNUSTEP_PREFIX}/System/Library/Headers
+ -${MKDIR} ${GNUSTEP_PREFIX}/System/Library/Images
+ -${MKDIR} ${GNUSTEP_PREFIX}/System/Library/KeyBindings
+ -${MKDIR} ${GNUSTEP_PREFIX}/System/Library/Libraries/Java
+ -${MKDIR} ${GNUSTEP_PREFIX}/System/Library/Libraries/Resources
+ -${MKDIR} ${GNUSTEP_PREFIX}/System/Library/PostScript
+ -${MKDIR} ${GNUSTEP_PREFIX}/System/Library/Services
+ -${MKDIR} ${GNUSTEP_PREFIX}/System/Library/Sounds
+ -${MKDIR} ${GNUSTEP_PREFIX}/System/Tools/Java
+ -${MKDIR} ${GNUSTEP_PREFIX}/System/Tools/Resources
+ -${MKDIR} ${GNUSTEP_PREFIX}/Local/Applications
+ -${MKDIR} ${GNUSTEP_PREFIX}/Local/Library/ApplicationSupport
+ -${MKDIR} ${GNUSTEP_PREFIX}/Local/Library/Bundles
+ -${MKDIR} ${GNUSTEP_PREFIX}/Local/Library/Documentation
+ -${MKDIR} ${GNUSTEP_PREFIX}/Local/Library/Frameworks
+ -${MKDIR} ${GNUSTEP_PREFIX}/Local/Library/Headers
+ -${MKDIR} ${GNUSTEP_PREFIX}/Local/Library/Libraries
+ -${MKDIR} ${GNUSTEP_PREFIX}/Local/Library/Preferences
+ -${MKDIR} ${GNUSTEP_PREFIX}/Local/Library/Services
+ -${MKDIR} ${GNUSTEP_PREFIX}/Local/Tools/Resources
.include <bsd.port.mk>
diff --git a/devel/gnustep-make/distinfo b/devel/gnustep-make/distinfo
index 5fd5d84f02f6..f280bdb92862 100644
--- a/devel/gnustep-make/distinfo
+++ b/devel/gnustep-make/distinfo
@@ -1,3 +1,3 @@
-MD5 (gnustep-make-2.0.6.tar.gz) = 58ebb672d10925a2004242eab1aec225
-SHA256 (gnustep-make-2.0.6.tar.gz) = f4731b95f9b16fc8a918d921be00a89b9e65a86734625176e98db224155f9e42
-SIZE (gnustep-make-2.0.6.tar.gz) = 477219
+MD5 (gnustep-make-2.0.7.tar.gz) = 1a4b3cf7cca6d1e90b84034012480630
+SHA256 (gnustep-make-2.0.7.tar.gz) = 054a9301e5f5b54be58e8f06872a66aad3333a1664530294875bad910b9b0472
+SIZE (gnustep-make-2.0.7.tar.gz) = 483812
diff --git a/devel/gnustep-make/pkg-plist b/devel/gnustep-make/pkg-plist
index 536997b2771e..14548b3b3464 100644
--- a/devel/gnustep-make/pkg-plist
+++ b/devel/gnustep-make/pkg-plist
@@ -96,8 +96,6 @@ System/Library/Makefiles/java-executable.template
System/Library/Makefiles/java-tool.make
System/Library/Makefiles/java.make
System/Library/Makefiles/jni.make
-System/Library/Makefiles/ld_lib_path.csh
-System/Library/Makefiles/ld_lib_path.sh
System/Library/Makefiles/library-combo.make
System/Library/Makefiles/library.make
System/Library/Makefiles/messages.make