aboutsummaryrefslogtreecommitdiff
path: root/devel/go-flags
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2014-07-14 10:29:59 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2014-07-14 10:29:59 +0000
commitc189f5fcc965d205eb6f3f4c0119fc1e0f9d53d1 (patch)
tree1a717867cd5440f1e60189a66be0336d96ce5e26 /devel/go-flags
parentc5f5a1d39d301d868ffdc6087f9caed2aec85cfd (diff)
Add go-flags, Go command line option parser.
Notes
Notes: svn path=/head/; revision=361764
Diffstat (limited to 'devel/go-flags')
-rw-r--r--devel/go-flags/Makefile25
-rw-r--r--devel/go-flags/distinfo2
-rw-r--r--devel/go-flags/pkg-descr7
-rw-r--r--devel/go-flags/pkg-plist61
4 files changed, 95 insertions, 0 deletions
diff --git a/devel/go-flags/Makefile b/devel/go-flags/Makefile
new file mode 100644
index 000000000000..2836bfa149ab
--- /dev/null
+++ b/devel/go-flags/Makefile
@@ -0,0 +1,25 @@
+# Created by: Akinori MUSHA aka knu <knu@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= flags
+PORTVERSION= 1.0.0.20140623
+CATEGORIES= devel
+MASTER_SITES= GH GHC
+PKGNAMEPREFIX= go-
+
+MAINTAINER= knu@FreeBSD.org
+COMMENT= Go command line option parser
+
+LICENSE= BSD3CLAUSE
+
+USE_GITHUB= yes
+GH_ACCOUNT= jessevdk
+GH_PROJECT= ${PKGNAMEPREFIX}${PORTNAME}
+GH_TAGNAME= ${GH_COMMIT}
+GH_COMMIT= 7047cf7
+
+GO_PKGNAME= github.com/${GH_ACCOUNT}/${GH_PROJECT}
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/lang/go/files/bsd.go.mk"
+.include <bsd.port.post.mk>
diff --git a/devel/go-flags/distinfo b/devel/go-flags/distinfo
new file mode 100644
index 000000000000..26bae13cf734
--- /dev/null
+++ b/devel/go-flags/distinfo
@@ -0,0 +1,2 @@
+SHA256 (flags-1.0.0.20140623.tar.gz) = 55500b644ecb786bbf9bb0856c1c88256934b76fee5785f9ab74e314fdaec74b
+SIZE (flags-1.0.0.20140623.tar.gz) = 41497
diff --git a/devel/go-flags/pkg-descr b/devel/go-flags/pkg-descr
new file mode 100644
index 000000000000..50ff4d133a13
--- /dev/null
+++ b/devel/go-flags/pkg-descr
@@ -0,0 +1,7 @@
+Package flags provides an extensive command line option parser. The
+flags package is similar in functionality to the go built-in flag
+package but provides more options and uses reflection to provide a
+convenient and succinct way of specifying command line options.
+
+Author: Jesse van den Kieboom
+WWW: http://godoc.org/github.com/jessevdk/go-flags
diff --git a/devel/go-flags/pkg-plist b/devel/go-flags/pkg-plist
new file mode 100644
index 000000000000..d249573aa87a
--- /dev/null
+++ b/devel/go-flags/pkg-plist
@@ -0,0 +1,61 @@
+%%GO_LIBDIR%%/github.com/jessevdk/go-flags.a
+@dirrmtry %%GO_LIBDIR%%/github.com/jessevdk
+@dirrmtry %%GO_LIBDIR%%/github.com
+@dirrmtry %%GO_LIBDIR%%
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/LICENSE
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/README.md
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/arg.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/arg_test.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/assert_test.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/check_crosscompile.sh
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/closest.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/command.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/command_private.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/command_test.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/completion.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/completion_test.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/convert.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/convert_test.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/error.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/example_test.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/examples/add.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/examples/bash-completion
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/examples/main.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/examples/rm.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/flags.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/group.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/group_private.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/group_test.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/help.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/help_test.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/ini.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/ini_private.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/ini_test.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/long_test.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/man.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/marshal_test.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/multitag.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/option.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/option_private.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/options_test.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/optstyle_other.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/optstyle_windows.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/parser.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/parser_private.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/parser_test.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/pointer_test.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/short_test.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/tag_test.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/termsize.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/termsize_linux.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/termsize_nosysioctl.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/termsize_other.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/termsize_unix.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/unknown_test.go
+@dirrm %%GO_SRCDIR%%/%%GO_PKGNAME%%/examples
+@dirrmtry %%GO_SRCDIR%%/%%GO_PKGNAME%%
+@dirrmtry %%GO_SRCDIR%%/github.com/jessevdk
+@dirrmtry %%GO_SRCDIR%%/github.com
+@dirrmtry %%GO_SRCDIR%%
+@dirrmtry share/go/pkg
+@dirrmtry share/go