aboutsummaryrefslogtreecommitdiff
path: root/devel/gobject-introspection
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2011-07-30 09:20:22 +0000
committerKoop Mast <kwm@FreeBSD.org>2011-07-30 09:20:22 +0000
commit0b743289fc32232ef4026a42f720186d8ae7c899 (patch)
tree1d1222f6f025fbba9f6a7bc42cf1bd0545242e55 /devel/gobject-introspection
parent42ee47bc6af00264547c217e6ce66acfc5aa7220 (diff)
downloadports-0b743289fc32232ef4026a42f720186d8ae7c899.tar.gz
ports-0b743289fc32232ef4026a42f720186d8ae7c899.zip
Notes
Diffstat (limited to 'devel/gobject-introspection')
-rw-r--r--devel/gobject-introspection/Makefile18
-rw-r--r--devel/gobject-introspection/distinfo4
-rw-r--r--devel/gobject-introspection/files/patch-Makefile.in (renamed from devel/gobject-introspection/files/patch-gir_Makefile.in)8
-rw-r--r--devel/gobject-introspection/files/patch-tests_Makefile.in18
4 files changed, 13 insertions, 35 deletions
diff --git a/devel/gobject-introspection/Makefile b/devel/gobject-introspection/Makefile
index 441343b1206d..6b55d3643296 100644
--- a/devel/gobject-introspection/Makefile
+++ b/devel/gobject-introspection/Makefile
@@ -3,20 +3,18 @@
# Whom: Alexander Logvinov <avl@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports/devel/gobject-introspection/Makefile,v 1.26 2010/10/07 10:28:00 kwm Exp $
+# $MCom: ports/devel/gobject-introspection/Makefile,v 1.39 2011/06/11 19:51:15 mezz Exp $
#
PORTNAME= gobject-introspection
-PORTVERSION= 0.9.12
-PORTREVISION= 1
+PORTVERSION= 0.10.8
CATEGORIES= devel
MASTER_SITES= GNOME
-DIST_SUBDIR= gnome2
+DIST_SUBDIR= gnome3
MAINTAINER= gnome@FreeBSD.org
COMMENT= Generate interface introspection data for GObject libraries
-BUILD_DEPENDS= flex:${PORTSDIR}/textproc/flex
LIB_DEPENDS= ffi.5:${PORTSDIR}/devel/libffi \
cairo.2:${PORTSDIR}/graphics/cairo
@@ -24,15 +22,14 @@ USE_BZIP2= yes
GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_GNOME= gnomehack glib20 ltverhack
-USE_PYTHON= 2.5+
-USE_BISON= both
+USE_PYTHON= yes
+USE_BISON= build
USE_GETTEXT= yes
USE_AUTOTOOLS= libtool
USE_LDCONFIG= yes
MAKE_JOBS_UNSAFE=yes
-
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib"
+CPPFLAGS= -I${LOCALBASE}/include
+CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib"
CONFIGURE_ARGS= --disable-tests
# Force it to put the .cache in ${WRKSRC} instead of ~/.cache. ports/143260
@@ -47,4 +44,3 @@ post-patch:
${WRKSRC}/giscanner/sourcescanner.py
.include <bsd.port.post.mk>
-
diff --git a/devel/gobject-introspection/distinfo b/devel/gobject-introspection/distinfo
index 469888a47583..c1537f1494e8 100644
--- a/devel/gobject-introspection/distinfo
+++ b/devel/gobject-introspection/distinfo
@@ -1,2 +1,2 @@
-SHA256 (gnome2/gobject-introspection-0.9.12.tar.bz2) = 9c0060d66d14a060057a1fc005be73675a1b8a00d4968ce8e78ff2d6b9f84e81
-SIZE (gnome2/gobject-introspection-0.9.12.tar.bz2) = 1050788
+SHA256 (gnome3/gobject-introspection-0.10.8.tar.bz2) = 5b1387ff37f03db880a2b1cbd6c6b6dfb923a29468d4d8367c458abf7704c61e
+SIZE (gnome3/gobject-introspection-0.10.8.tar.bz2) = 1024874
diff --git a/devel/gobject-introspection/files/patch-gir_Makefile.in b/devel/gobject-introspection/files/patch-Makefile.in
index f25f14725aef..fea86b08b627 100644
--- a/devel/gobject-introspection/files/patch-gir_Makefile.in
+++ b/devel/gobject-introspection/files/patch-Makefile.in
@@ -1,6 +1,6 @@
---- gir/Makefile.in.orig 2010-09-29 01:50:46.000000000 +0000
-+++ gir/Makefile.in 2010-09-29 01:52:35.000000000 +0000
-@@ -393,13 +393,13 @@
+--- Makefile.in.orig 2010-12-24 00:50:07.000000000 +0100
++++ Makefile.in 2010-12-24 00:51:39.000000000 +0100
+@@ -864,13 +864,13 @@
GLib_2_0_gir_PACKAGES = glib-2.0
GLib_2_0_gir_CFLAGS = \
-I$(GLIB_INCLUDEDIR) \
@@ -14,5 +14,5 @@
- $(GLIB_LIBDIR)/glib-2.0/include/glibconfig.h \
+ $(GLIB_INCLUDEDIR)/glibconfig.h \
$(GLIB_INCLUDEDIR)/glib/*.h \
- glib-2.0.c
+ gir/glib-2.0.c
diff --git a/devel/gobject-introspection/files/patch-tests_Makefile.in b/devel/gobject-introspection/files/patch-tests_Makefile.in
deleted file mode 100644
index a96e8a48d708..000000000000
--- a/devel/gobject-introspection/files/patch-tests_Makefile.in
+++ /dev/null
@@ -1,18 +0,0 @@
---- tests/Makefile.in.orig 2010-09-21 16:31:48.000000000 +0000
-+++ tests/Makefile.in 2010-09-21 16:33:10.000000000 +0000
-@@ -819,6 +819,7 @@
- $(AM_V_GEN) $(INTROSPECTION_SCANNER) $(INTROSPECTION_SCANNER_ARGS) --warn-all --warn-error --reparse-validate \
- --namespace=Everything --nsversion=1.0 \
- --add-include-path=$(top_builddir)/gir --include=Gio-2.0 \
-+ --libtool="$(LIBTOOL)" \
- --library=libeverything-1.0.la --output=$@ \
- everything.h everything.c
-
-@@ -826,6 +827,7 @@
- $(AM_V_GEN) $(INTROSPECTION_SCANNER) $(INTROSPECTION_SCANNER_ARGS) --warn-all --warn-error --reparse-validate \
- --namespace=GIMarshallingTests --symbol-prefix=gi_marshalling_tests --nsversion=1.0 \
- --add-include-path=$(top_builddir)/gir --include=Gio-2.0 \
-+ --libtool="$(LIBTOOL)" \
- --library=libgimarshallingtests-1.0.la --output=$@ \
- $(srcdir)/gimarshallingtests.h $(srcdir)/gimarshallingtests.c
-