aboutsummaryrefslogtreecommitdiff
path: root/devel/gobject-introspection
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2010-11-20 15:37:08 +0000
committerKoop Mast <kwm@FreeBSD.org>2010-11-20 15:37:08 +0000
commit3680f27ebff58ece429c4e032f9ad84fb1372114 (patch)
tree6c5ff4664c1a779ddad350ac887e5706dbfdd4eb /devel/gobject-introspection
parent02c6e6b485454dc3f5a27cbc887d9e4aaf376a36 (diff)
downloadports-3680f27ebff58ece429c4e032f9ad84fb1372114.tar.gz
ports-3680f27ebff58ece429c4e032f9ad84fb1372114.zip
Notes
Diffstat (limited to 'devel/gobject-introspection')
-rw-r--r--devel/gobject-introspection/Makefile10
-rw-r--r--devel/gobject-introspection/distinfo6
-rw-r--r--devel/gobject-introspection/files/patch-gir_Makefile.in10
-rw-r--r--devel/gobject-introspection/files/patch-girepository_ginfo.c46
-rw-r--r--devel/gobject-introspection/files/patch-giscanner_sourcescanner.py11
-rw-r--r--devel/gobject-introspection/files/patch-giscanner_xmlwriter.py11
-rw-r--r--devel/gobject-introspection/files/patch-tests_Makefile.in18
-rw-r--r--devel/gobject-introspection/pkg-plist120
8 files changed, 129 insertions, 103 deletions
diff --git a/devel/gobject-introspection/Makefile b/devel/gobject-introspection/Makefile
index 5d88f02a9c98..a093619c8b0e 100644
--- a/devel/gobject-introspection/Makefile
+++ b/devel/gobject-introspection/Makefile
@@ -3,11 +3,11 @@
# Whom: Alexander Logvinov <avl@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports/devel/gobject-introspection/Makefile,v 1.8 2010/04/22 15:11:23 kwm Exp $
+# $MCom: ports/devel/gobject-introspection/Makefile,v 1.26 2010/10/07 10:28:00 kwm Exp $
#
PORTNAME= gobject-introspection
-PORTVERSION= 0.6.14
+PORTVERSION= 0.9.12
CATEGORIES= devel
MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
@@ -22,7 +22,7 @@ LIB_DEPENDS= ffi.5:${PORTSDIR}/devel/libffi \
USE_BZIP2= yes
GNU_CONFIGURE= yes
USE_GMAKE= yes
-USE_GNOME= gnomehack glib20
+USE_GNOME= gnomehack glib20 ltverhack
USE_PYTHON= yes
USE_BISON= both
USE_GETTEXT= yes
@@ -32,6 +32,10 @@ MAKE_JOBS_UNSAFE=yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
+CONFIGURE_ARGS= --disable-tests
+
+# Force it to put the .cache in ${WRKSRC} instead of ~/.cache. ports/143260
+MAKE_ENV= HOME=${WRKDIR}
MAN1= g-ir-compiler.1 g-ir-generate.1 g-ir-scanner.1
diff --git a/devel/gobject-introspection/distinfo b/devel/gobject-introspection/distinfo
index cce161879a1b..57ea68928bcd 100644
--- a/devel/gobject-introspection/distinfo
+++ b/devel/gobject-introspection/distinfo
@@ -1,3 +1,3 @@
-MD5 (gnome2/gobject-introspection-0.6.14.tar.bz2) = 7ea9be9a347b5c408fd3c3907803de9b
-SHA256 (gnome2/gobject-introspection-0.6.14.tar.bz2) = c4713bcbcebb06861738a8f630ab05289666e631f42f7abbf2e836978db7eba6
-SIZE (gnome2/gobject-introspection-0.6.14.tar.bz2) = 763182
+MD5 (gnome2/gobject-introspection-0.9.12.tar.bz2) = 260ba5e77b5c0de0e7d8faf63ecbfee7
+SHA256 (gnome2/gobject-introspection-0.9.12.tar.bz2) = 9c0060d66d14a060057a1fc005be73675a1b8a00d4968ce8e78ff2d6b9f84e81
+SIZE (gnome2/gobject-introspection-0.9.12.tar.bz2) = 1050788
diff --git a/devel/gobject-introspection/files/patch-gir_Makefile.in b/devel/gobject-introspection/files/patch-gir_Makefile.in
index f56e9f69b115..f25f14725aef 100644
--- a/devel/gobject-introspection/files/patch-gir_Makefile.in
+++ b/devel/gobject-introspection/files/patch-gir_Makefile.in
@@ -1,15 +1,15 @@
---- gir/Makefile.in.orig 2010-06-06 15:58:29.000000000 -0400
-+++ gir/Makefile.in 2010-06-06 15:59:15.000000000 -0400
-@@ -436,14 +436,13 @@ GLib_2_0_gir_SCANNERFLAGS = --noclosure
+--- gir/Makefile.in.orig 2010-09-29 01:50:46.000000000 +0000
++++ gir/Makefile.in 2010-09-29 01:52:35.000000000 +0000
+@@ -393,13 +393,13 @@
GLib_2_0_gir_PACKAGES = glib-2.0
- GLib_2_0_gir_CFLAGS = $(CPPFLAGS) \
+ GLib_2_0_gir_CFLAGS = \
-I$(GLIB_INCLUDEDIR) \
- -I$(GLIB_LIBDIR)/glib-2.0/include \
++ -I$(GLIB_INCLUDEDIR)/.. \
-DGETTEXT_PACKAGE=Dummy \
-DGLIB_COMPILATION \
-D__G_I18N_LIB_H__
- GLib_2_0_gir_ASSERTIONS = GLib-2.0.xpath
GLib_2_0_gir_FILES = \
- $(GLIB_LIBDIR)/glib-2.0/include/glibconfig.h \
+ $(GLIB_INCLUDEDIR)/glibconfig.h \
diff --git a/devel/gobject-introspection/files/patch-girepository_ginfo.c b/devel/gobject-introspection/files/patch-girepository_ginfo.c
deleted file mode 100644
index 794bf443c8aa..000000000000
--- a/devel/gobject-introspection/files/patch-girepository_ginfo.c
+++ /dev/null
@@ -1,46 +0,0 @@
---- girepository/ginfo.c.orig 2010-06-01 15:48:36.000000000 -0400
-+++ girepository/ginfo.c 2010-06-06 16:02:36.000000000 -0400
-@@ -2110,6 +2110,9 @@ g_constant_info_get_type (GIConstantInfo
- return g_type_info_new ((GIBaseInfo*)info, rinfo->typelib, rinfo->offset + 8);
- }
-
-+#define DO_ALIGNED_COPY(dest_addr, src_addr, type) \
-+ memcpy((dest_addr), (src_addr), sizeof(type))
-+
- gint
- g_constant_info_get_value (GIConstantInfo *info,
- GArgument *value)
-@@ -2148,16 +2151,16 @@ g_constant_info_get_value (GIConstantInf
- value->v_uint32 = *(guint32*)&rinfo->typelib->data[blob->offset];
- break;
- case GI_TYPE_TAG_INT64:
-- value->v_int64 = *(gint64*)&rinfo->typelib->data[blob->offset];
-+ DO_ALIGNED_COPY(&value->v_int64, &rinfo->typelib->data[blob->offset], gint64);
- break;
- case GI_TYPE_TAG_UINT64:
-- value->v_uint64 = *(guint64*)&rinfo->typelib->data[blob->offset];
-+ DO_ALIGNED_COPY(&value->v_uint64, &rinfo->typelib->data[blob->offset], guint64);
- break;
- case GI_TYPE_TAG_FLOAT:
-- value->v_float = *(gfloat*)&rinfo->typelib->data[blob->offset];
-+ DO_ALIGNED_COPY(&value->v_float, &rinfo->typelib->data[blob->offset], gfloat);
- break;
- case GI_TYPE_TAG_DOUBLE:
-- value->v_double = *(gdouble*)&rinfo->typelib->data[blob->offset];
-+ DO_ALIGNED_COPY(&value->v_double, &rinfo->typelib->data[blob->offset], gdouble);
- break;
- case GI_TYPE_TAG_TIME_T:
- value->v_long = *(long*)&rinfo->typelib->data[blob->offset];
-@@ -2175,10 +2178,10 @@ g_constant_info_get_value (GIConstantInf
- value->v_uint = *(guint*)&rinfo->typelib->data[blob->offset];
- break;
- case GI_TYPE_TAG_LONG:
-- value->v_long = *(glong*)&rinfo->typelib->data[blob->offset];
-+ DO_ALIGNED_COPY(&value->v_long, &rinfo->typelib->data[blob->offset], glong);
- break;
- case GI_TYPE_TAG_ULONG:
-- value->v_ulong = *(gulong*)&rinfo->typelib->data[blob->offset];
-+ DO_ALIGNED_COPY(&value->v_ulong, &rinfo->typelib->data[blob->offset], gulong);
- break;
- }
- }
diff --git a/devel/gobject-introspection/files/patch-giscanner_sourcescanner.py b/devel/gobject-introspection/files/patch-giscanner_sourcescanner.py
deleted file mode 100644
index cb77d1c7ac7b..000000000000
--- a/devel/gobject-introspection/files/patch-giscanner_sourcescanner.py
+++ /dev/null
@@ -1,11 +0,0 @@
---- giscanner/sourcescanner.py.orig
-+++ giscanner/sourcescanner.py
-@@ -196,7 +196,7 @@ class SourceSymbol(object):
- class SourceScanner(object):
-
- def __init__(self):
-- with LibtoolImporter:
-+ with LibtoolImporter(None, None):
- from giscanner._giscanner import SourceScanner
- self._scanner = SourceScanner()
- self._filenames = []
diff --git a/devel/gobject-introspection/files/patch-giscanner_xmlwriter.py b/devel/gobject-introspection/files/patch-giscanner_xmlwriter.py
deleted file mode 100644
index 94b3ca939d52..000000000000
--- a/devel/gobject-introspection/files/patch-giscanner_xmlwriter.py
+++ /dev/null
@@ -1,11 +0,0 @@
---- giscanner/xmlwriter.py.orig
-+++ giscanner/xmlwriter.py
-@@ -67,7 +67,7 @@ def collect_attributes(tag_name, attributes, self_indent,
- return attr_value
-
-
--with LibtoolImporter:
-+with LibtoolImporter(None, None):
- from giscanner._giscanner import collect_attributes
-
-
diff --git a/devel/gobject-introspection/files/patch-tests_Makefile.in b/devel/gobject-introspection/files/patch-tests_Makefile.in
new file mode 100644
index 000000000000..a96e8a48d708
--- /dev/null
+++ b/devel/gobject-introspection/files/patch-tests_Makefile.in
@@ -0,0 +1,18 @@
+--- tests/Makefile.in.orig 2010-09-21 16:31:48.000000000 +0000
++++ tests/Makefile.in 2010-09-21 16:33:10.000000000 +0000
+@@ -819,6 +819,7 @@
+ $(AM_V_GEN) $(INTROSPECTION_SCANNER) $(INTROSPECTION_SCANNER_ARGS) --warn-all --warn-error --reparse-validate \
+ --namespace=Everything --nsversion=1.0 \
+ --add-include-path=$(top_builddir)/gir --include=Gio-2.0 \
++ --libtool="$(LIBTOOL)" \
+ --library=libeverything-1.0.la --output=$@ \
+ everything.h everything.c
+
+@@ -826,6 +827,7 @@
+ $(AM_V_GEN) $(INTROSPECTION_SCANNER) $(INTROSPECTION_SCANNER_ARGS) --warn-all --warn-error --reparse-validate \
+ --namespace=GIMarshallingTests --symbol-prefix=gi_marshalling_tests --nsversion=1.0 \
+ --add-include-path=$(top_builddir)/gir --include=Gio-2.0 \
++ --libtool="$(LIBTOOL)" \
+ --library=libgimarshallingtests-1.0.la --output=$@ \
+ $(srcdir)/gimarshallingtests.h $(srcdir)/gimarshallingtests.c
+
diff --git a/devel/gobject-introspection/pkg-plist b/devel/gobject-introspection/pkg-plist
index 7588b683930d..c39c55aa80c4 100644
--- a/devel/gobject-introspection/pkg-plist
+++ b/devel/gobject-introspection/pkg-plist
@@ -1,14 +1,30 @@
+bin/g-ir-annotation-tool
bin/g-ir-compiler
bin/g-ir-generate
bin/g-ir-scanner
+include/gobject-introspection-1.0/giarginfo.h
include/gobject-introspection-1.0/gibaseinfo.h
+include/gobject-introspection-1.0/gicallableinfo.h
+include/gobject-introspection-1.0/giconstantinfo.h
+include/gobject-introspection-1.0/gienuminfo.h
+include/gobject-introspection-1.0/gierrordomaininfo.h
+include/gobject-introspection-1.0/gifieldinfo.h
include/gobject-introspection-1.0/gifunctioninfo.h
+include/gobject-introspection-1.0/giinterfaceinfo.h
+include/gobject-introspection-1.0/giobjectinfo.h
+include/gobject-introspection-1.0/gipropertyinfo.h
+include/gobject-introspection-1.0/giregisteredtypeinfo.h
include/gobject-introspection-1.0/girepository.h
include/gobject-introspection-1.0/girffi.h
+include/gobject-introspection-1.0/gisignalinfo.h
+include/gobject-introspection-1.0/gistructinfo.h
+include/gobject-introspection-1.0/gitypeinfo.h
include/gobject-introspection-1.0/gitypelib.h
include/gobject-introspection-1.0/gitypes.h
-lib/girepository-1.0/Everything-1.0.typelib
-lib/girepository-1.0/GIMarshallingTests-1.0.typelib
+include/gobject-introspection-1.0/giunioninfo.h
+include/gobject-introspection-1.0/givfuncinfo.h
+lib/girepository-1.0/DBus-1.0.typelib
+lib/girepository-1.0/DBusGLib-1.0.typelib
lib/girepository-1.0/GIRepository-2.0.typelib
lib/girepository-1.0/GL-1.0.typelib
lib/girepository-1.0/GLib-2.0.typelib
@@ -29,6 +45,9 @@ lib/gobject-introspection/giscanner/__init__.pyo
lib/gobject-introspection/giscanner/_giscanner.a
lib/gobject-introspection/giscanner/_giscanner.la
lib/gobject-introspection/giscanner/_giscanner.so
+lib/gobject-introspection/giscanner/annotationmain.py
+lib/gobject-introspection/giscanner/annotationmain.pyc
+lib/gobject-introspection/giscanner/annotationmain.pyo
lib/gobject-introspection/giscanner/annotationparser.py
lib/gobject-introspection/giscanner/annotationparser.pyc
lib/gobject-introspection/giscanner/annotationparser.pyo
@@ -38,30 +57,36 @@ lib/gobject-introspection/giscanner/ast.pyo
lib/gobject-introspection/giscanner/cachestore.py
lib/gobject-introspection/giscanner/cachestore.pyc
lib/gobject-introspection/giscanner/cachestore.pyo
+lib/gobject-introspection/giscanner/codegen.py
+lib/gobject-introspection/giscanner/codegen.pyc
+lib/gobject-introspection/giscanner/codegen.pyo
lib/gobject-introspection/giscanner/config.py
lib/gobject-introspection/giscanner/config.pyc
lib/gobject-introspection/giscanner/config.pyo
lib/gobject-introspection/giscanner/dumper.py
lib/gobject-introspection/giscanner/dumper.pyc
lib/gobject-introspection/giscanner/dumper.pyo
+lib/gobject-introspection/giscanner/gdumpparser.py
+lib/gobject-introspection/giscanner/gdumpparser.pyc
+lib/gobject-introspection/giscanner/gdumpparser.pyo
lib/gobject-introspection/giscanner/girparser.py
lib/gobject-introspection/giscanner/girparser.pyc
lib/gobject-introspection/giscanner/girparser.pyo
lib/gobject-introspection/giscanner/girwriter.py
lib/gobject-introspection/giscanner/girwriter.pyc
lib/gobject-introspection/giscanner/girwriter.pyo
-lib/gobject-introspection/giscanner/glibast.py
-lib/gobject-introspection/giscanner/glibast.pyc
-lib/gobject-introspection/giscanner/glibast.pyo
-lib/gobject-introspection/giscanner/glibtransformer.py
-lib/gobject-introspection/giscanner/glibtransformer.pyc
-lib/gobject-introspection/giscanner/glibtransformer.pyo
+lib/gobject-introspection/giscanner/introspectablepass.py
+lib/gobject-introspection/giscanner/introspectablepass.pyc
+lib/gobject-introspection/giscanner/introspectablepass.pyo
lib/gobject-introspection/giscanner/libtoolimporter.py
lib/gobject-introspection/giscanner/libtoolimporter.pyc
lib/gobject-introspection/giscanner/libtoolimporter.pyo
-lib/gobject-introspection/giscanner/minixpath.py
-lib/gobject-introspection/giscanner/minixpath.pyc
-lib/gobject-introspection/giscanner/minixpath.pyo
+lib/gobject-introspection/giscanner/maintransformer.py
+lib/gobject-introspection/giscanner/maintransformer.pyc
+lib/gobject-introspection/giscanner/maintransformer.pyo
+lib/gobject-introspection/giscanner/message.py
+lib/gobject-introspection/giscanner/message.pyc
+lib/gobject-introspection/giscanner/message.pyo
lib/gobject-introspection/giscanner/odict.py
lib/gobject-introspection/giscanner/odict.pyc
lib/gobject-introspection/giscanner/odict.pyo
@@ -74,6 +99,9 @@ lib/gobject-introspection/giscanner/shlibs.pyo
lib/gobject-introspection/giscanner/sourcescanner.py
lib/gobject-introspection/giscanner/sourcescanner.pyc
lib/gobject-introspection/giscanner/sourcescanner.pyo
+lib/gobject-introspection/giscanner/testcodegen.py
+lib/gobject-introspection/giscanner/testcodegen.pyc
+lib/gobject-introspection/giscanner/testcodegen.pyo
lib/gobject-introspection/giscanner/transformer.py
lib/gobject-introspection/giscanner/transformer.pyc
lib/gobject-introspection/giscanner/transformer.pyo
@@ -86,20 +114,12 @@ lib/gobject-introspection/giscanner/xmlwriter.pyo
lib/libgirepository-1.0.a
lib/libgirepository-1.0.la
lib/libgirepository-1.0.so
-lib/libgirepository-1.0.so.0
-lib/libgirepository-everything-1.0.a
-lib/libgirepository-everything-1.0.la
-lib/libgirepository-everything-1.0.so
-lib/libgirepository-everything-1.0.so.1
-lib/libgirepository-gimarshallingtests-1.0.a
-lib/libgirepository-gimarshallingtests-1.0.la
-lib/libgirepository-gimarshallingtests-1.0.so
-lib/libgirepository-gimarshallingtests-1.0.so.1
+lib/libgirepository-1.0.so.1
libdata/pkgconfig/gobject-introspection-1.0.pc
libdata/pkgconfig/gobject-introspection-no-export-1.0.pc
share/aclocal/introspection.m4
-share/gir-1.0/Everything-1.0.gir
-share/gir-1.0/GIMarshallingTests-1.0.gir
+share/gir-1.0/DBus-1.0.gir
+share/gir-1.0/DBusGLib-1.0.gir
share/gir-1.0/GIRepository-2.0.gir
share/gir-1.0/GL-1.0.gir
share/gir-1.0/GLib-2.0.gir
@@ -115,9 +135,61 @@ share/gir-1.0/xft-2.0.gir
share/gir-1.0/xlib-2.0.gir
share/gir-1.0/xrandr-1.3.gir
share/gobject-introspection-1.0/Makefile.introspection
+share/gobject-introspection-1.0/gdump.c
+share/gobject-introspection-1.0/tests/everything.c
+share/gobject-introspection-1.0/tests/everything.h
+share/gobject-introspection-1.0/tests/gimarshallingtests.c
+share/gobject-introspection-1.0/tests/gimarshallingtests.h
+share/gobject-introspection-1.0/tests/regress.c
+share/gobject-introspection-1.0/tests/regress.h
+share/gtk-doc/html/gi/annotation-glossary.html
+share/gtk-doc/html/gi/gi-GIArgInfo.html
+share/gtk-doc/html/gi/gi-GIBaseInfo.html
+share/gtk-doc/html/gi/gi-GICallableInfo.html
+share/gtk-doc/html/gi/gi-GIConstantInfo.html
+share/gtk-doc/html/gi/gi-GIEnumInfo.html
+share/gtk-doc/html/gi/gi-GIErrorDomainInfo.html
+share/gtk-doc/html/gi/gi-GIFieldInfo.html
+share/gtk-doc/html/gi/gi-GIFunctionInfo.html
+share/gtk-doc/html/gi/gi-GIInterfaceInfo.html
+share/gtk-doc/html/gi/gi-GIObjectInfo.html
+share/gtk-doc/html/gi/gi-GIPropertyInfo.html
+share/gtk-doc/html/gi/gi-GIRegisteredTypeInfo.html
+share/gtk-doc/html/gi/gi-GISignalInfo.html
+share/gtk-doc/html/gi/gi-GIStructInfo.html
+share/gtk-doc/html/gi/gi-GITypeInfo.html
+share/gtk-doc/html/gi/gi-GIUnionInfo.html
+share/gtk-doc/html/gi/gi-GIVFuncInfo.html
+share/gtk-doc/html/gi/gi-ffi.html
+share/gtk-doc/html/gi/gi-gir-reference.html
+share/gtk-doc/html/gi/gi-gir.html
+share/gtk-doc/html/gi/gi-girepository.html
+share/gtk-doc/html/gi/gi-girffi.html
+share/gtk-doc/html/gi/gi-gtypelib.html
+share/gtk-doc/html/gi/gi-libgirepository.html
+share/gtk-doc/html/gi/gi-overview.html
+share/gtk-doc/html/gi/gi-repository-structs.html
+share/gtk-doc/html/gi/gi-struct-hierarchy.html
+share/gtk-doc/html/gi/gi-typelib.html
+share/gtk-doc/html/gi/gi.devhelp
+share/gtk-doc/html/gi/gi.devhelp2
+share/gtk-doc/html/gi/girepository.html
+share/gtk-doc/html/gi/glib.html
+share/gtk-doc/html/gi/home.png
+share/gtk-doc/html/gi/index.html
+share/gtk-doc/html/gi/index.sgml
+share/gtk-doc/html/gi/left.png
+share/gtk-doc/html/gi/overview.png
+share/gtk-doc/html/gi/right.png
+share/gtk-doc/html/gi/style.css
+share/gtk-doc/html/gi/up.png
+@dirrm share/gtk-doc/html/gi
+@dirrmtry share/gtk-doc/html
+@dirrmtry share/gtk-doc
+@dirrm share/gobject-introspection-1.0/tests
@dirrm share/gobject-introspection-1.0
-@dirrm include/gobject-introspection-1.0
+@dirrmtry share/gir-1.0
@dirrmtry lib/girepository-1.0
@dirrm lib/gobject-introspection/giscanner
@dirrm lib/gobject-introspection
-@dirrmtry share/gir-1.0
+@dirrm include/gobject-introspection-1.0