aboutsummaryrefslogtreecommitdiff
path: root/devel/goffice010/Makefile
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2013-05-05 23:39:59 +0000
committerKoop Mast <kwm@FreeBSD.org>2013-05-05 23:39:59 +0000
commit014d1f7db7b079d825e31307fcff5d9364db82e0 (patch)
treeafbf26294e69af21efa9f4c5eea746e678c5d284 /devel/goffice010/Makefile
parent8be07ccc6635926bd5bb0bf333b75a7bb046a9bb (diff)
Notes
Diffstat (limited to 'devel/goffice010/Makefile')
-rw-r--r--devel/goffice010/Makefile39
1 files changed, 39 insertions, 0 deletions
diff --git a/devel/goffice010/Makefile b/devel/goffice010/Makefile
new file mode 100644
index 000000000000..c60194e5aac8
--- /dev/null
+++ b/devel/goffice010/Makefile
@@ -0,0 +1,39 @@
+# Created by: Joe Marcus Clarke <marcus@FreeBSD.org>
+# $FreeBSD$
+# $MCom: ports/trunk/devel/goffice/Makefile 18385 2013-04-22 12:56:25Z kwm $
+
+PORTNAME= goffice
+PORTVERSION= 0.10.2
+CATEGORIES= devel gnome
+MASTER_SITES= GNOME
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= GLib/GTK+ set of document centric objects and utilities
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+LATEST_LINK= goffice010
+USE_XZ= yes
+USE_GMAKE= yes
+USE_GNOME= gnomeprefix intlhack gtk30 libgsf ltverhack librsvg2
+USES= gettext pathfix pkgconfig
+USE_AUTOTOOLS= libtool
+USE_LDCONFIG= yes
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+CONFIGURE_ARGS= --with-lasem=no --with-config-backend=gsettings
+
+PLIST_SUB= VERSION=${PORTVERSION} SHORT_VER=${SHORT_VER}
+SHORT_VER=0.10
+
+MAKE_JOBS_SAFE= yes
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|-DGTK_DISABLE_DEPRECATED||g'\
+ ${WRKSRC}/configure
+
+post-install:
+ @${MKDIR} ${PREFIX}/lib/goffice/${SHORT_VER}/plugins
+
+.include <bsd.port.mk>