aboutsummaryrefslogtreecommitdiff
path: root/devel/goffice
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2013-03-13 20:54:33 +0000
committerKoop Mast <kwm@FreeBSD.org>2013-03-13 20:54:33 +0000
commitc55be4c443bf811590b9393822764ef8e6af613a (patch)
tree2d1574328c8849f796a3cdd5644e381d58df983b /devel/goffice
parente4ab10abf17bf787a73fe1ade896b01bd1be0a21 (diff)
Fix unresolved symbol pcre_info from pcre. This symbol was deprecated for a
while now and in a recent update removed. The check to enable replacement code from using glib functions doesn't work quite correctly. So enable it manualy. Tested by: madpilot@
Notes
Notes: svn path=/head/; revision=314112
Diffstat (limited to 'devel/goffice')
-rw-r--r--devel/goffice/Makefile2
-rw-r--r--devel/goffice/files/patch-goffice_utils_regutf8.c48
2 files changed, 49 insertions, 1 deletions
diff --git a/devel/goffice/Makefile b/devel/goffice/Makefile
index 62215243dd8a..be322a4dd3a4 100644
--- a/devel/goffice/Makefile
+++ b/devel/goffice/Makefile
@@ -10,7 +10,7 @@
PORTNAME= goffice
PORTVERSION= 0.8.17
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= devel gnome
MASTER_SITES= GNOME
diff --git a/devel/goffice/files/patch-goffice_utils_regutf8.c b/devel/goffice/files/patch-goffice_utils_regutf8.c
new file mode 100644
index 000000000000..4a0633af7496
--- /dev/null
+++ b/devel/goffice/files/patch-goffice_utils_regutf8.c
@@ -0,0 +1,48 @@
+--- goffice/utils/regutf8.c.orig 2009-09-05 23:52:09.000000000 +0000
++++ goffice/utils/regutf8.c 2013-03-13 17:22:39.000000000 +0000
+@@ -21,11 +21,7 @@ void
+ go_regfree (GORegexp *gor)
+ {
+ if (gor->ppcre) {
+-#ifdef HAVE_G_REGEX_ERROR_STRAY_BACKSLASH
+ g_regex_unref (gor->ppcre);
+-#else
+- pcre_free (gor->ppcre);
+-#endif
+ gor->ppcre = NULL;
+ }
+ }
+@@ -70,7 +66,6 @@ go_regerror (int errcode, const GORegexp
+ int
+ go_regcomp (GORegexp *gor, const char *pat, int cflags)
+ {
+-#ifdef HAVE_G_REGEX_ERROR_STRAY_BACKSLASH
+ GError *error = NULL;
+ GRegex *r;
+ int coptions =
+@@ -119,7 +114,7 @@ go_regcomp (GORegexp *gor, const char *p
+ gor->nosub = (cflags & GO_REG_NOSUB) != 0;
+ return 0;
+ }
+-#else
++#if 0
+ const char *errorptr;
+ int errorofs, errorcode;
+ pcre *r;
+@@ -167,7 +162,6 @@ int
+ go_regexec (const GORegexp *gor, const char *txt,
+ size_t nmatch, GORegmatch *pmatch, int eflags)
+ {
+-#ifdef HAVE_G_REGEX_ERROR_STRAY_BACKSLASH
+ int eoptions =
+ ((eflags & GO_REG_NOTBOL) ? G_REGEX_MATCH_NOTBOL : 0) |
+ ((eflags & GO_REG_NOTEOL) ? G_REGEX_MATCH_NOTEOL : 0);
+@@ -196,7 +190,7 @@ go_regexec (const GORegexp *gor, const c
+ g_match_info_free (match_info);
+
+ return matched ? GO_REG_NOERROR : GO_REG_NOMATCH;
+-#else
++#if 0
+ size_t txtlen = strlen (txt);
+ int eoptions =
+ ((eflags & GO_REG_NOTBOL) ? PCRE_NOTBOL : 0) |