aboutsummaryrefslogtreecommitdiff
path: root/devel/googlemock
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2008-12-12 05:17:52 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2008-12-12 05:17:52 +0000
commit86c5e741ada247ab63a87c84cce0caa442cc26d5 (patch)
tree807d0597c9b5442b7c8cfc53cb4cf3e954a3c907 /devel/googlemock
parent858427a4fa60166688a7f8b770f3ada13656428c (diff)
downloadports-86c5e741ada247ab63a87c84cce0caa442cc26d5.tar.gz
ports-86c5e741ada247ab63a87c84cce0caa442cc26d5.zip
Notes
Diffstat (limited to 'devel/googlemock')
-rw-r--r--devel/googlemock/Makefile26
-rw-r--r--devel/googlemock/distinfo3
-rw-r--r--devel/googlemock/pkg-descr11
-rw-r--r--devel/googlemock/pkg-plist25
4 files changed, 65 insertions, 0 deletions
diff --git a/devel/googlemock/Makefile b/devel/googlemock/Makefile
new file mode 100644
index 000000000000..fae5fcb0a65c
--- /dev/null
+++ b/devel/googlemock/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: googlemock
+# Date created: Dec 12, 2008
+# Whom: Cheng-Lung Sung <clsung@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= googlemock
+PORTVERSION= 1.0.0
+CATEGORIES= devel
+MASTER_SITES= GOOGLE_CODE
+DISTNAME= gmock-${PORTVERSION}
+
+MAINTAINER= clsung@FreeBSD.org
+COMMENT= A library for writing and using C++ mock classes
+
+BUILD_DEPENDS= googletest>=1.2.1:${PORTSDIR}/devel/googletest
+
+GNU_CONFIGURE= yes
+USE_LDCONFIG= yes
+USE_GCC= 4.2+
+
+#regression-mock:
+# cd ${WRKSRC}; ${MAKE} check
+
+.include <bsd.port.mk>
diff --git a/devel/googlemock/distinfo b/devel/googlemock/distinfo
new file mode 100644
index 000000000000..0730ca7e70bd
--- /dev/null
+++ b/devel/googlemock/distinfo
@@ -0,0 +1,3 @@
+MD5 (gmock-1.0.0.tar.gz) = ea2a6c6ffc06e74d411418a9d7eb2b8c
+SHA256 (gmock-1.0.0.tar.gz) = e101db337b138321ffb758e1953d51df6f2acd527307be2e084177e25adaf092
+SIZE (gmock-1.0.0.tar.gz) = 1080859
diff --git a/devel/googlemock/pkg-descr b/devel/googlemock/pkg-descr
new file mode 100644
index 000000000000..6bdf4b75a53f
--- /dev/null
+++ b/devel/googlemock/pkg-descr
@@ -0,0 +1,11 @@
+Inspired by jMock, EasyMock, and Hamcrest, and designed with C++'s specifics
+in mind, Google C++ Mocking Framework (or Google Mock for short) is a library
+for writing and using C++ mock classes. Google Mock:
+
+ * lets you create mock classes trivially using simple macros,
+ * supports a rich set of matchers and actions,
+ * handles unordered, partially ordered, or completely ordered expectations,
+ * is extensible by users, and
+ * works on Linux, Windows, and Mac OS X.
+
+WWW: http://code.google.com/p/googlemock/
diff --git a/devel/googlemock/pkg-plist b/devel/googlemock/pkg-plist
new file mode 100644
index 000000000000..0d5a5829c30b
--- /dev/null
+++ b/devel/googlemock/pkg-plist
@@ -0,0 +1,25 @@
+bin/gmock-config
+bin/gmock_doctor.py
+include/gmock/gmock.h
+include/gmock/gmock-actions.h
+include/gmock/gmock-cardinalities.h
+include/gmock/gmock-generated-actions.h
+include/gmock/gmock-generated-function-mockers.h
+include/gmock/gmock-generated-matchers.h
+include/gmock/gmock-generated-nice-strict.h
+include/gmock/gmock-matchers.h
+include/gmock/gmock-printers.h
+include/gmock/gmock-spec-builders.h
+include/gmock/internal/gmock-generated-internal-utils.h
+include/gmock/internal/gmock-internal-utils.h
+include/gmock/internal/gmock-port.h
+lib/libgmock.so.0
+lib/libgmock.so
+lib/libgmock.la
+lib/libgmock.a
+lib/libgmock_main.so.0
+lib/libgmock_main.so
+lib/libgmock_main.la
+lib/libgmock_main.a
+@dirrmtry include/gmock/internal
+@dirrmtry include/gmock