aboutsummaryrefslogtreecommitdiff
path: root/devel/goprotobuf
diff options
context:
space:
mode:
authorJulien Laffaye <jlaffaye@FreeBSD.org>2012-05-14 22:02:57 +0000
committerJulien Laffaye <jlaffaye@FreeBSD.org>2012-05-14 22:02:57 +0000
commite88fbe13839e6f342d5f620fe61cf1d30e0eb9d8 (patch)
treee79f3146b1fe0ed3dcbd5329075cd5ed94323f01 /devel/goprotobuf
parent9d779315cfe1c9a2cd128db308bad04b412c5fad (diff)
Notes
Diffstat (limited to 'devel/goprotobuf')
-rw-r--r--devel/goprotobuf/Makefile20
-rw-r--r--devel/goprotobuf/distinfo4
-rw-r--r--devel/goprotobuf/pkg-plist43
3 files changed, 46 insertions, 21 deletions
diff --git a/devel/goprotobuf/Makefile b/devel/goprotobuf/Makefile
index c1ab2b9f7508..805d6de21ce6 100644
--- a/devel/goprotobuf/Makefile
+++ b/devel/goprotobuf/Makefile
@@ -6,11 +6,9 @@
#
PORTNAME= goprotobuf
-PORTVERSION= 20120122
-PORTREVISION= 1
+PORTVERSION= 20120409
CATEGORIES= devel
-MASTER_SITES= http://m.ahze.net/packages/ \
- LOCAL/ahze
+MASTER_SITES= LOCAL/jlaffaye
MAINTAINER= ahze@FreeBSD.org
COMMENT= Go support for Google's protocol buffers
@@ -20,12 +18,16 @@ LICENSE= BSD
RUN_DEPENDS= protoc:${PORTSDIR}/devel/protobuf
USE_GO= yes
-NO_BUILD= yes
-MAKE_ENV= GOBIN=${PREFIX}/bin
+GO_PKGNAME= code.google.com/p/goprotobuf
+GO_TARGET= ${GO_PKGNAME}/proto ${GO_PKGNAME}/protoc-gen-go
-post-install:
- ${INSTALL} -d ${GOROOT}/src/pkg/goprotobuf.googlecode.com/hg/
- ${INSTALL} -m 644 ${WRKSRC}/Make.protobuf ${GOROOT}/src/pkg/goprotobuf.googlecode.com/hg/
+do-install:
+ ${INSTALL_PROGRAM} ${GO_WRKDIR_BIN}/protoc-gen-go ${LOCALBASE}/bin
+ ${MKDIR} ${GO_LOCAL_LIBDIR}/${GO_PKGNAME}
+ (cd ${GO_WRKDIR_PKG}/${GO_PKGNAME}/ && ${COPYTREE_SHARE} \* ${GO_LOCAL_LIBDIR}/${GO_PKGNAME})
+ ${MKDIR} ${GO_LOCAL_SRCDIR}/${GO_PKGNAME}/proto
+ (cd ${GO_WRKSRC}/proto && ${COPYTREE_SHARE} \* \
+ ${GO_LOCAL_SRCDIR}/${GO_PKGNAME}/proto)
.include <bsd.port.pre.mk>
.include "${PORTSDIR}/lang/go/files/bsd.go.mk"
diff --git a/devel/goprotobuf/distinfo b/devel/goprotobuf/distinfo
index f44bd0a59cee..0e0784f98e13 100644
--- a/devel/goprotobuf/distinfo
+++ b/devel/goprotobuf/distinfo
@@ -1,2 +1,2 @@
-SHA256 (goprotobuf-20120122.tar.gz) = e7f1e19584309ff9c445d2858910140d12f6b29b63e2ddd8655bffdf7eb991d2
-SIZE (goprotobuf-20120122.tar.gz) = 76105
+SHA256 (goprotobuf-20120409.tar.gz) = bc91396932f09b991e17d7b5dbff32e53264fa1c7aa382682f8d1b214288445c
+SIZE (goprotobuf-20120409.tar.gz) = 79354
diff --git a/devel/goprotobuf/pkg-plist b/devel/goprotobuf/pkg-plist
index 3c2ef665411f..b5a6780bb98c 100644
--- a/devel/goprotobuf/pkg-plist
+++ b/devel/goprotobuf/pkg-plist
@@ -1,11 +1,34 @@
bin/protoc-gen-go
-%%GO_LIBDIR%%/goprotobuf.googlecode.com/hg/compiler/descriptor.a
-%%GO_LIBDIR%%/goprotobuf.googlecode.com/hg/compiler/generator.a
-%%GO_LIBDIR%%/goprotobuf.googlecode.com/hg/compiler/plugin.a
-%%GO_LIBDIR%%/goprotobuf.googlecode.com/hg/proto.a
-go/src/pkg/goprotobuf.googlecode.com/hg/Make.protobuf
-@dirrm %%GO_LIBDIR%%/goprotobuf.googlecode.com/hg/compiler
-@dirrm %%GO_LIBDIR%%/goprotobuf.googlecode.com/hg
-@dirrm %%GO_LIBDIR%%/goprotobuf.googlecode.com
-@dirrm go/src/pkg/goprotobuf.googlecode.com/hg
-@dirrm go/src/pkg/goprotobuf.googlecode.com
+%%GO_LIBDIR%%/%%GO_PKGNAME%%/proto.a
+%%GO_LIBDIR%%/%%GO_PKGNAME%%/protoc-gen-go/descriptor.a
+%%GO_LIBDIR%%/%%GO_PKGNAME%%/protoc-gen-go/generator.a
+%%GO_LIBDIR%%/%%GO_PKGNAME%%/protoc-gen-go/plugin.a
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/proto/Makefile
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/proto/all_test.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/proto/clone.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/proto/clone_test.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/proto/decode.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/proto/encode.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/proto/equal.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/proto/equal_test.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/proto/extensions.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/proto/lib.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/proto/message_set.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/proto/properties.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/proto/testdata/Makefile
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/proto/testdata/golden_test.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/proto/testdata/test.pb.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/proto/testdata/test.proto
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/proto/text.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/proto/text_parser.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/proto/text_parser_test.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/proto/text_test.go
+@dirrm %%GO_LIBDIR%%/%%GO_PKGNAME%%/protoc-gen-go
+@dirrm %%GO_LIBDIR%%/%%GO_PKGNAME%%
+@dirrmtry %%GO_LIBDIR%%/code.google.com/p
+@dirrmtry %%GO_LIBDIR%%/code.google.com
+@dirrm %%GO_SRCDIR%%/%%GO_PKGNAME%%/proto/testdata
+@dirrm %%GO_SRCDIR%%/%%GO_PKGNAME%%/proto
+@dirrm %%GO_SRCDIR%%/%%GO_PKGNAME%%
+@dirrmtry %%GO_SRCDIR%%/code.google.com/p
+@dirrmtry %%GO_SRCDIR%%/code.google.com