aboutsummaryrefslogtreecommitdiff
path: root/devel/gorm
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2008-12-24 07:49:52 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2008-12-24 07:49:52 +0000
commitba89e9ecd8969ceec0018ccefd12f741ae106ba9 (patch)
tree6ecd19b60a139dcd1185c5cc77791893090bed67 /devel/gorm
parentf2c413e3db6dcdcb6b81e84b10fc4e1d152277bd (diff)
downloadports-ba89e9ecd8969ceec0018ccefd12f741ae106ba9.tar.gz
ports-ba89e9ecd8969ceec0018ccefd12f741ae106ba9.zip
Notes
Diffstat (limited to 'devel/gorm')
-rw-r--r--devel/gorm/Makefile25
-rw-r--r--devel/gorm/files/patch-GormNSWindow.m12
-rw-r--r--devel/gorm/files/patch-GormNibWrapperLoader.h12
-rw-r--r--devel/gorm/files/patch-GormPrivate.h13
4 files changed, 62 insertions, 0 deletions
diff --git a/devel/gorm/Makefile b/devel/gorm/Makefile
index 9c9d32052ab8..e388a442d0ec 100644
--- a/devel/gorm/Makefile
+++ b/devel/gorm/Makefile
@@ -24,4 +24,29 @@ USE_GNUSTEP_LDCONFIG= ${GNUSTEP_SYSTEM_LIBRARIES}
DEFAULT_LIBVERSION= 1.1.0
+FIXME= GormCore/GormCustomView.m \
+ GormCore/GormDocument.m \
+ GormCore/GormFilePrefsManager.m \
+ GormCore/GormHelpInspector.m \
+ GormCore/GormPrivate.m \
+ Palettes/1Windows/WindowsPalette.m \
+ Plugins/Nib/GormNibWrapperBuilder.m
+
+FIXME2= Palettes/1Windows/GormNSPanel.m \
+ Palettes/1Windows/GormWindowSizeInspector.m \
+ Plugins/Gorm/GormGormWrapperBuilder.m \
+ Plugins/Nib/GormNibWrapperLoader.h \
+
+post-patch:
+.for i in ${FIXME}
+ ${REINPLACE_CMD} -e 's|GSNibTemplates|GSNibLoading|' \
+ -e 's|GSNibCompatibility|GSNibLoading|' \
+ ${WRKSRC}/${i}
+.endfor
+.for i in ${FIXME2}
+ ${REINPLACE_CMD} -e 's|GSNibTemplates|GSGormLoading|' \
+ -e 's|GSNibCompatibility|GSGormLoading|' \
+ ${WRKSRC}/${i}
+.endfor
+
.include <bsd.port.mk>
diff --git a/devel/gorm/files/patch-GormNSWindow.m b/devel/gorm/files/patch-GormNSWindow.m
new file mode 100644
index 000000000000..459ee8cc33c5
--- /dev/null
+++ b/devel/gorm/files/patch-GormNSWindow.m
@@ -0,0 +1,12 @@
+--- Palettes/1Windows/GormNSWindow.m.orig 2008-05-03 19:40:55.000000000 +0200
++++ Palettes/1Windows/GormNSWindow.m 2008-12-23 11:55:25.000000000 +0100
+@@ -23,7 +23,8 @@
+ */
+
+ #include <AppKit/AppKit.h>
+-#include <GNUstepGUI/GSNibTemplates.h>
++#include <GNUstepGUI/GSNibLoading.h>
++#include <GNUstepGUI/GSGormLoading.h>
+ #include <InterfaceBuilder/InterfaceBuilder.h>
+ #include "GormNSWindow.h"
+
diff --git a/devel/gorm/files/patch-GormNibWrapperLoader.h b/devel/gorm/files/patch-GormNibWrapperLoader.h
new file mode 100644
index 000000000000..15f8970224c9
--- /dev/null
+++ b/devel/gorm/files/patch-GormNibWrapperLoader.h
@@ -0,0 +1,12 @@
+--- Plugins/Nib/GormNibWrapperLoader.h.orig 2008-06-25 00:09:55.000000000 +0200
++++ Plugins/Nib/GormNibWrapperLoader.h 2008-12-23 16:40:32.000000000 +0100
+@@ -26,7 +26,8 @@
+ #define GORM_NIBWRAPPERLOADER
+
+ #include <GormCore/GormWrapperLoader.h>
+-#include <GNUstepGUI/GSNibCompatibility.h>
++#include <GNUstepGUI/GSNibLoading.h>
++#include <GNUstepGUI/GSGormLoading.h>
+
+ @interface GormNibWrapperLoader : GormWrapperLoader
+ {
diff --git a/devel/gorm/files/patch-GormPrivate.h b/devel/gorm/files/patch-GormPrivate.h
new file mode 100644
index 000000000000..712c08db0685
--- /dev/null
+++ b/devel/gorm/files/patch-GormPrivate.h
@@ -0,0 +1,13 @@
+--- GormCore/GormPrivate.h.orig 2007-11-06 00:44:36.000000000 +0100
++++ GormCore/GormPrivate.h 2008-12-23 09:27:03.000000000 +0100
+@@ -36,8 +36,8 @@
+ #include <GormCore/GormPalettesManager.h>
+ #include <GormCore/GormProtocol.h>
+ #include <GormCore/GormClassEditor.h>
+-#include <GNUstepGUI/GSNibTemplates.h>
+-#include <GNUstepGUI/GSNibCompatibility.h>
++#include <GNUstepGUI/GSNibLoading.h>
++#include <GNUstepGUI/GSGormLoading.h>
+
+ extern NSString *GormLinkPboardType;
+ extern NSString *GormToggleGuidelineNotification;