aboutsummaryrefslogtreecommitdiff
path: root/devel/got
diff options
context:
space:
mode:
authorChristian Weisgerber <naddy@FreeBSD.org>2023-01-30 18:01:27 +0000
committerChristian Weisgerber <naddy@FreeBSD.org>2023-01-30 18:01:27 +0000
commit124ad05ebceef478a6d98c05f4ddbb417c35dc19 (patch)
tree6834f895d9447af0f4746971fce58d263bae4d71 /devel/got
parent86bc0033ce5281f90e4a89686be9010376c6d9a7 (diff)
downloadports-124ad05ebceef478a6d98c05f4ddbb417c35dc19.tar.gz
ports-124ad05ebceef478a6d98c05f4ddbb417c35dc19.zip
Diffstat (limited to 'devel/got')
-rw-r--r--devel/got/Makefile2
-rw-r--r--devel/got/distinfo6
-rw-r--r--devel/got/files/patch-regress_cmdline_commit.sh13
-rw-r--r--devel/got/files/patch-regress_cmdline_histedit.sh19
4 files changed, 29 insertions, 11 deletions
diff --git a/devel/got/Makefile b/devel/got/Makefile
index b736f5bba8fa..76d7ceea7fe4 100644
--- a/devel/got/Makefile
+++ b/devel/got/Makefile
@@ -1,5 +1,5 @@
PORTNAME= got
-PORTVERSION= 0.82
+PORTVERSION= 0.83
CATEGORIES= devel
MASTER_SITES= https://gameoftrees.org/releases/
diff --git a/devel/got/distinfo b/devel/got/distinfo
index 4b1d20e1f868..754eb40d919e 100644
--- a/devel/got/distinfo
+++ b/devel/got/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1674473954
-SHA256 (got-0.82.tar.gz) = daea3ff3622667fa99f23ecce9a3d2db169d3c7c51627c4f4fec79882ba16190
-SIZE (got-0.82.tar.gz) = 785741
+TIMESTAMP = 1675095574
+SHA256 (got-0.83.tar.gz) = 4f372bc41a34473de2204e694d05a0d896571a0dcb1ffcef402f8bad3f7988c2
+SIZE (got-0.83.tar.gz) = 795432
diff --git a/devel/got/files/patch-regress_cmdline_commit.sh b/devel/got/files/patch-regress_cmdline_commit.sh
index d3187079463d..6113f815e739 100644
--- a/devel/got/files/patch-regress_cmdline_commit.sh
+++ b/devel/got/files/patch-regress_cmdline_commit.sh
@@ -1,6 +1,6 @@
---- regress/cmdline/commit.sh.orig 2022-07-02 13:23:44 UTC
+--- regress/cmdline/commit.sh.orig 2023-01-30 08:56:03 UTC
+++ regress/cmdline/commit.sh
-@@ -1380,7 +1380,7 @@ test_commit_prepared_logmsg() {
+@@ -1492,7 +1492,7 @@ test_commit_prepared_logmsg() {
cat > $testroot/editor.sh <<EOF
#!/bin/sh
@@ -9,3 +9,12 @@
EOF
chmod +x $testroot/editor.sh
+@@ -1755,7 +1755,7 @@ test_commit_logmsg_ref() {
+
+ cat > $testroot/editor.sh <<EOF
+ #!/bin/sh
+-sed -i 's/# l/l/' "\$1"
++sed -i '' 's/# l/l/' "\$1"
+ EOF
+ chmod +x $testroot/editor.sh
+
diff --git a/devel/got/files/patch-regress_cmdline_histedit.sh b/devel/got/files/patch-regress_cmdline_histedit.sh
index d56397895a19..fa6d904094fb 100644
--- a/devel/got/files/patch-regress_cmdline_histedit.sh
+++ b/devel/got/files/patch-regress_cmdline_histedit.sh
@@ -1,6 +1,6 @@
---- regress/cmdline/histedit.sh.orig 2022-01-19 10:29:31 UTC
+--- regress/cmdline/histedit.sh.orig 2023-01-29 10:30:53 UTC
+++ regress/cmdline/histedit.sh
-@@ -1565,7 +1565,7 @@ test_histedit_fold_only() {
+@@ -1564,7 +1564,7 @@ test_histedit_fold_only() {
cat > $testroot/editor.sh <<EOF
#!/bin/sh
@@ -9,7 +9,7 @@
EOF
chmod +x $testroot/editor.sh
-@@ -1681,7 +1681,7 @@ test_histedit_fold_only_empty_logmsg() {
+@@ -1680,7 +1680,7 @@ test_histedit_fold_only_empty_logmsg() {
cat > $testroot/editor.sh <<EOF
#!/bin/sh
@@ -18,7 +18,7 @@
EOF
chmod +x $testroot/editor.sh
-@@ -1815,7 +1815,7 @@ test_histedit_edit_only() {
+@@ -1814,7 +1814,7 @@ test_histedit_edit_only() {
cat > $testroot/editor.sh <<EOF
#!/bin/sh
@@ -27,7 +27,7 @@
EOF
chmod +x $testroot/editor.sh
-@@ -1844,7 +1844,7 @@ EOF
+@@ -1843,7 +1843,7 @@ EOF
cat > $testroot/editor.sh <<EOF
#!/bin/sh
@@ -36,3 +36,12 @@
EOF
chmod +x $testroot/editor.sh
+@@ -2239,7 +2239,7 @@ test_histedit_mesg_filemode_change() {
+
+ cat > $testroot/editor.sh <<EOF
+ #!/bin/sh
+-sed -i 's/ x bit / executable bit /' "\$1"
++sed -i '' 's/ x bit / executable bit /' "\$1"
+ EOF
+
+ chmod +x $testroot/editor.sh