aboutsummaryrefslogtreecommitdiff
path: root/devel/gsoap
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2014-10-14 17:47:34 +0000
committerPawel Pekala <pawel@FreeBSD.org>2014-10-14 17:47:34 +0000
commitd90b0c4e22c3749843666a07e9ad4e713819b957 (patch)
tree5125d83b19c095f14e59d9f4cccd4a77df607f84 /devel/gsoap
parent3d2a3256c480cfa32025b66832588a52f9f79977 (diff)
downloadports-d90b0c4e22c3749843666a07e9ad4e713819b957.tar.gz
ports-d90b0c4e22c3749843666a07e9ad4e713819b957.zip
Notes
Diffstat (limited to 'devel/gsoap')
-rw-r--r--devel/gsoap/Makefile25
-rw-r--r--devel/gsoap/distinfo4
-rw-r--r--devel/gsoap/files/patch-gsoap_wsdl_Makefile.in (renamed from devel/gsoap/files/patch-gsoap__wsdl__Makefile.in)10
-rw-r--r--devel/gsoap/pkg-plist34
4 files changed, 42 insertions, 31 deletions
diff --git a/devel/gsoap/Makefile b/devel/gsoap/Makefile
index 7933c7bdbb39..9f96021ff305 100644
--- a/devel/gsoap/Makefile
+++ b/devel/gsoap/Makefile
@@ -2,13 +2,12 @@
# $FreeBSD$
PORTNAME= gsoap
-PORTVERSION= 2.8.17
-PORTREVISION= 3
+PORTVERSION= 2.8.18
CATEGORIES= devel
MASTER_SITES= SF/${PORTNAME}2/gSOAP
DISTNAME= ${PORTNAME}_${PORTVERSION}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= 5u623l20@gmail.com
COMMENT= Generator Tools for Coding SOAP/XML Web Services in C and C++
LICENSE= GPLv2
@@ -22,20 +21,12 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:R}
OPTIONS_RADIO= SSL
OPTIONS_RADIO_SSL= GNUTLS OPENSSL
OPTIONS_DEFAULT= OPENSSL
-
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MGNUTLS}
-LIB_DEPENDS= libgnutls.so:${PORTSDIR}/security/gnutls \
- libgcrypt.so:${PORTSDIR}/security/libgcrypt \
- libgpg-error.so:${PORTSDIR}/security/libgpg-error
-CONFIGURE_ARGS= --enable-gnutls
-LDFLAGS+= -L${LOCALBASE}/lib
-.elif ${PORT_OPTIONS:MOPENSSL}
-CONFIGURE_ARGS= --enable-ssl
-.else
-CONFIGURE_ARGS= --disable-ssl
-.endif
+GNUTLS_LIB_DEPENDS= libgnutls.so:${PORTSDIR}/security/gnutls \
+ libgcrypt.so:${PORTSDIR}/security/libgcrypt \
+ libgpg-error.so:${PORTSDIR}/security/libgpg-error
+GNUTLS_CONFIGURE_ON= --enable-gnutls
+GNUTLS_LDFLAGS= -L${LOCALBASE}/lib
+OPENSSL_CONFIGURE_ENABLE= ssl
post-patch:
${REINPLACE_CMD} -e 's| sys/timeb.h | |' \
diff --git a/devel/gsoap/distinfo b/devel/gsoap/distinfo
index 220229c6ee41..9ca5d7e4058e 100644
--- a/devel/gsoap/distinfo
+++ b/devel/gsoap/distinfo
@@ -1,2 +1,2 @@
-SHA256 (gsoap_2.8.17.zip) = 30a53785708c842694227753badda17010cac64efd43f7a4f2b0e8de3de68f28
-SIZE (gsoap_2.8.17.zip) = 20695905
+SHA256 (gsoap_2.8.18.zip) = 764281a67020b7b7b982ddf8e7fdffae27f7a3e61af9ab4ec8a4705a67ba7ced
+SIZE (gsoap_2.8.18.zip) = 20596233
diff --git a/devel/gsoap/files/patch-gsoap__wsdl__Makefile.in b/devel/gsoap/files/patch-gsoap_wsdl_Makefile.in
index 1004dd9ce45f..2e3e20cb747c 100644
--- a/devel/gsoap/files/patch-gsoap__wsdl__Makefile.in
+++ b/devel/gsoap/files/patch-gsoap_wsdl_Makefile.in
@@ -1,11 +1,11 @@
---- gsoap/wsdl/Makefile.in 2013-12-18 14:58:38.000000000 -0500
-+++ gsoap/wsdl/Makefile.in 2014-01-16 14:35:52.000000000 -0500
-@@ -204,7 +204,7 @@
+--- gsoap/wsdl/Makefile.in.orig 2014-10-09 00:09:14.631256099 +0600
++++ gsoap/wsdl/Makefile.in 2014-10-09 00:09:33.119255143 +0600
+@@ -303,7 +303,7 @@
BUILT_SOURCES = $(SOAP_CPP_SRC)
wsdl2h_CFLAGS = $(C_DEBUG_FLAGS) $(WSDL2H_EXTRA_FLAGS)
- wsdl2h_CXXFLAGS = $(C_DEBUG_FLAGS) $(WSDL2H_EXTRA_FLAGS)
+ wsdl2h_CXXFLAGS = $(C_DEBUG_FLAGS) $(WSDL2H_EXTRA_FLAGS) $(WSDL2H_IMPORTPATH)
-wsdl2h_CPPFLAGS = $(AM_CPPFLAGS) $(SOAPCPP2_NONAMESPACES) -D$(platform)
+wsdl2h_CPPFLAGS = $(AM_CPPFLAGS) $(SOAPCPP2_NONAMESPACES) $(WSDL2H_IMPORTPATH) -D$(platform)
- wsdl2h_SOURCES = wsdl2h.cpp wsdl.cpp schema.cpp types.cpp service.cpp soap.cpp mime.cpp wsp.cpp $(SOAP_CPP_SRC)
+ wsdl2h_SOURCES = wsdl2h.cpp wsdl.cpp schema.cpp types.cpp service.cpp soap.cpp mime.cpp wsp.cpp bpel.cpp $(SOAP_CPP_SRC)
wsdl2h_LDADD = $(SOAP_CPP_LIB) $(WSDL2H_EXTRA_LIBS)
CLEANFILES = *~ *C.cpp *H.h *Stub.h *.nsmap
diff --git a/devel/gsoap/pkg-plist b/devel/gsoap/pkg-plist
index c0b6df593ccb..99a6ddd4e354 100644
--- a/devel/gsoap/pkg-plist
+++ b/devel/gsoap/pkg-plist
@@ -15,6 +15,7 @@ libdata/pkgconfig/gsoapck++.pc
libdata/pkgconfig/gsoapck.pc
libdata/pkgconfig/gsoapssl++.pc
libdata/pkgconfig/gsoapssl.pc
+%%DATADIR%%/WS/LEGAL.txt
%%DATADIR%%/WS/README.txt
%%DATADIR%%/WS/WS-Addressing.xsd
%%DATADIR%%/WS/WS-Addressing03.xsd
@@ -37,6 +38,11 @@ libdata/pkgconfig/gsoapssl.pc
%%DATADIR%%/WS/enumeration.xsd
%%DATADIR%%/WS/reference-1.1.xsd
%%DATADIR%%/WS/typemap.dat
+%%DATADIR%%/WS/ws-bpel_abstract_common_base.xsd
+%%DATADIR%%/WS/ws-bpel_executable.xsd
+%%DATADIR%%/WS/ws-bpel_plnktype.xsd
+%%DATADIR%%/WS/ws-bpel_serviceref.xsd
+%%DATADIR%%/WS/ws-bpel_varprop.xsd
%%DATADIR%%/WS/ws-reliability-1.1.xsd
%%DATADIR%%/WS/wsse.xsd
%%DATADIR%%/WS/wsu.xsd
@@ -50,6 +56,9 @@ libdata/pkgconfig/gsoapssl.pc
%%DATADIR%%/custom/struct_timeval.h
%%DATADIR%%/custom/struct_tm.c
%%DATADIR%%/custom/struct_tm.h
+%%DATADIR%%/custom/wsrmdemo-duration.o
+%%DATADIR%%/custom/wsrmdemo_ssl-duration.o
+%%DATADIR%%/custom/wsrmdemo_udp-duration.o
%%DATADIR%%/extras/README.txt
%%DATADIR%%/extras/ckdb.c
%%DATADIR%%/extras/ckdb.h
@@ -66,6 +75,7 @@ libdata/pkgconfig/gsoapssl.pc
%%DATADIR%%/import/dom.h
%%DATADIR%%/import/ds.h
%%DATADIR%%/import/ds2.h
+%%DATADIR%%/import/plnk.h
%%DATADIR%%/import/ref.h
%%DATADIR%%/import/ser.h
%%DATADIR%%/import/soap12.h
@@ -75,6 +85,7 @@ libdata/pkgconfig/gsoapssl.pc
%%DATADIR%%/import/stllist.h
%%DATADIR%%/import/stlset.h
%%DATADIR%%/import/stlvector.h
+%%DATADIR%%/import/vprop.h
%%DATADIR%%/import/wsa.h
%%DATADIR%%/import/wsa3.h
%%DATADIR%%/import/wsa4.h
@@ -119,6 +130,7 @@ libdata/pkgconfig/gsoapssl.pc
%%DATADIR%%/plugin/httpform.h
%%DATADIR%%/plugin/httpget.c
%%DATADIR%%/plugin/httpget.h
+%%DATADIR%%/plugin/httpget.o
%%DATADIR%%/plugin/httpgettest.c
%%DATADIR%%/plugin/httpgettest.h
%%DATADIR%%/plugin/httpmd5.c
@@ -127,6 +139,7 @@ libdata/pkgconfig/gsoapssl.pc
%%DATADIR%%/plugin/httpmd5test.h
%%DATADIR%%/plugin/httppost.c
%%DATADIR%%/plugin/httppost.h
+%%DATADIR%%/plugin/httppost.o
%%DATADIR%%/plugin/httpposttest.c
%%DATADIR%%/plugin/httpposttest.h
%%DATADIR%%/plugin/logging.c
@@ -141,23 +154,30 @@ libdata/pkgconfig/gsoapssl.pc
%%DATADIR%%/plugin/plugin.h
%%DATADIR%%/plugin/smdevp.c
%%DATADIR%%/plugin/smdevp.h
+%%DATADIR%%/plugin/sslserver-threads.o
%%DATADIR%%/plugin/threads.c
%%DATADIR%%/plugin/threads.h
%%DATADIR%%/plugin/wsaapi.c
%%DATADIR%%/plugin/wsaapi.h
+%%DATADIR%%/plugin/wsademo-wsaapi.o
%%DATADIR%%/plugin/wsddapi.c
%%DATADIR%%/plugin/wsddapi.h
%%DATADIR%%/plugin/wsrmapi.c
%%DATADIR%%/plugin/wsrmapi.h
+%%DATADIR%%/plugin/wsrmdemo-threads.o
+%%DATADIR%%/plugin/wsrmdemo-wsaapi.o
+%%DATADIR%%/plugin/wsrmdemo-wsrmapi.o
+%%DATADIR%%/plugin/wsrmdemo_ssl-threads.o
+%%DATADIR%%/plugin/wsrmdemo_ssl-wsaapi.o
+%%DATADIR%%/plugin/wsrmdemo_ssl-wsrmapi.o
+%%DATADIR%%/plugin/wsrmdemo_udp-threads.o
+%%DATADIR%%/plugin/wsrmdemo_udp-wsaapi.o
+%%DATADIR%%/plugin/wsrmdemo_udp-wsrmapi.o
%%DATADIR%%/plugin/wsse2api.c
%%DATADIR%%/plugin/wsse2api.h
%%DATADIR%%/plugin/wsseapi.c
%%DATADIR%%/plugin/wsseapi.cpp
%%DATADIR%%/plugin/wsseapi.h
-@dirrm lib/gsoap
-@dirrm %%DATADIR%%/plugin
-@dirrm %%DATADIR%%/import
-@dirrm %%DATADIR%%/extras
-@dirrm %%DATADIR%%/custom
-@dirrm %%DATADIR%%/WS
-@dirrm %%DATADIR%%
+%%DATADIR%%/plugin/wssedemo-mecevp.o
+%%DATADIR%%/plugin/wssedemo-smdevp.o
+%%DATADIR%%/plugin/wssedemo-wsseapi.o