aboutsummaryrefslogtreecommitdiff
path: root/devel/gsoap
diff options
context:
space:
mode:
authorSergey Matveychuk <sem@FreeBSD.org>2012-05-03 18:55:48 +0000
committerSergey Matveychuk <sem@FreeBSD.org>2012-05-03 18:55:48 +0000
commit6c7f64dae666036a2260afeac199d375111f5ebd (patch)
tree4e57191bbc78ef747d4a6e36f169ccc612248633 /devel/gsoap
parent6c577fda0457d005e9a54beee83f291af1d3afc5 (diff)
downloadports-6c7f64dae666036a2260afeac199d375111f5ebd.tar.gz
ports-6c7f64dae666036a2260afeac199d375111f5ebd.zip
Notes
Diffstat (limited to 'devel/gsoap')
-rw-r--r--devel/gsoap/Makefile27
-rw-r--r--devel/gsoap/distinfo4
-rw-r--r--devel/gsoap/pkg-plist16
3 files changed, 42 insertions, 5 deletions
diff --git a/devel/gsoap/Makefile b/devel/gsoap/Makefile
index 3b6b38b9e40a..529f19b89ce6 100644
--- a/devel/gsoap/Makefile
+++ b/devel/gsoap/Makefile
@@ -6,19 +6,25 @@
#
PORTNAME= gsoap
-PORTVERSION= 2.7.15
+PORTVERSION= 2.8.8
CATEGORIES= devel
-MASTER_SITES= SF/${PORTNAME}2/gSOAP/${PORTVERSION}%20stable
+MASTER_SITES= SF/${PORTNAME}2/gSOAP
DISTNAME= ${PORTNAME}_${PORTVERSION}
MAINTAINER= sem@FreeBSD.org
COMMENT= Generator Tools for Coding SOAP/XML Web Services in C and C++
+OPTIONS= OPENSSL "Enable SSL/TLS (OpenSSL from base)" on \
+ GNUTLS "Enable SSL/TLS (GnuTLS)" off
+
+USE_ZIP= yes
GNU_CONFIGURE= yes
USE_GNOME= gnomehack
MAKE_JOBS_UNSAFE= yes
+CFLAGS+= -DWSDL_TYPEMAP_FILE=\\\"${DATADIR}/WS/typemap.dat\\\" \
+ -DSOAPCPP2_IMPORT_PATH=\\\"${DATADIR}/import\\\"
-WRKSRC= ${WRKDIR}/${PORTNAME}-2.7
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:R}
ONLY_FOR_ARCHS= i386 amd64
@@ -28,6 +34,21 @@ ONLY_FOR_ARCHS= i386 amd64
CFLAGS+= -fPIC
.endif
+.if defined(WITHOUT_OPENSSL) && defined(WITHOUT_GNUTLS)
+CONFIGURE_ARGS+=--disable-ssl
+.endif
+
+.if defined(WITH_GNUTLS)
+LIB_DEPENDS+= gnutls.47:${PORTSDIR}/security/gnutls \
+ gcrypt.18:${PORTSDIR}/security/libgcrypt \
+ gpg-error.0:${PORTSDIR}/security/libgpg-error
+CONFIGURE_ARGS+=--enable-gnutls
+LDFLAGS+= -L${LOCALBASE}/lib
+.endif
+
+post-patch:
+ ${REINPLACE_CMD} -e 's|sys/timeb.h||' ${WRKSRC}/${CONFIGURE_SCRIPT}
+
post-install:
@${MKDIR} ${PREFIX}/lib/gsoap
@${CP} ${WRKSRC}/gsoap/stdsoap2.c ${PREFIX}/lib/gsoap
diff --git a/devel/gsoap/distinfo b/devel/gsoap/distinfo
index 5e7975c7d018..0bd9471ef47c 100644
--- a/devel/gsoap/distinfo
+++ b/devel/gsoap/distinfo
@@ -1,2 +1,2 @@
-SHA256 (gsoap_2.7.15.tar.gz) = 3ed883ab1a3d32b5bb2bf599306f247f6de3ffedd8890eb0e6303ae15995dc12
-SIZE (gsoap_2.7.15.tar.gz) = 6338478
+SHA256 (gsoap_2.8.8.zip) = 8b1ad1cbd521bd5f85ff4c038bfd5a17a2530610c1ce8bf7318725bc568465cc
+SIZE (gsoap_2.8.8.zip) = 13782549
diff --git a/devel/gsoap/pkg-plist b/devel/gsoap/pkg-plist
index 7c8bcb8ca8d6..5e10128580c3 100644
--- a/devel/gsoap/pkg-plist
+++ b/devel/gsoap/pkg-plist
@@ -23,9 +23,11 @@ libdata/pkgconfig/gsoapssl.pc
%%DATADIR%%/WS/WS-Discovery.wsdl
%%DATADIR%%/WS/WS-Enumeration.wsdl
%%DATADIR%%/WS/WS-Policy.xsd
+%%DATADIR%%/WS/WS-Policy12.xsd
%%DATADIR%%/WS/WS-ReliableMessaging.wsdl
%%DATADIR%%/WS/WS-ReliableMessaging.xsd
%%DATADIR%%/WS/WS-Routing.xsd
+%%DATADIR%%/WS/WS-SecurityPolicy.xsd
%%DATADIR%%/WS/WS-typemap.dat
%%DATADIR%%/WS/discovery.xsd
%%DATADIR%%/WS/ds.xsd
@@ -35,7 +37,10 @@ libdata/pkgconfig/gsoapssl.pc
%%DATADIR%%/WS/ws-reliability-1.1.xsd
%%DATADIR%%/WS/wsse.xsd
%%DATADIR%%/WS/wsu.xsd
+%%DATADIR%%/WS/xenc.xsd
%%DATADIR%%/custom/README.txt
+%%DATADIR%%/custom/duration.c
+%%DATADIR%%/custom/duration.h
%%DATADIR%%/custom/long_double.c
%%DATADIR%%/custom/long_double.h
%%DATADIR%%/custom/struct_timeval.c
@@ -70,14 +75,19 @@ libdata/pkgconfig/gsoapssl.pc
%%DATADIR%%/import/wsa3.h
%%DATADIR%%/import/wsa4.h
%%DATADIR%%/import/wsa5.h
+%%DATADIR%%/import/wsdd.h
+%%DATADIR%%/import/wsdd10.h
+%%DATADIR%%/import/wsdx.h
%%DATADIR%%/import/wsp.h
%%DATADIR%%/import/wsrm.h
%%DATADIR%%/import/wsrm4.h
%%DATADIR%%/import/wsrp.h
%%DATADIR%%/import/wsrx.h
%%DATADIR%%/import/wsse.h
+%%DATADIR%%/import/wsse11.h
%%DATADIR%%/import/wsse2.h
%%DATADIR%%/import/wsu.h
+%%DATADIR%%/import/xenc.h
%%DATADIR%%/import/xlink.h
%%DATADIR%%/import/xmime.h
%%DATADIR%%/import/xmime4.h
@@ -112,6 +122,8 @@ libdata/pkgconfig/gsoapssl.pc
%%DATADIR%%/plugin/logging.h
%%DATADIR%%/plugin/md5evp.c
%%DATADIR%%/plugin/md5evp.h
+%%DATADIR%%/plugin/mecevp.c
+%%DATADIR%%/plugin/mecevp.h
%%DATADIR%%/plugin/plugin.c
%%DATADIR%%/plugin/plugin.h
%%DATADIR%%/plugin/smdevp.c
@@ -120,6 +132,10 @@ libdata/pkgconfig/gsoapssl.pc
%%DATADIR%%/plugin/threads.h
%%DATADIR%%/plugin/wsaapi.c
%%DATADIR%%/plugin/wsaapi.h
+%%DATADIR%%/plugin/wsddapi.c
+%%DATADIR%%/plugin/wsddapi.h
+%%DATADIR%%/plugin/wsrmapi.c
+%%DATADIR%%/plugin/wsrmapi.h
%%DATADIR%%/plugin/wsse2api.c
%%DATADIR%%/plugin/wsse2api.h
%%DATADIR%%/plugin/wsseapi.c